summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordian Edenhofer2015-07-08 14:56:07 +0200
committerGordian Edenhofer2015-07-08 14:56:07 +0200
commit8660889efd8324f563e56a61e941f8ed6d85901d (patch)
treedecc5c44e88c729e615e1e38948240b6cdf4905f
downloadaur-8660889efd8324f563e56a61e941f8ed6d85901d.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aabf0bb19936
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = paper-gtk-theme-git
+ pkgdesc = A modern desktop theme suite. Its design is mostly flat with a minimal use of shadows for depth.
+ pkgver = 175.9b84bc5
+ pkgrel = 1
+ url = https://github.com/snwh/paper-gtk-theme
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gtk-engine-murrine
+ optdepends = python: scripts to simplify the rendering process
+ optdepends = inkscape: edit theme assets
+ source = paper-gtk-theme::git+https://github.com/snwh/paper-gtk-theme.git
+ md5sums = SKIP
+
+pkgname = paper-gtk-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..2bad775c3eb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gordian Edenhofer <gordian.edenhofer[at]yahoo[dot]de>
+# Submitter: Martin Wimpress <code@flexion.org>
+
+pkgname=paper-gtk-theme-git
+_pkgname=paper-gtk-theme
+pkgver=175.9b84bc5
+pkgrel=1
+pkgdesc="A modern desktop theme suite. Its design is mostly flat with a minimal use of shadows for depth."
+arch=('any')
+url="https://github.com/snwh/paper-gtk-theme"
+license=('GPL3')
+depends=('gtk-engine-murrine')
+optdepends=("python: scripts to simplify the rendering process"
+ "inkscape: edit theme assets")
+makedepends=('git')
+source=("${_pkgname}"::"git+https://github.com/snwh/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -dm755 "${pkgdir}"/usr/share/themes/Paper
+ install -dm755 "${pkgdir}"/usr/share/"${_pkgname}"
+
+ cp -dpr --no-preserve=ownership ./Paper "${pkgdir}"/usr/share/themes/
+ cp -dpr --no-preserve=ownership ./*.py "${pkgdir}"/usr/share/"${_pkgname}"
+ cp -dpr --no-preserve=ownership ./src "${pkgdir}"/usr/share/"${_pkgname}"
+}