summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTharre2015-06-23 22:07:19 +0200
committerTharre2015-06-23 22:10:20 +0200
commit16aba02b715181873575bd1b93d5ddc3355f5f43 (patch)
treed3ed26af350ab6e15e62386bb699e8a50e7413f4
parente65bb35a503aacd5e6bb7813f287a05876402d49 (diff)
downloadaur-16aba02b715181873575bd1b93d5ddc3355f5f43.tar.gz
Fix icon updating
-rw-r--r--PKGBUILD5
-rw-r--r--papersplease.install11
2 files changed, 15 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bb47c37a5e1..6160be913a0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,20 @@ pkgdesc="Assume the role of an immigration inspector for the communist state of
arch=('i686' 'x86_64')
url="http://papersplea.se"
license=('custom:commercial')
-depends=('hicolor-icon-theme')
+depends=('hicolor-icon-theme' 'xdg-utils')
depends_x86_64=('lib32-gcc-libs' 'lib32-libgl')
depends_i386=('gcc-libs' 'libgl')
+install=papersplease.install
options=(!strip)
source=("$pkgname.desktop"
"launch-$pkgname.sh"
"${pkgname}.png"
+ "${pkgname}.install"
"${_pkgname}_${pkgver}_i386.tar.gz::hib://${_pkgname}_${pkgver}_i386.tar.gz")
sha256sums=('478b736281d4d397bcff3972a548dc85bddae49342d561adefa25186310cd5ec'
'e199745f2158fd04fd70ce463aa57452be3a5d8c9c390970e2cadbe7d2122dd4'
'e8aaf890dbfa6363f0197892ca2abd5ac4a45918787a8524cf8c99d785000823'
+ '9b7837376b5ba5bfb46b2ffff6cab3d527fbe479694d097f4fbabe2bccca6f07'
'50562ad2b01cb7558147cd05de4dc37c02deb2e66fc5d3bff77994785f9551d7')
# Disable compression of the package
diff --git a/papersplease.install b/papersplease.install
new file mode 100644
index 000000000000..97fda5a9615b
--- /dev/null
+++ b/papersplease.install
@@ -0,0 +1,11 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor 2> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}