summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTharre2015-06-08 14:09:53 +0200
committerTharre2015-06-08 14:10:29 +0200
commita4cc83d8eca15da0022113a7a8c954f89a76f31b (patch)
tree14ea77cfb2f4b40875c9a221d384a0a43bccaba0
downloadaur-a4cc83d8eca15da0022113a7a8c954f89a76f31b.tar.gz
Move to new AUR
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD90
-rw-r--r--launch-papersplease.sh5
-rw-r--r--papersplease.desktop11
-rw-r--r--papersplease.pngbin0 -> 2307 bytes
6 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b611889cace9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = papersplease
+ pkgdesc = Assume the role of an immigration inspector for the communist state of Arstotzka
+ pkgver = 1.1.65
+ pkgrel = 5
+ url = http://papersplea.se
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ depends = sh
+ depends = hicolor-icon-theme
+ options = !strip
+ source = papersplease.desktop
+ source = launch-papersplease.sh
+ source = papersplease.png
+ source = papers-please_1.1.65_i386.tar.gz::hib://papers-please_1.1.65_i386.tar.gz
+ sha256sums = 478b736281d4d397bcff3972a548dc85bddae49342d561adefa25186310cd5ec
+ sha256sums = e199745f2158fd04fd70ce463aa57452be3a5d8c9c390970e2cadbe7d2122dd4
+ sha256sums = e8aaf890dbfa6363f0197892ca2abd5ac4a45918787a8524cf8c99d785000823
+ sha256sums = 50562ad2b01cb7558147cd05de4dc37c02deb2e66fc5d3bff77994785f9551d7
+ depends_x86_64 = lib32-gcc-libs
+ depends_x86_64 = lib32-libgl
+
+pkgname = papersplease
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..453ed145e84b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+papers-please_*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d71b38a3825
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer: Tharre <tharre3@gmail.com>
+# Contributor: Alex Szczuczko <alex at szc dot ca>
+
+pkgname=papersplease
+_pkgname=papers-please
+pkgver=1.1.65
+pkgrel=5
+pkgdesc="Assume the role of an immigration inspector for the communist state of Arstotzka"
+arch=('i686' 'x86_64')
+url="http://papersplea.se"
+license=('custom:commercial')
+depends=('sh' 'hicolor-icon-theme')
+depends_x86_64=('lib32-gcc-libs' 'lib32-libgl')
+depends_i386=('gcc-libs' 'libgl')
+options=(!strip)
+source=("$pkgname.desktop"
+ "launch-$pkgname.sh"
+ "${pkgname}.png"
+ "${_pkgname}_${pkgver}_i386.tar.gz::hib://${_pkgname}_${pkgver}_i386.tar.gz")
+sha256sums=('478b736281d4d397bcff3972a548dc85bddae49342d561adefa25186310cd5ec'
+ 'e199745f2158fd04fd70ce463aa57452be3a5d8c9c390970e2cadbe7d2122dd4'
+ 'e8aaf890dbfa6363f0197892ca2abd5ac4a45918787a8524cf8c99d785000823'
+ '50562ad2b01cb7558147cd05de4dc37c02deb2e66fc5d3bff77994785f9551d7')
+
+# Disable compression of the package
+PKGEXT='.pkg.tar'
+
+# You can download the Humble Indie Bundle file manually, or you can configure
+# DLAGENTS in makepkg.conf to auto-download.
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+package() {
+ cd "$srcdir/papers-please/"
+
+ #
+ # Create /opt/$pkgname directory
+ #
+
+ # Binaries
+ install -m755 -d "$pkgdir/opt/$pkgname/"
+ install -m755 -t "$pkgdir/opt/$pkgname/" "PapersPlease" "lime.ndll" "regexp.dso" "std.dso" "zlib.dso"
+
+ # Launcher
+ install -m755 -t "$pkgdir/opt/$pkgname/" "$srcdir/launch-$pkgname.sh"
+
+ # Text/config files
+ install -m644 -t "$pkgdir/opt/$pkgname/" "boot.xml" "LICENSE" "manifest" "README"
+
+ # i18n
+ install -m755 -d "$pkgdir/opt/$pkgname/loc/"
+ find "loc/" -type f -name '*.zip' -print0 | \
+ xargs -0 install -m644 -t "$pkgdir/opt/$pkgname/loc/"
+
+ # Assets
+ install -m755 -d "$pkgdir/opt/$pkgname/assets/"
+ find "assets/" -maxdepth 1 -type f -print0 | \
+ xargs -0 install -m644 -t "$pkgdir/opt/$pkgname/assets/"
+
+ # Music
+ install -m755 -d "$pkgdir/opt/$pkgname/assets/music/"
+ find "assets/music/" -maxdepth 1 -type f -print0 | \
+ xargs -0 install -m644 -t "$pkgdir/opt/$pkgname/assets/music/"
+
+ # Sound
+ install -m755 -d "$pkgdir/opt/$pkgname/assets/sound/"
+ find "assets/sound/" -type f -name "*.wav" -print0 | \
+ xargs -0 install -m644 -t "$pkgdir/opt/$pkgname/assets/sound/"
+
+
+ #
+ # System integration
+ #
+
+ # /bin
+ install -m755 -d "$pkgdir/usr/bin/"
+ ln -s "/opt/$pkgname/launch-$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+
+ # License
+ install -m755 -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s "/opt/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Icon
+ #install -Dm644 $pkgname.png "$pkgdir/usr/share/icons/128x128/apps/$pkgname.png"
+ install -m755 -d "${pkgdir}/usr/share/icons/hicolor/128x128/apps"
+ install -m644 "${srcdir}/${pkgname}.png" "${pkgdir}/usr/share/icons/hicolor/128x128/apps"
+
+ # .desktop File
+ install -m755 -d "$pkgdir/usr/share/applications/"
+ install -m644 -t "$pkgdir/usr/share/applications/" "$srcdir/$pkgname.desktop"
+}
diff --git a/launch-papersplease.sh b/launch-papersplease.sh
new file mode 100644
index 000000000000..bb9e4b25c43f
--- /dev/null
+++ b/launch-papersplease.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+DIR="/opt/papersplease"
+export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR"
+cd "$DIR"
+exec ./PapersPlease "$@"
diff --git a/papersplease.desktop b/papersplease.desktop
new file mode 100644
index 000000000000..944bbb486800
--- /dev/null
+++ b/papersplease.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Icon=/usr/share/icons/hicolor/128x128/apps/papersplease.png
+Exec=/usr/bin/papersplease
+Terminal=false
+StartupNotify=false
+
+Name=Papers Please
+Comment=Assume the role of an immigration inspector for the communist state of Arstotzka
+
+Categories=Game; \ No newline at end of file
diff --git a/papersplease.png b/papersplease.png
new file mode 100644
index 000000000000..b5a5bfae9661
--- /dev/null
+++ b/papersplease.png
Binary files differ