summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmos Ng2022-12-19 22:11:42 +0800
committerAmos Ng2022-12-19 22:11:42 +0800
commit9af5bcd4fd8a0e5a7b6228e706bbdac50f1f5915 (patch)
tree8f9e60d141152b6406c9806f60bcc249c29f174e
parent45d3c0582c6748f6ecd6dc91e91df3687858b3c1 (diff)
downloadaur-9af5bcd4fd8a0e5a7b6228e706bbdac50f1f5915.tar.gz
Fixed installation
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68c7eb171205..c7e7eb554878 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,10 @@ pkgdesc="Cross-platform TCP port testing, emulating the functionality of ping (p
arch=('x86_64')
url="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/paping"
license=('MIT')
-source=(${pkgname}-${pkgver}.tar.gz::${url}/paping_${pkgver}_${arch}_linux.tar.gz)
-b2sums=('75ab976318ceb69ab5c28d5861d7e21b994585ac90e11d9378789450aeed0e493d1a978bea42d131509125b437ba3f2123d4cd2530ee13a0ec1b867a791a4bfb')
+source=(${pkgname}-${pkgver}.tar.gz::${url}/${pkgname%-bin}_${pkgver}_x86-64_linux.tar.gz)
+b2sums=('2857200a5b3593add689dd060d3ca7e707158c9e7680fd3081d7f19ef3734e1789faf254f8e22b599089781a1f94e3b2ddfb21adf30e989d0e5eb2dcbfd70418')
package() {
- install -Dm755 ./paping -t "${pkgdir}/usr/bin/paping"
+ cd "$srcdir/"
+ install -Dm755 "./${pkgname%-bin}" -t "${pkgdir}/usr/bin"
}