summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-07-15 07:58:14 +0430
committerMohammadreza Abdollahzadeh2017-07-15 07:58:14 +0430
commit591c882cb657734ccc91f109bd400db28f0ab2b1 (patch)
tree5a2b4b046b72999b1cfcb2c06bcbf427768dca03
downloadaur-591c882cb657734ccc91f109bd400db28f0ab2b1.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..079874b2e289
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jul 15 03:28:02 UTC 2017
+pkgbase = papirus-claws-mail-theme-git
+ pkgdesc = Papirus theme for Claws Mail (git version)
+ pkgver = 20170629
+ pkgrel = 1
+ url = https://github.com/PapirusDevelopmentTeam/papirus-claws-mail-theme
+ arch = any
+ license = LGPL3
+ makedepends = git
+ depends = claws-mail
+ conflicts = papirus-claws-mail-theme
+ conflicts = claws-mail-papirus-theme
+ conflicts = claws-mail-papirus-theme-git
+ options = !strip
+ source = papirus-claws-mail-theme-git::git+https://github.com/PapirusDevelopmentTeam/papirus-claws-mail-theme.git
+ sha256sums = SKIP
+
+pkgname = papirus-claws-mail-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..786f470bd224
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+pkgname=papirus-claws-mail-theme-git
+pkgver=20170629
+pkgrel=1
+pkgdesc="Papirus theme for Claws Mail (git version)"
+url="https://github.com/PapirusDevelopmentTeam/${pkgname%-git}"
+arch=('any')
+license=('LGPL3')
+depends=('claws-mail')
+makedepends=('git')
+conflicts=('papirus-claws-mail-theme' 'claws-mail-papirus-theme' 'claws-mail-papirus-theme-git')
+options=('!strip')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+package() {
+ cd $pkgname
+ install -d $pkgdir/usr/share/claws-mail/themes
+ cp -a ./{ePapirus,Papirus{,-{Light,Dark}}} $pkgdir/usr/share/claws-mail/themes/
+}