summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2016-06-03 18:10:44 +0200
committerFadeMind2016-06-03 18:10:44 +0200
commit6be8556c3ec58399704e44da5373ba1198de82d2 (patch)
treebc2bb49430aaee2152cbc177f5cfb7e3b866cbde
parent4923317121238b38a85fc171ff2fb0d418e0929f (diff)
downloadaur-6be8556c3ec58399704e44da5373ba1198de82d2.tar.gz
update
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD34
3 files changed, 35 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20d6f04f23e7..91c5d50beb57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Jun 3 16:10:44 UTC 2016
pkgbase = papirus-color-scheme
- pkgdesc = Modified and adaptive Paper color scheme for KDE
- pkgver = 20151004
+ pkgdesc = Papirus color scheme for KDE
+ pkgver = 20160601
pkgrel = 1
- url = https://github.com/varlesh/papirus-pack-kde
+ url = https://github.com/PapirusDevelopmentTeam/papirus-color-scheme
arch = any
- license = CCPL:by-sa
+ license = GPL
+ makedepends = git
+ makedepends = make
+ depends = plasma-desktop
+ conflicts = papirus-color-scheme-git
options = !strip
- source = papirus-pack-kde-20151004.tar.gz::https://github.com/varlesh/papirus-pack-kde/archive/3f97691234d1688ad54b94d9b81f9ef181b0d8e9.tar.gz
- sha256sums = 87e2b1cbb0e08588a231d5c2638926de7ba566c5c0df81f4a897f95b54957f63
+ source = papirus-color-scheme::git+https://github.com/PapirusDevelopmentTeam/papirus-color-scheme.git#commit=3048aea
+ sha256sums = SKIP
pkgname = papirus-color-scheme
diff --git a/.gitignore b/.gitignore
index 4406c5231a4f..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,15 +1,4 @@
-
-### ArchLinuxPackages
-*.tar
-*.tar.*
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-pkg/
-src/
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index aa376fb0e9ae..b07935811600 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
-# Maintainer: Grigorii Horos <horosgrisa@gmail.com>
+# Maintainer: FadeMind <fademind@gmail.com>
-_git=3f97691234d1688ad54b94d9b81f9ef181b0d8e9
-_repo=papirus-pack-kde
pkgname=papirus-color-scheme
-pkgver=20151004
+_commit=3048aea # 7 digits
+pkgver=20160601
pkgrel=1
-pkgdesc="Modified and adaptive Paper color scheme for KDE"
+pkgdesc="Papirus color scheme for KDE"
+url="https://github.com/PapirusDevelopmentTeam/${pkgname}"
arch=('any')
-url="https://github.com/varlesh/${_repo}"
-license=('CCPL:by-sa')
+license=('GPL')
+depends=('plasma-desktop')
+makedepends=('git' 'make')
+conflicts=('papirus-color-scheme-git')
options=('!strip')
-source=("${_repo}-${pkgver}.tar.gz::${url}/archive/${_git}.tar.gz")
-sha256sums=('87e2b1cbb0e08588a231d5c2638926de7ba566c5c0df81f4a897f95b54957f63')
+source=("${pkgname}::git+${url}.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
package() {
- install -d ${pkgdir}/usr/share/color-schemes
- cp -r ${srcdir}/${_repo}-${_git}/color-schemes/Papirus* ${pkgdir}/usr/share/color-schemes/
- install -D -m644 ${srcdir}/${_repo}-${_git}/color-schemes/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- find ${pkgdir}/usr -type f -exec chmod 644 {} \;
- find ${pkgdir}/usr -type d -exec chmod 755 {} \;
-} \ No newline at end of file
+ cd ${pkgname}
+ make install DESTDIR="$pkgdir"
+}