summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-06-15 14:36:16 +1200
committercaltlgin2020-06-15 14:36:16 +1200
commita351bf72f7fa6d80296963c2b2b84afb5729d421 (patch)
tree50c1c1f9aa1a9f58c3831b415498eb7366003abc
parent8863f6562fb5f986df76b79a61bf9f209ea3fb12 (diff)
downloadaur-a351bf72f7fa6d80296963c2b2b84afb5729d421.tar.gz
Clean PKGBUILD in lines with packaging guidelines
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7181b9733393..b6c31ff18fb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
pkgbase = papirus-filezilla-themes
pkgdesc = Papirus icon theme for Filezilla
pkgver = 20200105
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/PapirusDevelopmentTeam/papirus-filezilla-themes
arch = any
license = GPL3
depends = filezilla
- provides = papirus-filezilla-themes
- conflicts = papirus-filezilla-themes
- conflicts = papirus-filezilla-themes-git
source = https://github.com/PapirusDevelopmentTeam/papirus-filezilla-themes/archive/20200105.tar.gz
sha256sums = 28e28c50b6b500b522f78590ce442e2ed93c5c2bd7a169ee1d31ab588af92427
diff --git a/PKGBUILD b/PKGBUILD
index bd36fcf0da93..d4859aab6874 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,22 @@
pkgname=papirus-filezilla-themes
pkgver=20200105
-pkgrel=1
-pkgdesc="Papirus icon theme for Filezilla"
+pkgrel=2
+pkgdesc='Papirus icon theme for Filezilla'
arch=('any')
-url="https://github.com/PapirusDevelopmentTeam/${pkgname}"
+url='https://github.com/PapirusDevelopmentTeam/papirus-filezilla-themes'
license=('GPL3')
-source=("https://github.com/PapirusDevelopmentTeam/${pkgname}/archive/${pkgver}.tar.gz")
depends=('filezilla')
-provides=("${pkgname}")
-conflicts=("${pkgname}" "${pkgname}-git")
+source=("${url}/archive/${pkgver}.tar.gz")
sha256sums=('28e28c50b6b500b522f78590ce442e2ed93c5c2bd7a169ee1d31ab588af92427')
+build() {
+ make -C "${pkgname}-${pkgver}"
+}
+
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
- install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ make DESTDIR="${pkgdir}" -C "${pkgname}-${pkgver}" install
+ install -Dm644 "${pkgname}-${pkgver}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file