summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2016-12-07 13:56:24 +0330
committerMohammadreza Abdollahzadeh2016-12-07 13:56:24 +0330
commitc994d58121f84828aa3ffbd082bd8bfca42e4034 (patch)
treed3caa7383dbae9ed46d6e134938d8826f280b43a
downloadaur-c994d58121f84828aa3ffbd082bd8bfca42e4034.tar.gz
Initial import.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD26
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..225c093d6897
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Dec 7 10:25:23 UTC 2016
+pkgbase = papirus-filezilla-themes-git
+ pkgdesc = Papirus theme for Filezilla (git version)
+ pkgver = 20161127
+ pkgrel = 1
+ url = https://github.com/PapirusDevelopmentTeam/papirus-filezilla-themes
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = filezilla
+ conflicts = papirus-filezilla-theme
+ conflicts = filezilla-papirus-theme
+ conflicts = filezilla-papirus-theme-git
+ options = !strip
+ source = papirus-filezilla-themes-git::git+https://github.com/PapirusDevelopmentTeam/papirus-filezilla-themes.git
+ sha256sums = SKIP
+
+pkgname = papirus-filezilla-themes-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dfa7ec6a436
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=papirus-filezilla-themes-git
+pkgver=20161127
+pkgrel=1
+pkgdesc="Papirus theme for Filezilla (git version)"
+url="https://github.com/PapirusDevelopmentTeam/${pkgname%-git}"
+arch=('any')
+license=('GPL')
+depends=('filezilla')
+makedepends=('git')
+conflicts=('papirus-filezilla-theme' 'filezilla-papirus-theme' 'filezilla-papirus-theme-git')
+options=('!strip')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+package() {
+ cd $pkgname
+ install -d $pkgdir/usr/share/filezilla/resources
+ cp -a ./{papirus,papirus-dark} $pkgdir/usr/share/filezilla/resources/
+}