summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorItzSelenux2021-04-13 21:59:14 -0500
committerItzSelenux2021-04-13 21:59:14 -0500
commit6cfa7ff5a73885449804ffaf97329f87c9400aa0 (patch)
treed8f44dee7a634b796698165ff3c8dfc7d0ce8d38
downloadaur-6cfa7ff5a73885449804ffaf97329f87c9400aa0.tar.gz
An Extra section was added
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--papirus-folders-gui.hook11
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..28f83ec15e02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = papirus-folders-gui
+ pkgdesc = change the folders color of the Papirus icon theme
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/ItzSelenux/papirus-folders-gui
+ arch = any
+ license = LGPL2
+ makedepends = git
+ depends = polkit-gnome
+ depends = papirus-folders
+ provides = papirus-folders-gui
+ source = papirus-folders-gui::git+https://github.com/ItzSelenux/papirus-folders-gui.git
+ source = papirus-folders-gui.hook
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = papirus-folders-gui
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3670d0379698
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: ItzSelenux <zariepcommunication@gmail.com>
+
+pkgname=papirus-folders-gui
+pkgver=1.2
+pkgrel=1
+pkgdesc="change the folders color of the Papirus icon theme"
+url="https://github.com/ItzSelenux/papirus-folders-gui"
+arch=('any')
+license=('LGPL2')
+depends=('polkit-gnome' 'papirus-folders')
+makedepends=('git')
+provides=("papirus-folders-gui")
+source=("$pkgname::git+https://github.com/ItzSelenux/papirus-folders-gui.git"
+ "papirus-folders-gui.hook")
+sha256sums=('SKIP'
+ 'SKIP')
+
+package() {
+ cd $pkgname
+ cd papirus-folders-gui
+ make
+ mv papirus-folders-GUI papirus-folders-gui
+ sudo cp papirus-folders-gui /usr/bin/
+ sudo cp papirus.desktop /usr/share/applications/
+}
diff --git a/papirus-folders-gui.hook b/papirus-folders-gui.hook
new file mode 100644
index 000000000000..4e3dd199d10a
--- /dev/null
+++ b/papirus-folders-gui.hook
@@ -0,0 +1,11 @@
+[Action]
+Depends=papirus-folders
+Description=change the folders color of the Papirus icon theme
+Exec=/usr/bin/papirus-folders-gui -R
+When=PostTransaction
+
+[Trigger]
+Operation=Install
+Operation=Upgrade
+Target=papirus-icon-theme
+Type=Package