summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorItzSelenux2021-06-18 21:00:42 +0000
committerItzSelenux2021-06-18 21:00:42 +0000
commitfffb3d6983a40ea2bb4b8fc2ed9ebee63d953f40 (patch)
tree130e71ae9bfb1b603f474972d1161ccf54d0605c
parentf18b8a3900e16dfad18c1a6296187a8497f28f40 (diff)
downloadaur-fffb3d6983a40ea2bb4b8fc2ed9ebee63d953f40.tar.gz
useful commit message
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee122844d44a..6eed787fa0f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = papirus-folders-gui
pkgdesc = A graphical user interface for papirus-folders
- pkgver = 1.3
+ pkgver = 1.4
pkgrel = 1
url = https://github.com/ItzSelenux/papirus-folders-gui
arch = x86_64
license = unknown
+ makedepends = cmake
+ makedepends = git
depends = polkit-gnome
depends = papirus-folders
depends = qt5-base
+ optdepends = mate-polkit: Polkit Authentication agent, not required on most DE
provides = papirus-folders-gui
conflicts = papirus-folders-gui-bin
- source = papirus-folders-gui-1.3.tar.gz::https://github.com/ItzSelenux/papirus-folders-gui/archive/refs/tags/1.3.tar.gz
- sha256sums = 356c015b55b0746bbb77841554ab6b5bfca3ea608c0b900c5828bb359a1472b2
+ source = papirus-folders-gui-1.4.tar.gz::https://github.com/ItzSelenux/papirus-folders-gui/archive/refs/tags/1.4.tar.gz
+ sha256sums = b40aa996923a551f55f2f525687a845d29cb9110f0187b11dd8954bb2d70ee32
pkgname = papirus-folders-gui
-
diff --git a/PKGBUILD b/PKGBUILD
index dc04448468ae..fa7c28f9fab2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,19 @@
# Maintainer: ItzSelenux <zariepcommunication@gmail.com>
# Maintainer: yochananmarqos
pkgname=papirus-folders-gui
-pkgver=1.3
+pkgver=1.4
pkgrel=1
pkgdesc="A graphical user interface for papirus-folders"
url="https://github.com/ItzSelenux/papirus-folders-gui"
arch=('x86_64')
license=('unknown')
+optdepends=('mate-polkit: Polkit Authentication agent, not required on most DE')
+makedepends=('cmake' 'git')
depends=('polkit-gnome' 'papirus-folders' 'qt5-base')
provides=('papirus-folders-gui')
conflicts=('papirus-folders-gui-bin')
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('356c015b55b0746bbb77841554ab6b5bfca3ea608c0b900c5828bb359a1472b2')
+sha256sums=('b40aa996923a551f55f2f525687a845d29cb9110f0187b11dd8954bb2d70ee32')
prepare() {
cd "$pkgname-$pkgver/$pkgname"
@@ -20,7 +22,7 @@ prepare() {
build() {
cd "$pkgname-$pkgver/$pkgname"
- qmake
+ cmake .
make
}