summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorItzSelenux2021-04-20 20:21:06 -0500
committerItzSelenux2021-04-20 20:21:06 -0500
commitf58466ad849b63848e2c79dd12e3af3946c6156f (patch)
treea20f8aa2887eb3c3ff09fa4f54e402fed8aa2ba8
downloadaur-f58466ad849b63848e2c79dd12e3af3946c6156f.tar.gz
useful commit message
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a715460231b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = papirus-folders-gui-bin
+ pkgdesc = A graphical user interface for papirus-folders, precompiled bin
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/ItzSelenux/papirus-folders-gui
+ arch = x86_64
+ license = unknown
+ depends = polkit-gnome
+ depends = papirus-folders
+ depends = qt5-base
+ source = papirus-folders-gui-bin-1.3.tar.gz::https://github.com/ItzSelenux/papirus-folders-gui/archive/refs/tags/1.3.tar.gz
+ sha256sums = e5fd6bd064559c5c585effb5d7df2fb723e3f389d82d57a6e7477ecd682830a7
+
+pkgname = papirus-folders-gui-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1d00451d0aea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: ItzSelenux <zariepcommunication@gmail.com>
+# Maintainer: yochananmarqos
+pkgname=papirus-folders-gui-bin
+pkgver=1.3
+pkgrel=1
+pkgdesc="A graphical user interface for papirus-folders, precompiled bin"
+url="https://github.com/ItzSelenux/papirus-folders-gui"
+arch=('x86_64')
+license=('unknown')
+depends=('polkit-gnome' 'papirus-folders' 'qt5-base')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('e5fd6bd064559c5c585effb5d7df2fb723e3f389d82d57a6e7477ecd682830a7')
+package() {
+ ls
+ cd "papirus-folders-gui-1.3/premaked-build"
+ install -Dm755 "papirus-folders-gui" -t "$pkgdir/usr/bin"
+ install -Dm644 papirus.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+}