summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbasigur2019-02-18 01:41:07 +0500
committerbasigur2019-02-18 01:41:07 +0500
commit796457543e80f3882fd00939d059eeb23bf4213d (patch)
tree4ff7802ca7f5cdcc3888cd72ed80795f5a6d1ad1
downloadaur-796457543e80f3882fd00939d059eeb23bf4213d.tar.gz
papirus-nordic
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..652b48f1d532
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 5.1.2
+# Sun Feb 17 20:32:10 UTC 2019
+pkgbase = papirus-folders-nordic
+ pkgdesc = Papirus icon theme
+ pkgver = r
+ pkgrel = 1
+ url = https://github.com/basigur/papirus-folders
+ arch = any
+ license = LGPL3
+ depends = gtk-update-icon-cache
+ conflicts = papirus-icon-theme
+ replaces = papirus-folders-nordic
+ source = papirus-icon-theme-20190203.tar.gz::https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/20190203.tar.gz
+ source = papirus-folders::git+https://github.com/basigur/papirus-folders
+ sha512sums = 40e274b31cf3f78512229c68c9fc52efcf7f2cb36db4c474052fd954e31ad5ca4f2345df9cc26017056a0604cc1cc9ccd77b4b703d6020da1a8aede571a82926
+ sha512sums = SKIP
+
+pkgname = papirus-folders-nordic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d6481115c7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: basigur
+
+pkgname=papirus-folders-nordic
+_pkgname=papirus-icon-theme
+pkgver=r
+_pkgver=20190203
+pkgrel=1
+pkgdesc="Papirus icon theme"
+arch=('any')
+url="https://github.com/basigur/papirus-folders"
+license=("LGPL3")
+conflicts=('papirus-icon-theme')
+replaces=('papirus-folders-nordic')
+depends=('gtk-update-icon-cache')
+source=("$_pkgname-$_pkgver.tar.gz::https://github.com/PapirusDevelopmentTeam/$_pkgname/archive/$_pkgver.tar.gz"
+ "papirus-folders::git+https://github.com/basigur/papirus-folders")
+ sha512sums=('40e274b31cf3f78512229c68c9fc52efcf7f2cb36db4c474052fd954e31ad5ca4f2345df9cc26017056a0604cc1cc9ccd77b4b703d6020da1a8aede571a82926'
+ 'SKIP'
+)
+
+pkgver() {
+ cd papirus-folders
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $_pkgname-$_pkgver
+ make DESTDIR="$pkgdir" install
+
+ ##papirus-folders##
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ cp -r "$srcdir"/papirus-folders/'README.md' "$pkgdir"/usr/share/doc/"$pkgname"/'README.md'
+ cp -r "$srcdir"/papirus-folders/'LICENSE' "$pkgdir"/usr/share/licenses/"$pkgname"/'LICENSE'
+ cp -rf "$srcdir"/papirus-folders/Papirus "$pkgdir"/usr/share/icons/
+
+
+ gtk-update-icon-cache "$pkgdir"/usr/share/icons/Papirus/
+ gtk-update-icon-cache "$pkgdir"/usr/share/icons/Papirus-Dark/
+ gtk-update-icon-cache "$pkgdir"/usr/share/icons/Papirus-Light/
+ gtk-update-icon-cache "$pkgdir"/usr/share/icons/ePapirus/
+
+}