summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-12-04 09:51:37 -0700
committerMark Wagie2023-12-04 09:51:37 -0700
commit600aa8deb0a703d061ec4b1e4ad629b7741d8927 (patch)
tree4dccd9527cf0a808ee12b5e627df456228168781
parentf6e64f67d2327626e2ef00aefcc77ca0c77dacb9 (diff)
downloadaur-600aa8deb0a703d061ec4b1e4ad629b7741d8927.tar.gz
split epapirus into its own package
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
2 files changed, 42 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e713952d2c4b..b7a9ce217323 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,28 @@
pkgbase = papirus-icon-theme-git
- pkgdesc = A free and open source SVG icon theme based on Paper Icon Set
- pkgver = 20221101.r5.gcce26033ea
+ pkgdesc = Pixel perfect icon theme for Linux
+ pkgver = 20231201.r7.ga510018dad
pkgrel = 1
epoch = 1
- url = https://git.io/papirus-icon-theme
- install = alt-icons.install
+ url = https://github.com/PapirusDevelopmentTeam/papirus-icon-theme
arch = any
license = GPL3
makedepends = git
depends = gtk-update-icon-cache
+ options = !strip
+ source = git+https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git
+ sha256sums = SKIP
+
+pkgname = papirus-icon-theme-git
+ install = alt-icons.install
optdepends = hardcode-fixer-git: To deal with hardcoded application icons
optdepends = hardcode-tray-git: To fix hardcoded tray icons
optdepends = sif-git: To fix icons of running Steam games
provides = papirus-icon-theme
conflicts = papirus-icon-theme
- options = !strip
- source = git+https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git
- sha256sums = SKIP
-pkgname = papirus-icon-theme-git
+pkgname = epapirus-icon-theme-git
+ pkgdesc = Pixel perfect icon theme for Linux (for elementary OS and Pantheon Desktop only)
+ depends = gtk-update-icon-cache
+ depends = papirus-icon-theme-git
+ provides = epapirus-icon-theme
+ conflicts = epapirus-icon-theme
diff --git a/PKGBUILD b/PKGBUILD
index 56285a86357d..580692e2c86f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
# Contributor: Edgard Castro <castro@edgard.org>
# Contributor: Frederic Bezies <fredbezies at gmail dot com>
@@ -6,32 +6,44 @@
# Contributor: Icaro Perseo <icaroperseo[at]protonmail[dot]com>
# Contributor: Lucas SaliƩs Brum <lucas@archlinux.com.br>
-pkgname=papirus-icon-theme-git
-pkgver=20221101.r5.gcce26033ea
+pkgname=('papirus-icon-theme-git' 'epapirus-icon-theme-git')
+pkgbase=papirus-icon-theme-git
+pkgver=20231201.r7.ga510018dad
pkgrel=1
epoch=1
-pkgdesc="A free and open source SVG icon theme based on Paper Icon Set"
+pkgdesc="Pixel perfect icon theme for Linux"
arch=('any')
-url="https://git.io/papirus-icon-theme"
+url="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
license=('GPL3')
depends=('gtk-update-icon-cache')
makedepends=('git')
-optdepends=('hardcode-fixer-git: To deal with hardcoded application icons'
- 'hardcode-tray-git: To fix hardcoded tray icons'
- 'sif-git: To fix icons of running Steam games')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-install='alt-icons.install'
options=('!strip')
source=('git+https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${pkgbase%-git}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
- cd "$srcdir/${pkgname%-git}"
- make DESTDIR="$pkgdir" install
+package_papirus-icon-theme-git() {
+ optdepends=('hardcode-fixer-git: To deal with hardcoded application icons'
+ 'hardcode-tray-git: To fix hardcoded tray icons'
+ 'sif-git: To fix icons of running Steam games')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+ install='alt-icons.install'
+
+ cd "${pkgbase%-git}"
+ make DESTDIR="$pkgdir" ICON_THEMES="Papirus Papirus-Dark Papirus-Light" install
+}
+
+package_epapirus-icon-theme-git() {
+ pkgdesc+=" (for elementary OS and Pantheon Desktop only)"
+ depends+=('papirus-icon-theme-git')
+ provides=("${pkgname%-git}")
+ conflicts=("${pkgname%-git}")
+
+ cd "${pkgbase%-git}"
+ make DESTDIR="$pkgdir" ICON_THEMES="ePapirus ePapirus-Dark" install
}