summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-01-05 22:10:49 +0100
committerDaniel Peukert2020-01-05 22:10:49 +0100
commit800e25d277ddaaaba051fcdc0521df64ffb2c7b1 (patch)
tree0a4cf0373e5e98fb043b058a0ea1f212346dfef1
parent662ea2e5b1ef5d0598a0efedf7936ca5fb096716 (diff)
downloadaur-800e25d277ddaaaba051fcdc0521df64ffb2c7b1.tar.gz
Added papirus-libreoffice-theme
-rw-r--r--.SRCINFO16
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore18
-rw-r--r--PKGBUILD42
4 files changed, 42 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d91d763540e9..4703d06fa7ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,14 @@
pkgbase = papirus-libreoffice-theme
pkgdesc = Papirus theme for LibreOffice
- pkgver = 20170325
+ pkgver = 20170228
pkgrel = 1
+ epoch = 1
url = https://github.com/PapirusDevelopmentTeam/papirus-libreoffice-theme
arch = any
- license = GPL
- makedepends = git
+ license = GPL3
makedepends = make
optdepends = libreoffice
- optdepends = libreoffice-fresh-rpm
- conflicts = papirus-libreoffice-theme-git
- conflicts = libreoffice-papirus-theme
- conflicts = libreoffice-papirus-theme-git
- options = !strip
- source = papirus-libreoffice-theme::git+https://github.com/PapirusDevelopmentTeam/papirus-libreoffice-theme.git#commit=2884637
- sha256sums = SKIP
+ source = papirus-libreoffice-theme-20170228-1.tar.gz::https://github.com/PapirusDevelopmentTeam/papirus-libreoffice-theme/archive/20170228.tar.gz
+ sha256sums = 396402c9327506a729d3c01e339528dd5b5f9b205cb3edabca4eb85b5db5df6d
pkgname = papirus-libreoffice-theme
-
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
index 018a3de08144..82b3c183d5d4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,14 @@
-*
-!PKGBUILD
-!.SRCINFO
-!.gitignore
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
index 857bb45a6f21..baf2ea5345f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,19 @@
-# Maintainer: Icaro Perseo <icaroperseo[at]protonmail[dot]com>
-# Contributor: FadeMind <fademind@gmail.com>
-
-pkgname=papirus-libreoffice-theme
-_commit=2884637
-pkgver=20170325
-pkgrel=1
-pkgdesc="Papirus theme for LibreOffice"
-url="https://github.com/PapirusDevelopmentTeam/${pkgname}"
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Maintainer: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com>
+pkgname='papirus-libreoffice-theme'
+pkgver='20170228'
+pkgrel='1'
+epoch='1'
+pkgdesc='Papirus theme for LibreOffice'
arch=('any')
-license=('GPL')
-makedepends=('git' 'make')
-conflicts=('papirus-libreoffice-theme-git' 'libreoffice-papirus-theme' 'libreoffice-papirus-theme-git')
-optdepends=('libreoffice' 'libreoffice-fresh-rpm')
-options=('!strip')
-source=("${pkgname}::git+${url}.git#commit=${_commit}")
-sha256sums=('SKIP')
-
-pkgver() {
- cd ${pkgname}
- git log -1 --format="%cd" --date=short | tr -d '-'
-}
+url="https://github.com/PapirusDevelopmentTeam/$pkgname"
+license=('GPL3')
+optdepends=('libreoffice')
+makedepends=('make')
+source=("$pkgname-$pkgver-$pkgrel.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('396402c9327506a729d3c01e339528dd5b5f9b205cb3edabca4eb85b5db5df6d')
package() {
- cd ${pkgname}
- make install \
- PREFIX="/usr/lib" \
- DESTDIR="$pkgdir"
+ cd "$srcdir/$pkgname-$pkgver/"
+ make install DESTDIR="$pkgdir" PREFIX='/usr/lib'
}
-
-# vim:set ts=2 sw=2 cc=80 et: