summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2016-06-03 18:57:30 +0200
committerFadeMind2016-06-03 18:57:30 +0200
commit83382a31b8600bb88b199f0248ffb19dbe0fc409 (patch)
tree161688eb17da886ec6548a8910e243fa7a44ca5a
downloadaur-83382a31b8600bb88b199f0248ffb19dbe0fc409.tar.gz
update
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4047c7b29bb8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Fri Jun 3 16:57:30 UTC 2016
+pkgbase = papirus-libreoffice-theme
+ pkgdesc = Papirus theme for LibreOffice
+ pkgver = 20160601
+ pkgrel = 1
+ url = https://github.com/PapirusDevelopmentTeam/papirus-libreoffice-theme
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = make
+ depends = plasma-desktop
+ optdepends = libreoffice
+ optdepends = libreoffice-fresh-rpm
+ conflicts = papirus-libreoffice-theme-git
+ conflicts = libreoffice-papirus-theme
+ conflicts = libreoffice-papirus-theme-git
+ options = !strip
+ source = papirus-libreoffice-theme::git+https://github.com/PapirusDevelopmentTeam/papirus-libreoffice-theme.git#commit=536bba5
+ sha256sums = SKIP
+
+pkgname = papirus-libreoffice-theme
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71db1bc4018c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+
+pkgname=papirus-libreoffice-theme
+_commit=536bba5
+pkgver=20160601
+pkgrel=1
+pkgdesc="Papirus theme for LibreOffice"
+url="https://github.com/PapirusDevelopmentTeam/${pkgname}"
+arch=('any')
+license=('GPL')
+depends=('plasma-desktop')
+makedepends=('git' 'make')
+conflicts=('papirus-libreoffice-theme-git' 'libreoffice-papirus-theme' 'libreoffice-papirus-theme-git')
+optdepends=('libreoffice' 'libreoffice-fresh-rpm')
+options=('!strip')
+source=("${pkgname}::git+${url}.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+package() {
+ cd ${pkgname}
+ make install DESTDIR="$pkgdir"
+}