summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-07-21 08:54:13 -0600
committerMark Wagie2020-07-21 08:54:13 -0600
commit7d675ed509cf71d7f609c0e57ff4a167ea4a40c9 (patch)
tree507f32ecf5583ff18209ba4bdbdc048d236f4da7
parentc3eea4b900bf1b7a9b034c3937e022672b340bb6 (diff)
downloadaur-7d675ed509cf71d7f609c0e57ff4a167ea4a40c9.tar.gz
use proper pkgver
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD31
3 files changed, 21 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7379ef1e50ac..6708469fe11a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
-# Generated by mksrcinfo v8
-# Wed Mar 8 12:02:36 UTC 2017
pkgbase = papirus-libreoffice-theme-git
- pkgdesc = Papirus theme for LibreOffice (git version)
- pkgver = 20170228
+ pkgdesc = Papirus theme for LibreOffice
+ pkgver = 20170228.r8.gcfe7659
pkgrel = 1
url = https://github.com/PapirusDevelopmentTeam/papirus-libreoffice-theme
arch = any
license = GPL
makedepends = git
depends = libreoffice
+ provides = papirus-libreoffice-theme
conflicts = papirus-libreoffice-theme
- conflicts = libreoffice-papirus-theme
- conflicts = libreoffice-papirus-theme-git
options = !strip
- source = papirus-libreoffice-theme-git::git+https://github.com/PapirusDevelopmentTeam/papirus-libreoffice-theme.git
+ source = git+https://github.com/PapirusDevelopmentTeam/papirus-libreoffice-theme.git
sha256sums = SKIP
pkgname = papirus-libreoffice-theme-git
diff --git a/.gitignore b/.gitignore
index 018a3de08144..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
+# Ignore everything
*
+
+# But not these files...
+!.gitignore
!PKGBUILD
!.SRCINFO
-!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index f15d94774557..1d3035f1bbf5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,27 @@
-# Maintainer: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com
-
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com
+# Contributor: FadeMind <fademind@gmail.com>
pkgname=papirus-libreoffice-theme-git
-pkgver=20170228
+pkgver=20170228.r8.gcfe7659
pkgrel=1
-pkgdesc="Papirus theme for LibreOffice (git version)"
-url="https://github.com/PapirusDevelopmentTeam/${pkgname%-git}"
+pkgdesc="Papirus theme for LibreOffice"
+url="https://github.com/PapirusDevelopmentTeam/papirus-libreoffice-theme"
arch=('any')
license=('GPL')
depends=('libreoffice')
makedepends=('git')
-conflicts=('papirus-libreoffice-theme' 'libreoffice-papirus-theme' 'libreoffice-papirus-theme-git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
options=('!strip')
-source=("${pkgname}::git+${url}.git")
+source=("git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd ${pkgname}
- git log -1 --format="%cd" --date=short | tr -d '-'
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- #cd ${pkgname}
- #mkdir -p ${pkgdir}/usr/lib/libreoffice/share/config
- #cp --no-preserve=mode,ownership -r \
- # images_papirus.zip \
- # images_papirus_dark.zip \
- # images_epapirus.zip \
- # ${pkgdir}/usr/lib/libreoffice/share/config
- cd "${srcdir}/${pkgname}"
- make PREFIX="/usr/lib" DESTDIR="${pkgdir}" install
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
}