summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-03-19 14:46:28 -0600
committerMark Wagie2021-03-19 14:46:28 -0600
commitac382c907cfcba4ad6d35e1c8426472112238aa9 (patch)
treef141495baf4d2d6ff32fa9d7b56a30696a2c0688
downloadaur-ac382c907cfcba4ad6d35e1c8426472112238aa9.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD30
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d1f52188f69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = papirus-linux-universe
+ pkgdesc = Papirus folder icon set based on distros and the most famous icon themes in the Linux world!
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.pling.com/p/1493085
+ arch = any
+ license = GPL2
+ depends = bash
+ depends = papirus-icon-theme
+ optdepends = papirus-nord: additional icon themes
+ provides = papirus-folders
+ conflicts = papirus-folders
+ options = !strip
+ source = papirus-linux-universe-1.0.0.tar.gz::https://github.com/Adapta-Projects/Papirus-Linux-Universe/archive/refs/tags/1.0.0.tar.gz
+ sha256sums = 2e8764a1eee5aaba97471d85c320238659f7cb74577454eb20c91dcca18b038a
+
+pkgname = papirus-linux-universe
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0de12d436c0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+pkgname=papirus-linux-universe
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Papirus folder icon set based on distros and the most famous icon themes in the Linux world!"
+arch=('any')
+url="https://www.pling.com/p/1493085"
+license=('GPL2')
+depends=('bash' 'papirus-icon-theme')
+optdepends=('papirus-nord: additional icon themes')
+provides=('papirus-folders')
+conflicts=('papirus-folders')
+options=('!strip')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Adapta-Projects/Papirus-Linux-Universe/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('2e8764a1eee5aaba97471d85c320238659f7cb74577454eb20c91dcca18b038a')
+
+package() {
+ cd Papirus-Linux-Universe-$pkgver
+ install -Dm755 papirus-folders "$pkgdir/usr/bin/papirus-folders"
+ install -Dm755 papirus-folders1 "$pkgdir/usr/bin/papirus-folders-nord"
+
+ for i in 22x22 24x24 32x32 48x48 64x64; do
+
+ # Remove conflicting icons provided by papirus-icon-theme
+ rm Icons/${i}/*breeze*
+
+ install -d "$pkgdir/usr/share/icons/Papirus/${i}/places"
+ cp -r Icons/${i}/* "$pkgdir/usr/share/icons/Papirus/${i}/places"
+ done
+}