summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfademind2018-03-22 09:58:31 +0100
committerfademind2018-03-22 09:58:31 +0100
commit15f1be7102242aa893e6b0acd1432c3359c37236 (patch)
tree216dad0ddad01ad8d3fcb8a6d9f2fad423b4dc09
downloadaur-15f1be7102242aa893e6b0acd1432c3359c37236.tar.gz
papirus-maia-icon-theme-git init merge
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD81
3 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e1a4b5dc0d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Thu Mar 22 08:57:49 UTC 2018
+pkgbase = papirus-maia-icon-theme-git
+ pkgdesc = Manjaro variation of Papirus icon theme (git version)
+ pkgver = 20180322.102d72b7e
+ pkgrel = 1
+ url = https://github.com/PapirusDevelopmentTeam/papirus-icon-theme
+ arch = any
+ license = LGPL3
+ makedepends = git
+ depends = gtk-update-icon-cache
+ conflicts = papirus-icon-theme
+ conflicts = papirus-icon-theme-git
+ conflicts = papirus-maia-icon-theme
+ conflicts = papirus-gtk-icon-theme
+ conflicts = papirus-gtk-icon-theme-git
+ conflicts = papirus-icon-theme-gtk
+ conflicts = papirus-icon-theme-gtk-git
+ conflicts = papirus-icon-theme-kde
+ conflicts = papirus-icon-theme-kde-git
+ options = !strip
+ source = git+https://github.com/PapirusDevelopmentTeam/papirus-icon-theme.git
+ sha256sums = SKIP
+
+pkgname = papirus-maia-icon-theme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9dd6c1eeaed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+# Contributor: Stefano Capitani <stefano@manjaro.org>
+
+_pkgbase=papirus-icon-theme
+pkgname=papirus-maia-icon-theme-git
+pkgver=20180322.102d72b7e
+pkgrel=1
+pkgdesc="Manjaro variation of Papirus icon theme (git version)"
+arch=('any')
+url="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+license=("LGPL3")
+depends=('gtk-update-icon-cache')
+makedepends=('git')
+options=('!strip')
+conflicts=(
+ "${_pkgbase}"
+ "${_pkgbase}-git"
+ "${pkgname/-git/}"
+ "papirus-gtk-icon-theme"
+ "papirus-gtk-icon-theme-git"
+ "papirus-icon-theme-gtk"
+ "papirus-icon-theme-gtk-git"
+ "papirus-icon-theme-kde"
+ "papirus-icon-theme-kde-git")
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgbase}
+ (
+ git show --format='%cI' -q master | sed 's/T.*//g;s/-//g'
+ echo .
+ git rev-parse --short master
+ ) | tr -d '\n'
+}
+
+prepare() {
+ cd ${_pkgbase}
+
+#Change color for Manjaro
+
+msg "Create Papirus-Maia: this next bit might take a little while..."
+
+ find . -type f -name '*.*' -exec sed -i "s|#4877b1|#3c8d7d|Ig;\
+ s|#5294e2|#16a085|Ig;\
+ s|#1d344f|#266357|Ig;\
+ s|#0096aa|#188694|Ig;\
+ s|#00bcd4|#16a085|Ig" {} \;
+msg "Done Manjarifications"
+
+#Change Icons folders name
+ sed -i -e 's/ePapirus Papirus Papirus-Adapta Papirus-Adapta-Nokto Papirus-Dark Papirus-Light/Papirus-Maia Papirus-Adapta-Maia Papirus-Adapta-Nokto-Maia Papirus-Dark-Maia Papirus-Light-Maia/g' Makefile
+
+#Remove unused icon theme
+ rm -R ePapirus
+
+#Change Folders name
+ mv Papirus Papirus-Maia
+ mv Papirus-Light Papirus-Light-Maia
+ mv Papirus-Dark Papirus-Dark-Maia
+ mv Papirus-Adapta Papirus-Adapta-Maia
+ mv Papirus-Adapta-Nokto Papirus-Adapta-Nokto-Maia
+
+#Change Theme name
+ find . -type f -name '*.theme' -exec sed -i '2s/$/-Maia/g' {} \;
+ find . -type f -name '*.theme' -exec sed -i '3s/$/ Maia/g' {} \;
+}
+
+package() {
+ make -C "${_pkgbase}" DESTDIR="$pkgdir" install
+
+#Recreate all symlinks to match with Papirus tree
+ cd $pkgdir/usr/share/icons
+ mkdir -p Papirus
+ mkdir -p Papirus-Adapta
+
+ for i in symbolic 64x64 48x48 32x32 24x24 22x22 16x16; do
+ ln -sr $pkgdir/usr/share/icons/Papirus-Maia/$i $pkgdir/usr/share/icons/Papirus/$i
+ ln -sr $pkgdir/usr/share/icons/Papirus-Adapta-Maia/$i $pkgdir/usr/share/icons/Papirus-Adapta/$i
+ done
+}