summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfademind2018-04-17 19:56:08 +0200
committerfademind2018-04-17 19:56:08 +0200
commite359d30d48c6a72625bc0c53f65616e6ff78d4b6 (patch)
treee35826c2de7d0929e1d29c910e5b4cf39fbc762e
parente0802edaae3456ebf7fb0d309291fbd4dcc8a948 (diff)
downloadaur-e359d30d48c6a72625bc0c53f65616e6ff78d4b6.tar.gz
update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1235cc5dba8..de8318874ade 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
# Generated by mksrcinfo v8
-# Tue Apr 17 06:10:47 UTC 2018
+# Tue Apr 17 17:56:08 UTC 2018
pkgbase = papirus-maia-icon-theme-git
pkgdesc = Manjaro variation of Papirus icon theme (git version)
- pkgver = 20180416.cad7b4e
+ pkgver = 20180417.6d88bb2
pkgrel = 1
url = https://github.com/Ste74/papirus-maia-icon-theme
arch = any
license = LGPL3
depends = gtk-update-icon-cache
- depends = papirus-icon-theme-git
+ depends = papirus-icon-theme
conflicts = papirus-maia-icon-theme
options = !strip
source = git+https://github.com/Ste74/papirus-maia-icon-theme.git
diff --git a/PKGBUILD b/PKGBUILD
index cb03c0b082f7..e5181d0e2057 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
# Contributor: Stefano Capitani <stefano@manjaro.org>
pkgname=papirus-maia-icon-theme-git
-pkgver=20180416.cad7b4e
+pkgver=20180417.6d88bb2
pkgrel=1
pkgdesc="Manjaro variation of Papirus icon theme (git version)"
arch=('any')
url="https://github.com/Ste74/papirus-maia-icon-theme"
license=("LGPL3")
-depends=('gtk-update-icon-cache' 'papirus-icon-theme-git')
+depends=('gtk-update-icon-cache' 'papirus-icon-theme')
+makepepends=('cmake' 'git')
conflicts=("${pkgname/-git/}")
options=('!strip')
source=("git+${url}.git")
@@ -22,13 +23,14 @@ pkgver() {
git rev-parse --short master
) | tr -d '\n'
}
-prepare() {
- cd ${pkgname/-git/}
- rm LICENSE README.md recolor.sh
+
+build() {
+ mkdir -p ${srcdir}/build
+ cd ${srcdir}/build
+ cmake ../${pkgname/-git/}
+ make
}
package() {
- cd ${pkgname/-git/}
- mkdir -p ${pkgdir}/usr/share/icons
- cp -R * ${pkgdir}/usr/share/icons/
+ make -C build DESTDIR="${pkgdir}" install
}