summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2016-06-03 19:15:24 +0200
committerFadeMind2016-06-03 19:15:24 +0200
commit0202b1ea34edff4aaf07165eceb9216da9bc448d (patch)
treee2308ec0b59fa1f83d1d259012465d48f27cd872
parent46586cb53938eaa7becb24bb661a8213f291f996 (diff)
downloadaur-0202b1ea34edff4aaf07165eceb9216da9bc448d.tar.gz
update
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD35
-rw-r--r--papirus-plasma-theme.install33
4 files changed, 71 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b07d58e8edb..b48bd4528ad7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Jun 3 17:15:24 UTC 2016
pkgbase = papirus-plasma-theme
- pkgdesc = Modified and adaptive Paper plasma theme for KDE
- pkgver = 20151004
+ pkgdesc = Papirus plasma theme for KDE
+ pkgver = 20160603
pkgrel = 1
- url = https://github.com/varlesh/papirus-pack-kde
+ url = https://github.com/PapirusDevelopmentTeam/papirus-plasma-theme
+ install = papirus-plasma-theme.install
arch = any
- license = CCPL:by-sa
+ license = GPL
+ makedepends = git
+ makedepends = make
+ depends = plasma-desktop
+ conflicts = papirus-plasma-theme-git
options = !strip
- source = papirus-pack-kde-20151004.tar.gz::https://github.com/varlesh/papirus-pack-kde/archive/3f97691234d1688ad54b94d9b81f9ef181b0d8e9.tar.gz
- sha256sums = 87e2b1cbb0e08588a231d5c2638926de7ba566c5c0df81f4a897f95b54957f63
+ source = papirus-plasma-theme::git+https://github.com/PapirusDevelopmentTeam/papirus-plasma-theme.git#commit=f88f002
+ sha256sums = SKIP
pkgname = papirus-plasma-theme
diff --git a/.gitignore b/.gitignore
index 4406c5231a4f..f70672ab8ea1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,15 +1,6 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!papirus-plasma-theme.install
-### ArchLinuxPackages
-*.tar
-*.tar.*
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-pkg/
-src/
diff --git a/PKGBUILD b/PKGBUILD
index 5756478370e9..8c6d25a0f485 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,27 @@
-# Maintainer: Grigorii Horos <horosgrisa@gmail.com>
+# Maintainer: FadeMind <fademind@gmail.com>
-_git=3f97691234d1688ad54b94d9b81f9ef181b0d8e9
-_repo=papirus-pack-kde
pkgname=papirus-plasma-theme
-pkgver=20151004
+_commit=f88f002 # 7 digits
+pkgver=20160603
pkgrel=1
-pkgdesc="Modified and adaptive Paper plasma theme for KDE"
+pkgdesc="Papirus plasma theme for KDE"
+url="https://github.com/PapirusDevelopmentTeam/${pkgname}"
arch=('any')
-url="https://github.com/varlesh/${_repo}"
-license=('CCPL:by-sa')
+license=('GPL')
+depends=('plasma-desktop')
+makedepends=('git' 'make')
+conflicts=('papirus-plasma-theme-git')
options=('!strip')
-source=("${_repo}-${pkgver}.tar.gz::${url}/archive/${_git}.tar.gz")
-sha256sums=('87e2b1cbb0e08588a231d5c2638926de7ba566c5c0df81f4a897f95b54957f63')
+install="${pkgname}.install"
+source=("${pkgname}::git+${url}.git#commit=${_commit}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
package() {
- install -d ${pkgdir}/usr/share/plasma/desktoptheme
- cp -r ${srcdir}/${_repo}-${_git}/plasma-themes/papirus* ${pkgdir}/usr/share/plasma/desktoptheme/
- install -D -m644 ${srcdir}/${_repo}-${_git}/plasma-themes/papirus/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- find ${pkgdir}/usr -type f -exec chmod 644 {} \;
- find ${pkgdir}/usr -type d -exec chmod 755 {} \;
-} \ No newline at end of file
+ cd ${pkgname}
+ make install DESTDIR="$pkgdir"
+}
diff --git a/papirus-plasma-theme.install b/papirus-plasma-theme.install
new file mode 100644
index 000000000000..83150ca06ef6
--- /dev/null
+++ b/papirus-plasma-theme.install
@@ -0,0 +1,33 @@
+plasma-cache-refresh() {
+ _l="/etc/login.defs"
+ _p="/etc/passwd"
+
+ ## get mini UID limit ##
+ l=$(grep "^UID_MIN" $_l)
+
+ ## get max UID limit ##
+ l1=$(grep "^UID_MAX" $_l)
+
+ ## use awk to print if UID >= $MIN and UID <= $MAX and shell is not /sbin/nologin ##
+ users=$(awk -F':' -v "min=${l##UID_MIN}" -v "max=${l1##UID_MAX}" '{ if ( $3 >= min && $3 <= max && $7 != "/sbin/nologin" ) print $0 }' "$_p" | cut -d: -f1)
+ for u in $users; do
+ rm -rf /home/$u/.cache/plasma* &> /dev/null
+ done
+ echo "Plasma cache files were purged."
+ echo "Reboot for regenerate plasma cache files."
+}
+
+papirus-dark-note() {
+ echo "WARNING: Papirus Dark was removed."
+ echo "If You using Papirus Dark variant, switch to arc-dark-suite-git"
+}
+
+post_install() {
+ plasma-cache-refresh
+ papirus-dark-note
+}
+
+post_upgrade() {
+ plasma-cache-refresh
+ papirus-dark-note
+}