summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2016-06-03 10:18:45 +0200
committerFadeMind2016-06-03 10:18:45 +0200
commit4f330714df25f9469f66495e966f8eb4d8e4951c (patch)
treeb392cac81be76a2890fcf4c826babcce365f85a1
downloadaur-4f330714df25f9469f66495e966f8eb4d8e4951c.tar.gz
update
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD25
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df55857ae0cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Jun 3 08:18:45 UTC 2016
+pkgbase = papirus-smplayer-theme-git
+ pkgdesc = Papirus theme for SMPlayer (git version)
+ pkgver = 20160601
+ pkgrel = 1
+ url = https://github.com/PapirusDevelopmentTeam/papirus-smplayer-theme
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = make
+ depends = smplayer
+ conflicts = papirus-smplayer-theme
+ options = !strip
+ source = papirus-smplayer-theme-git::git+https://github.com/PapirusDevelopmentTeam/papirus-smplayer-theme.git
+ sha256sums = SKIP
+
+pkgname = papirus-smplayer-theme-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05386e05b0fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: FadeMind <fademind@gmail.com>
+
+pkgname=papirus-smplayer-theme-git
+pkgver=20160601
+pkgrel=1
+pkgdesc="Papirus theme for SMPlayer (git version)"
+url="https://github.com/PapirusDevelopmentTeam/${pkgname%-git}"
+arch=('any')
+license=('GPL')
+depends=('smplayer')
+makedepends=('git' 'make')
+conflicts=('papirus-smplayer-theme')
+options=('!strip')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+package() {
+ cd ${pkgname}
+ make install DESTDIR="$pkgdir"
+}