summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2021-01-17 20:59:06 +1100
committerJP-Ellis2021-01-17 20:59:06 +1100
commit7cbd592ba66dc0b8aaa6d78bd91c777cec12b496 (patch)
tree215cff2d359e923faeb61ccbf851676395d83c69
parent28edd5bb0d02f7a272b5f89d530dac7f19051de4 (diff)
downloadaur-7cbd592ba66dc0b8aaa6d78bd91c777cec12b496.tar.gz
v0.11.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD12
-rw-r--r--isbnlib-3.10-fix.patch23
3 files changed, 35 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d191cc602a6f..95d04839321f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = papis
pkgdesc = Papis is a powerful and highly extensible command-line based document and bibliography manager.
- pkgver = 0.10
- pkgrel = 2
+ pkgver = 0.11.1
+ pkgrel = 1
url = https://github.com/papis/papis
arch = any
license = GPL
@@ -27,10 +27,10 @@ pkgbase = papis
depends = python-lxml
depends = python-slugify
optdepends = papis-rofi: integration with rofi
- source = https://files.pythonhosted.org/packages/source/p/papis/papis-0.10.tar.gz
- source = b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch
- sha256sums = 0668bba24c0ea159fd9f3497f8f26b1e27e8bc9d9f9a52c82ef28835ee4ec4d1
- sha256sums = 261f466e0a1765621877eef3b2b6498a2e54576d52b6fac66e52b7322d0d5608
+ source = https://files.pythonhosted.org/packages/source/p/papis/papis-0.11.1.tar.gz
+ source = isbnlib-3.10-fix.patch
+ sha256sums = e54739a1771ba4da4afe30b0b52dfc220543926765f975d14e8ddce508f4fdf9
+ sha256sums = 3f79cc4c5deb31cd56590b2c17e3d7a22fefd18e03580139ad665154b814fa10
pkgname = papis
diff --git a/PKGBUILD b/PKGBUILD
index 2418d3b4ade8..c7e69deb3a3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: JP-Ellis <josh@jpellis.me>
pkgname=papis
-pkgver=0.10
-pkgrel=2
+pkgver=0.11.1
+pkgrel=1
pkgdesc="Papis is a powerful and highly extensible command-line based document and bibliography manager."
arch=('any')
url="https://github.com/papis/papis"
@@ -30,14 +30,14 @@ depends=('python'
)
optdepends=('papis-rofi: integration with rofi')
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
- "b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch")
-sha256sums=('0668bba24c0ea159fd9f3497f8f26b1e27e8bc9d9f9a52c82ef28835ee4ec4d1'
- '261f466e0a1765621877eef3b2b6498a2e54576d52b6fac66e52b7322d0d5608')
+ "isbnlib-3.10-fix.patch")
+sha256sums=('e54739a1771ba4da4afe30b0b52dfc220543926765f975d14e8ddce508f4fdf9'
+ '3f79cc4c5deb31cd56590b2c17e3d7a22fefd18e03580139ad665154b814fa10')
noextract=()
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
- patch -p 1 < "${srcdir}/b8ce11c08dc32051545e73e858f0cd044ac12ef2.patch"
+ # patch -p 1 < "${srcdir}/isbnlib-3.10-fix.patch"
}
build() {
diff --git a/isbnlib-3.10-fix.patch b/isbnlib-3.10-fix.patch
new file mode 100644
index 000000000000..8b4ca82b6774
--- /dev/null
+++ b/isbnlib-3.10-fix.patch
@@ -0,0 +1,23 @@
+From da807047045bcc8371d3775a8533f3575ccb18f3 Mon Sep 17 00:00:00 2001
+From: Alejandro Gallo <aamsgallo@gmail.com>
+Date: Sat, 16 Jan 2021 12:23:30 +0100
+Subject: [PATCH] Remove isbnlib's restriction on the version
+
+Related to issue #242
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index de7958b1..a76e2b74 100644
+--- a/setup.py
++++ b/setup.py
+@@ -65,7 +65,7 @@
+ "bibtexparser>=0.6.2",
+ "click>=7.0.0",
+ "habanero>=0.6.0",
+- "isbnlib>=3.9.1,<3.10",
++ "isbnlib>=3.9.1",
+ "prompt_toolkit>=2.0.5",
+ "tqdm>=4.1",
+ "pygments>=2.2.0",