summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJP-Ellis2019-12-23 10:23:52 +0800
committerJP-Ellis2019-12-23 10:23:52 +0800
commitfbea70214e1393c05326b4707e6c03772c19df23 (patch)
treeae894928e011d72f37e67fbe15522aaa6621a99a
parentc4f4c33fb304c4d2504d2785e1b6a65ce22f1710 (diff)
downloadaur-fbea70214e1393c05326b4707e6c03772c19df23.tar.gz
Import upstream compatibility patches
-rw-r--r--.SRCINFO6
-rw-r--r--73e740b17d47e3ccddc72b58221f21a431b49d46.patch39
-rw-r--r--PKGBUILD16
-rw-r--r--bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch32
4 files changed, 89 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 613828037069..805d6cbb8c03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = papis
pkgdesc = Papis is a powerful and highly extensible command-line based document and bibliography manager.
pkgver = 0.9
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/papis/papis
arch = any
license = GPL
@@ -27,7 +27,11 @@ pkgbase = papis
depends = python-tqdm
optdepends = papis-rofi: integration with rofi
source = https://files.pythonhosted.org/packages/source/p/papis/papis-0.9.tar.gz
+ source = bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch
+ source = 73e740b17d47e3ccddc72b58221f21a431b49d46.patch
sha256sums = 6a1070ea9a8345dde9cb5d9ccda582e2592520f987d0cfefa6f95d714bf5fd42
+ sha256sums = 90534a40b12bcf3cc206ee11737fdb0bdf21cc6b56405ee9a8363a5a83b8e5fc
+ sha256sums = 0f49015e96084fa6e978d69d695133a9753bd914fa0eb5bb1a7ee7348182fc7d
pkgname = papis
diff --git a/73e740b17d47e3ccddc72b58221f21a431b49d46.patch b/73e740b17d47e3ccddc72b58221f21a431b49d46.patch
new file mode 100644
index 000000000000..a2b23a55d05c
--- /dev/null
+++ b/73e740b17d47e3ccddc72b58221f21a431b49d46.patch
@@ -0,0 +1,39 @@
+From 73e740b17d47e3ccddc72b58221f21a431b49d46 Mon Sep 17 00:00:00 2001
+From: JP-Ellis <josh@jpellis.me>
+Date: Mon, 2 Dec 2019 11:33:52 +1100
+Subject: [PATCH] Remove upper limits on dependencies
+
+Upper limits can be re-instated if/when an incompatibility is discovered (and
+until papis can be updated to be compatible with the newer version).
+
+Signed-off-by: JP-Ellis <josh@jpellis.me>
+---
+ setup.py | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 38cfbe0c..7e7c3bf9 100644
+--- a/setup.py
++++ b/setup.py
+@@ -65,15 +65,17 @@
+ "bibtexparser>=0.6.2",
+ "click>=7.0.0",
+ "habanero>=0.6.0",
+- "isbnlib>=3.9.1,<4.0.0",
+- "prompt_toolkit>=2.0.5,<3",
++ "isbnlib>=3.9.1",
++ "prompt_toolkit>=2.0.5",
+ "tqdm>=4.1",
+ "pygments>=2.2.0",
+ "stevedore>=1.30",
+ "python-doi>=0.1.1",
+ # for python 3.4
+- "lxml<=4.3.5",
+- "python-slugify>=1.2.6,<4",
++ "lxml<=4.3.5 ; python_version<='3.5'",
++ "lxml>=4.3.5 ; python_version>'3.5'",
++ "python-slugify>=1.2.6,<4 ; python_version<='3.4'",
++ "python-slugify>=1.2.6 ; python_version>'3.4'",
+ ],
+ python_requires='>=3',
+ classifiers=[
diff --git a/PKGBUILD b/PKGBUILD
index 79fec7bb5298..79ddc8edacd7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: JP-Ellis <josh@jpellis.me>
pkgname=papis
pkgver=0.9
-pkgrel=1
+pkgrel=2
pkgdesc="Papis is a powerful and highly extensible command-line based document and bibliography manager."
arch=('any')
url="https://github.com/papis/papis"
@@ -28,10 +28,20 @@ depends=('python'
'python-tqdm'
)
optdepends=('papis-rofi: integration with rofi')
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('6a1070ea9a8345dde9cb5d9ccda582e2592520f987d0cfefa6f95d714bf5fd42')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch"
+ "73e740b17d47e3ccddc72b58221f21a431b49d46.patch")
+sha256sums=('6a1070ea9a8345dde9cb5d9ccda582e2592520f987d0cfefa6f95d714bf5fd42'
+ '90534a40b12bcf3cc206ee11737fdb0bdf21cc6b56405ee9a8363a5a83b8e5fc'
+ '0f49015e96084fa6e978d69d695133a9753bd914fa0eb5bb1a7ee7348182fc7d')
noextract=()
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p 1 -i "${srcdir}/bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch"
+ patch -p 1 -i "${srcdir}/73e740b17d47e3ccddc72b58221f21a431b49d46.patch"
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
sed -i '/configparser/d' setup.py
diff --git a/bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch b/bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch
new file mode 100644
index 000000000000..a8be1305a48d
--- /dev/null
+++ b/bfe0ffae835dc5769198ae4aa5625ce44076eeb7.patch
@@ -0,0 +1,32 @@
+From bfe0ffae835dc5769198ae4aa5625ce44076eeb7 Mon Sep 17 00:00:00 2001
+From: JP-Ellis <josh@jpellis.me>
+Date: Mon, 2 Dec 2019 21:19:46 +1100
+Subject: [PATCH] Update supported Python version to 3.5, 3.6, 3.7 & 3.8
+
+It's probably safe to drop support for Python <= 3.4 as they are neither
+maintained nor receiving security fixes.
+
+Signed-off-by: JP-Ellis <josh@jpellis.me>
+---
+ .travis.yml | 3 +--
+ appveyor.yml | 10 ++++------
+ setup.py | 4 ++--
+ 3 files changed, 7 insertions(+), 10 deletions(-)
+
+diff --git a/.travis.yml b/.travis.yml
+index a94caae6..6f73695a 100644
+--- a/setup.py
++++ b/setup.py
+@@ -86,10 +86,10 @@
+ 'Operating System :: MacOS',
+ 'Operating System :: POSIX',
+ 'Operating System :: Unix',
+- 'Programming Language :: Python :: 3.3',
+- 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
++ 'Programming Language :: Python :: 3.7',
++ 'Programming Language :: Python :: 3.8',
+ 'Topic :: Utilities',
+ ],
+ extras_require=dict(