summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgesh2024-02-15 17:23:13 +0200
committergesh2024-02-15 17:23:13 +0200
commit7ab7c75ef920004c7fbff29478b061e68558a716 (patch)
tree3438d2ff3bbdbf621b761279474af20294600430
parent7a55fd131e8e95fcf2b899fd2063d6e2afda76f0 (diff)
downloadaur-7ab7c75ef920004c7fbff29478b061e68558a716.tar.gz
Use PEP517 builds
Contra wiki suggestion, PEP517-compliant frontends can build old-style packages as well. Might as well use the current build style.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 510e04f7b2ba..7208c5c88362 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = papis-git
pkgdesc = A powerful and highly extensible command-line document and bibliography manager. Git version.
- pkgver = 0.13.r328.g72dedcfa
+ pkgver = 0.13.r333.g1a6fe961
pkgrel = 1
url = https://github.com/papis/papis
arch = any
@@ -19,6 +19,9 @@ pkgbase = papis-git
checkdepends = python-types-setuptools
checkdepends = python-types-tqdm
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-arxiv
depends = python-beautifulsoup4
diff --git a/PKGBUILD b/PKGBUILD
index 8b3766dc465f..d45c1ebc90e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=papis-git
_pkgname=papis
-pkgver=0.13.r328.g72dedcfa
+pkgver=0.13.r333.g1a6fe961
pkgrel=1
pkgdesc="A powerful and highly extensible command-line document and bibliography manager. Git version."
arch=('any')
url="https://github.com/papis/papis"
license=('GPL-3.0-or-later')
-makedepends=('git')
+makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
depends=('python'
'python-arxiv'
'python-beautifulsoup4'
@@ -76,10 +76,10 @@ check() {
build() {
cd "${_pkgname}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}