summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 09:19:41 +0000
committerAntonio Rojas2021-05-08 09:19:41 +0000
commite756962b0828d4bf8e0132c294a8ea804f320366 (patch)
tree9ee054dfd6ef5f483fbe70e01652dc607f5cfe12
downloadaur-e756962b0828d4bf8e0132c294a8ea804f320366.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5268f35b1fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = paps
+ pkgdesc = Converts Unicode text to postscript and pdf using pango
+ pkgver = 0.7.1
+ pkgrel = 2
+ url = https://github.com/dov/paps
+ arch = x86_64
+ license = LGPL
+ makedepends = intltool
+ depends = pango
+ source = https://github.com/dov/paps/archive/v0.7.1.tar.gz
+ sha256sums = b8cbd16f8dd5832ecfa9907d31411b35a7f12d81a5ec472a1555d00a8a205e0e
+
+pkgname = paps
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..defb389ec1e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Artyom 'logus' Pervukhin <logus9@gmail.com>
+# Contributor: Tim Yang <tdy@gmx.com>
+
+pkgname=paps
+pkgver=0.7.1
+pkgrel=2
+pkgdesc='Converts Unicode text to postscript and pdf using pango'
+url='https://github.com/dov/paps'
+arch=('x86_64')
+license=('LGPL')
+depends=('pango')
+makedepends=('intltool')
+source=("https://github.com/dov/paps/archive/v${pkgver}.tar.gz")
+sha256sums=('b8cbd16f8dd5832ecfa9907d31411b35a7f12d81a5ec472a1555d00a8a205e0e')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}