summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Sabota2018-01-08 15:24:39 -0500
committerLukas Sabota2018-01-08 15:24:39 -0500
commita767fde240a49b7b5a845dfda795277e65326ba0 (patch)
treec9a695ca83274ca80d8449fc30c50dc94601fc18
downloadaur-papu-vst-git.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD46
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..549726c732ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = papu-vst-git
+ pkgdesc = Emulates Nintendo Gameboy PAPU audio chip as a VST
+ pkgver = r24.00acb26
+ pkgrel = 1
+ url = http://socalabs.com/
+ arch = i686
+ arch = x86_64
+ groups = socalabs-vst-suite
+ license = LGPL
+ makedepends = git
+ depends = mesa
+ source = PAPU::git+https://github.com/FigBug/PAPU.git
+ source = dRowAudio::git+https://github.com/FigBug/drowaudio.git#commit=3a1e6eb75681b166c055c501a2ed4a8df8a44df0
+ source = slCommon::git+https://github.com/FigBug/slCommon.git#commit=b49d31c4f2f131506fe5ac53f2ac6e47b3ee109b
+ source = JUCE::git+https://github.com/WeAreROLI/JUCE.git#branch=develop
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = papu-vst-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38b6b9f6495e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Lukas Sabota <lukas _at_ lwsabota _dot_ com>
+# Contributer: Lukas Sabota <lukas _at_ lwsabota _dot_ com>
+pkgname=papu-vst-git
+_gitbase=PAPU
+pkgver=r24.00acb26
+pkgrel=1
+pkgdesc="Emulates Nintendo Gameboy PAPU audio chip as a VST"
+arch=('i686' 'x86_64')
+url="http://socalabs.com/"
+license=('LGPL')
+groups=('socalabs-vst-suite')
+depends=('mesa')
+makedepends=('git')
+source=('PAPU::git+https://github.com/FigBug/PAPU.git'
+ 'dRowAudio::git+https://github.com/FigBug/drowaudio.git#commit=3a1e6eb75681b166c055c501a2ed4a8df8a44df0'
+ 'slCommon::git+https://github.com/FigBug/slCommon.git#commit=b49d31c4f2f131506fe5ac53f2ac6e47b3ee109b'
+ 'JUCE::git+https://github.com/WeAreROLI/JUCE.git#branch=develop')
+# Note: This package requires features in the develop branch of JUCE
+# This package can likely be moved to depend on the juce AUR package
+# after an upstream JUCE release.
+# FYI: This can be accomplished by symlinking /opt/JUCE to $srcdir/JUCE
+# in the future.
+md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitbase"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/$_gitbase"
+ # Workaround for SSH-only configured submodule remotes
+ cd modules
+ rm -rf dRowAudio slCommon
+ ln -s ../../dRowAudio ./
+ ln -s ../../slCommon ./
+}
+
+build() {
+ cd "$srcdir/$_gitbase/plugin/Builds/LinuxMakefile"
+ make
+}
+
+package() {
+ install -D -m644 "$srcdir/$_gitbase/plugin/Builds/LinuxMakefile/build/$_gitbase.so" "$pkgdir/usr/lib/vst/$_gitbase.so"
+}