summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Guldner2020-10-08 23:34:56 +0200
committerGabriel Guldner2020-10-08 23:34:56 +0200
commite048dbe17fd2329ef944f2fa18058ea1b6b91ade (patch)
tree5d65995ce63d72068ebdb82a8ffb7b1ff1e8206e
parent23d75a7dbf1b17abdd6d85935a08cd7af423cee8 (diff)
downloadaur-e048dbe17fd2329ef944f2fa18058ea1b6b91ade.tar.gz
update papyrus to 4.8.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
-rwxr-xr-xpapyrus.desktop11
-rw-r--r--papyrus.pngbin0 -> 25059 bytes
4 files changed, 54 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 991f72b3694b..f2b09c48ee93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
-# Generated by mksrcinfo v8
-# Fri Sep 22 08:18:38 UTC 2017
pkgbase = papyrus
pkgdesc = Graphical editing tool for UML based on eclipse.
- pkgver = 3.0.0
+ pkgver = 4.8.0
pkgrel = 1
url = http://www.eclipse.org/papyrus/
- arch = i686
arch = x86_64
license = EPL
makedepends = tar
depends = java-runtime
- source_i686 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/oxygen/3.0.0/papyrus-oxygen-3.0.0-linux32.tar.gz
- md5sums_i686 = 608176cd672d425ce4d21f9cf2cf0149
- source_x86_64 = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/oxygen/3.0.0/papyrus-oxygen-3.0.0-linux64.tar.gz
- md5sums_x86_64 = dcf605876567afcfd5d1a3a7ce617e5b
+ depends = python
+ depends = libsecret
+ source = http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/2020-06/4.8.0/papyrus-2020-06-4.8.0-linux64.tar.gz
+ source = papyrus.png
+ source = papyrus.desktop
+ md5sums = 2998813786cd8b03b72e07eb048b99e3
+ md5sums = 411d949e9e15e4e60f01f66091e18421
+ md5sums = d1d0f87c71fccdcca0bec57ccf36c2f0
pkgname = papyrus
diff --git a/PKGBUILD b/PKGBUILD
index 6d60a9f5a434..8c546052de00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,17 @@
-# Maintainer: Tomas Jasek <tomsik68(at)gmail(dot)com>
+# Maintainer: Gabriel Guldner <gabriel at guldner dot eu>
-pkgname="papyrus"
-pkgver="3.0.0"
+# Contributor: Tomas Jasek <tomsik68(at)gmail(dot)com>
+# Contributor: Alex Brinister <alex_brinister at yahoo dot com>
+
+pkgname='papyrus'
+pkgver='4.8.0'
pkgrel=1
-pkgdesc="Graphical editing tool for UML based on eclipse."
-arch=('i686' 'x86_64')
-url="http://www.eclipse.org/papyrus/"
+pkgdesc='Graphical editing tool for UML based on eclipse.'
+arch=('x86_64')
+url='http://www.eclipse.org/papyrus/'
license=('EPL')
groups=()
-depends=('java-runtime')
+depends=(java-runtime python libsecret)
makedepends=(tar)
provides=()
conflicts=()
@@ -17,24 +20,39 @@ backup=()
options=()
install=
changelog=
-_eclipsever="oxygen"
-source_i686=("http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/${_eclipsever}/${pkgver}/papyrus-${_eclipsever}-${pkgver}-linux32.tar.gz")
-md5sums_i686=('608176cd672d425ce4d21f9cf2cf0149')
-md5sums_x86_64=('dcf605876567afcfd5d1a3a7ce617e5b')
-source_x86_64=("http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/${_eclipsever}/${pkgver}/papyrus-${_eclipsever}-${pkgver}-linux64.tar.gz")
+_eclipsever='2020-06'
+md5sums=(
+ '2998813786cd8b03b72e07eb048b99e3'
+ '411d949e9e15e4e60f01f66091e18421'
+ 'd1d0f87c71fccdcca0bec57ccf36c2f0'
+)
+source=(
+ "http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/modeling/mdt/papyrus/rcp/${_eclipsever}/${pkgver}/papyrus-${_eclipsever}-${pkgver}-linux64.tar.gz"
+ "papyrus.png"
+ "papyrus.desktop"
+)
noextract=()
build() {
cd $srcdir
tar -xvzf papyrus-${_eclipsever}-${pkgver}-linux*.tar.gz
mkdir -p $srcdir/usr/bin/
- echo -e '#!/bin/sh\nexec /usr/lib/papyrus/papyrus' > $srcdir/usr/bin/papyrus
+ echo -e '#!/bin/sh\nexec /usr/lib/papyrus/papyrus' > $srcdir/papyrus
}
package() {
cd $srcdir
mkdir -p $pkgdir/usr/lib/papyrus
- mv $srcdir/Papyrus/* $pkgdir/usr/lib/papyrus/
mkdir -p $pkgdir/usr/bin/
- install -m775 $srcdir/usr/bin/papyrus $pkgdir/usr/bin/papyrus
-}
+ mkdir -p $pkgdir/usr/share/icons
+ mkdir -p $pkgdir/usr/share/applications
+
+ install -m644 papyrus.png $pkgdir/usr/share/icons/
+ install -m755 papyrus.desktop $pkgdir/usr/share/applications/
+
+ cd "$srcdir/Papyrus"
+ find . -type f -exec install -vDm755 {} $pkgdir/usr/lib/papyrus/{} \;
+
+ install -m755 $srcdir/papyrus $pkgdir/usr/bin/
+ # mv $pkgdir/usr/lib/papyrus/icon.xpm $pkgdir/usr/share/icons/papyrus.xpm
+} \ No newline at end of file
diff --git a/papyrus.desktop b/papyrus.desktop
new file mode 100755
index 000000000000..5042721f9864
--- /dev/null
+++ b/papyrus.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Categories=Development;Office;ProjectManagement;
+Comment=Papyrus is an open-source UML tool based on Eclipse.
+Exec=/usr/bin/papyrus
+GenericName=UML Designer
+Icon=/usr/share/icons/papyrus.png
+Name=Eclipse Papyrus
+StartupNotify=true
+Terminal=false
+Type=Application
+Version=1.1
diff --git a/papyrus.png b/papyrus.png
new file mode 100644
index 000000000000..804639d5f742
--- /dev/null
+++ b/papyrus.png
Binary files differ