summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorÉric NICOLAS (ccjmne)2024-02-07 00:49:25 +0100
committerÉric NICOLAS (ccjmne)2024-02-07 00:49:25 +0100
commitb9bc7ec73d2913cf5d381512b86c65ac248e03eb (patch)
treeb249983e0f79284ad6c0e4a90b00641ef52b07bb
downloadaur-b9bc7ec73d2913cf5d381512b86c65ac248e03eb.tar.gz
Create initial PKGBUILD
Seems to be working. Will still require going over some documentation to make sure it's doing nothing wrong.
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..939e17d0d28b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=par-git
+pkgver=1.53.0.r0.eb0590f
+pkgrel=1
+pkgdesc="Adam M. Costello's paragraph reformatter, vaguely similar to fmt, but better."
+arch=('x86_64')
+url=""
+license=('MIT')
+groups=()
+depends=()
+makedepends=('git' 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+_repo=upstream
+source=('upstream::git+https://bitbucket.org/amc-nicemice/par.git')
+noextract=()
+md5sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$_repo"
+
+# The examples below are not absolute and need to be adapted to each repo. The
+# primary goal is to generate version numbers that will increase according to
+# pacman's version comparisons with later commits to the repo. The format
+# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
+# are not available, is recommended.
+
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ echo "?"
+}
+
+build() {
+ cd "$_repo"
+ make -f protoMakefile CC="cc -c" LINK1="cc" LINK2="-o" RM="rm" JUNK="" $*
+}
+
+check() {
+ cd "$_repo"
+ ./test-par ./par
+}
+
+package() {
+ cd "$_repo"
+ install -D -m755 "par" "$pkgdir/usr/bin/par"
+}