summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Schleußer2018-08-31 17:00:24 +0200
committerJonathan Schleußer2018-08-31 17:00:24 +0200
commitf0af30ab6df8d1fc3eec2f0cf58556f63d41dea4 (patch)
tree75fa8f094a3ac70f5ff51e3be9b6e8ddf2167fcc
parent1c56187f3c1fd2eee5750284d66297c66bb47bdb (diff)
downloadaur-parabot-git.tar.gz
Don't overwrite existing files
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3732e14101a5..e37c931e11c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ package() {
cd parabot
mkdir -p "$pkgdir"/usr/lib/systemd/user/ "$pkgdir"/usr/bin ~/.config/parabot/ ~/.local/share/parabot/
install -Dm755 target/release/parabot "$pkgdir"/usr/bin
- install -Dm644 "$srcdir"/parabot.service "$pkgdir"/usr/lib/systemd/user/
- install -Dm644 example_conf.toml ~/.config/parabot/conf.toml
- install -Dm644 parabot_empty.db ~/.local/share/parabot/parabot.db
+ cp -n "$srcdir"/parabot.service "$pkgdir"/usr/lib/systemd/user/
+ cp -n example_conf.toml ~/.config/parabot/conf.toml
+ cp -n parabot_empty.db ~/.local/share/parabot/parabot.db
}