summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Schleußer2018-01-12 15:21:15 +0100
committerJonathan Schleußer2018-01-12 15:22:05 +0100
commita0812aa1acf86c47a12932816baa8cae45a35653 (patch)
treef9f4e9e9b033b8c7e77dc9b6fc9c8aeed7709a3e
parentf5df83b786b0c8096b41636f63c92c49488b91c1 (diff)
downloadaur-a0812aa1acf86c47a12932816baa8cae45a35653.tar.gz
Use files from git repo
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--config.toml27
-rw-r--r--parabot.dbbin36864 -> 0 bytes
4 files changed, 6 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdfaaae764dd..0d654fa0cabe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = parabot-git
pkgdesc = Rust irc bot
pkgver = r70.d2b8d7ai
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ParadoxSpiral/parabot
arch = i686
arch = x86_64
@@ -13,12 +13,8 @@ pkgbase = parabot-git
provides = parabot
source = git+https://github.com/ParadoxSpiral/parabot
source = parabot.service
- source = config.toml
- source = parabot.db
sha256sums = SKIP
sha256sums = 4ebb72cf950f8b67864bdf80bf911ca069fdc393f35dccb2ff7b9406a5934686
- sha256sums = c750a42610be544ac78ebd721c1d30a26e24823306b3800370be575ba58518a5
- sha256sums = c9d8c48d2ed33fd624498d7e8c002350ecc95a01a2d53c8fab8a62d40344033f
pkgname = parabot-git
diff --git a/PKGBUILD b/PKGBUILD
index 13ec60a0d59f..f597d400672e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=parabot-git
provides=(parabot)
pkgver=r70.d2b8d7ai
-pkgrel=1
+pkgrel=2
pkgdesc='Rust irc bot'
arch=(i686 x86_64)
url=https://github.com/ParadoxSpiral/parabot
@@ -10,13 +10,9 @@ license=(GPL3)
depends=(openssl sqlite)
makedepends=(cargo git)
source=(git+https://github.com/ParadoxSpiral/parabot
- parabot.service
- config.toml
- parabot.db)
+ parabot.service)
sha256sums=(SKIP
- 4ebb72cf950f8b67864bdf80bf911ca069fdc393f35dccb2ff7b9406a5934686
- c750a42610be544ac78ebd721c1d30a26e24823306b3800370be575ba58518a5
- c9d8c48d2ed33fd624498d7e8c002350ecc95a01a2d53c8fab8a62d40344033f)
+ 4ebb72cf950f8b67864bdf80bf911ca069fdc393f35dccb2ff7b9406a5934686)
pkgver() {
cd parabot
@@ -33,6 +29,6 @@ package() {
mkdir -p "$pkgdir"/usr/lib/systemd/user/ "$pkgdir"/usr/bin ~/.config/parabot/ ~/.local/share/parabot/
install -Dm755 target/release/parabot "$pkgdir"/usr/bin
install -Dm644 "$srcdir"/parabot.service "$pkgdir"/usr/lib/systemd/user/
- install -Dm644 "$srcdir"/config.toml ~/.config/parabot/
- install -Dm644 "$srcdir"/parabot.db ~/.local/share/parabot
+ install -Dm644 example_config.toml ~/.config/parabot/config.toml
+ install -Dm644 parabot_empty.db ~/.local/share/parabot/parabot.db
}
diff --git a/config.toml b/config.toml
deleted file mode 100644
index 1622d17e3dbe..000000000000
--- a/config.toml
+++ /dev/null
@@ -1,27 +0,0 @@
-[[server]]
-address = "irc.rizon.net"
-nickname = "parabot"
-# optional: alternative_nicknames = ["weebot"]
-nickserv_password = "test123"
-# optional: server_password = "test123"
-database = ".local/share/parabot/parabot.db" # Different servers may populate the same db
-owners = ["nick1", "nick2"] # a list of nicks that may exec priviledged cmds
-# optional: weather_api_secret = "secret" a https://darksky.net API secret
-# optional: geocoding_api_key = "key" a https://developer.mapquest.com API key
-# optional: wolframalpha_appid = "appid" a https://www.wolframalpha.com/ appid
-# pütional: youtube_api_key = "key" a https://console.developers.google.com api key
-# optional: google_search_id = "id" a http://cse.google.com/all id
-# optional: google_search_key = "key" a https://developers.google.com/custom-search/json-api/v1/introduction key
-# optional: max_burst_messages = 4
-# optional: burst_window_length = 8 # Time between bursts in seconds
-# optional: wormy_nick = "nick" # nick of a wormy hivemind bot
-port = 6697
- [[server.channel]]
- name = "#c"
- # optional: password = "channel_key"
- # optional: url_blacklisted_domains = ["google.com"]
- modules = ["duckduckgo", "google", "jisho", "url-info", "tell", "wolframalpha", "weather",
- "wormy", "youtube", "choose"]
- [[server.channel]]
- name = "#news"
- modules = ["url-info", "weather"]
diff --git a/parabot.db b/parabot.db
deleted file mode 100644
index aae7c5d7295b..000000000000
--- a/parabot.db
+++ /dev/null
Binary files differ