summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Schleußer2018-01-12 15:02:26 +0100
committerJonathan Schleußer2018-01-12 15:07:37 +0100
commitf5df83b786b0c8096b41636f63c92c49488b91c1 (patch)
treeab7291f1b6a9cdace889a4f25522be81f35c6144
downloadaur-f5df83b786b0c8096b41636f63c92c49488b91c1.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD38
-rw-r--r--config.toml27
-rw-r--r--parabot.dbbin0 -> 36864 bytes
-rw-r--r--parabot.service12
5 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bdfaaae764dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = parabot-git
+ pkgdesc = Rust irc bot
+ pkgver = r70.d2b8d7ai
+ pkgrel = 1
+ url = https://github.com/ParadoxSpiral/parabot
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ makedepends = git
+ depends = openssl
+ depends = sqlite
+ provides = parabot
+ source = git+https://github.com/ParadoxSpiral/parabot
+ source = parabot.service
+ source = config.toml
+ source = parabot.db
+ sha256sums = SKIP
+ sha256sums = 4ebb72cf950f8b67864bdf80bf911ca069fdc393f35dccb2ff7b9406a5934686
+ sha256sums = c750a42610be544ac78ebd721c1d30a26e24823306b3800370be575ba58518a5
+ sha256sums = c9d8c48d2ed33fd624498d7e8c002350ecc95a01a2d53c8fab8a62d40344033f
+
+pkgname = parabot-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13ec60a0d59f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+#Maintainer: ParadoxSpiral <skullduggery@riseup.net>
+pkgname=parabot-git
+provides=(parabot)
+pkgver=r70.d2b8d7ai
+pkgrel=1
+pkgdesc='Rust irc bot'
+arch=(i686 x86_64)
+url=https://github.com/ParadoxSpiral/parabot
+license=(GPL3)
+depends=(openssl sqlite)
+makedepends=(cargo git)
+source=(git+https://github.com/ParadoxSpiral/parabot
+ parabot.service
+ config.toml
+ parabot.db)
+sha256sums=(SKIP
+ 4ebb72cf950f8b67864bdf80bf911ca069fdc393f35dccb2ff7b9406a5934686
+ c750a42610be544ac78ebd721c1d30a26e24823306b3800370be575ba58518a5
+ c9d8c48d2ed33fd624498d7e8c002350ecc95a01a2d53c8fab8a62d40344033f)
+
+pkgver() {
+ cd parabot
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd parabot
+ cargo build --release
+}
+
+package() {
+ cd parabot
+ mkdir -p "$pkgdir"/usr/lib/systemd/user/ "$pkgdir"/usr/bin ~/.config/parabot/ ~/.local/share/parabot/
+ install -Dm755 target/release/parabot "$pkgdir"/usr/bin
+ install -Dm644 "$srcdir"/parabot.service "$pkgdir"/usr/lib/systemd/user/
+ install -Dm644 "$srcdir"/config.toml ~/.config/parabot/
+ install -Dm644 "$srcdir"/parabot.db ~/.local/share/parabot
+}
diff --git a/config.toml b/config.toml
new file mode 100644
index 000000000000..1622d17e3dbe
--- /dev/null
+++ b/config.toml
@@ -0,0 +1,27 @@
+[[server]]
+address = "irc.rizon.net"
+nickname = "parabot"
+# optional: alternative_nicknames = ["weebot"]
+nickserv_password = "test123"
+# optional: server_password = "test123"
+database = ".local/share/parabot/parabot.db" # Different servers may populate the same db
+owners = ["nick1", "nick2"] # a list of nicks that may exec priviledged cmds
+# optional: weather_api_secret = "secret" a https://darksky.net API secret
+# optional: geocoding_api_key = "key" a https://developer.mapquest.com API key
+# optional: wolframalpha_appid = "appid" a https://www.wolframalpha.com/ appid
+# pütional: youtube_api_key = "key" a https://console.developers.google.com api key
+# optional: google_search_id = "id" a http://cse.google.com/all id
+# optional: google_search_key = "key" a https://developers.google.com/custom-search/json-api/v1/introduction key
+# optional: max_burst_messages = 4
+# optional: burst_window_length = 8 # Time between bursts in seconds
+# optional: wormy_nick = "nick" # nick of a wormy hivemind bot
+port = 6697
+ [[server.channel]]
+ name = "#c"
+ # optional: password = "channel_key"
+ # optional: url_blacklisted_domains = ["google.com"]
+ modules = ["duckduckgo", "google", "jisho", "url-info", "tell", "wolframalpha", "weather",
+ "wormy", "youtube", "choose"]
+ [[server.channel]]
+ name = "#news"
+ modules = ["url-info", "weather"]
diff --git a/parabot.db b/parabot.db
new file mode 100644
index 000000000000..aae7c5d7295b
--- /dev/null
+++ b/parabot.db
Binary files differ
diff --git a/parabot.service b/parabot.service
new file mode 100644
index 000000000000..ddbfd74070fa
--- /dev/null
+++ b/parabot.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=parabot irc bot
+After=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/env RUST_BACKTRACE=1 /usr/bin/parabot ~/.config/parabot/config.toml
+WorkingDirectory=%h
+Restart=always
+
+[Install]
+WantedBy=default.target