summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2015-06-08 01:24:39 -0700
committerTyler Veness2015-06-08 01:41:51 -0700
commit6567d3489e1caded406584532b971c6db3dc4421 (patch)
treeb5821c86fbcc66980f62d741f5973876d870afe3
downloadaur-6567d3489e1caded406584532b971c6db3dc4421.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..726e3b24c272
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by makepkg 4.2.1
+# Tue Jun 2 10:12:43 UTC 2015
+pkgbase = paradiseo
+ pkgdesc = Evolving Objects is a template-based, ANSI-C++ evolutionary computation library which helps you to write your own stochastic optimization algorithms insanely fast.
+ pkgver = 2.0.1
+ pkgrel = 3
+ url = http://eodev.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = make
+ makedepends = cmake
+ options = staticlibs
+ source = https://gforge.inria.fr/frs/download.php/31732/ParadisEO-2.0.1.tar.gz
+ md5sums = 89f875b3f92abdb64b26c6c207fef346
+
+pkgname = paradiseo
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb4702f86f20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Tyler Veness <calcmogul at gmail dot com>
+# Contributor: MCMic <come.bernigaud@laposte.net>
+
+pkgname=paradiseo
+pkgver=2.0.1
+pkgrel=3
+pkgdesc="Evolving Objects is a template-based, ANSI-C++ evolutionary computation library which helps you to write your own stochastic optimization algorithms insanely fast."
+arch=('i686' 'x86_64')
+url="http://eodev.sourceforge.net/"
+license=('LGPL')
+depends=()
+makedepends=('make' 'cmake')
+conflicts=()
+source=("https://gforge.inria.fr/frs/download.php/31732/ParadisEO-${pkgver}.tar.gz")
+md5sums=('89f875b3f92abdb64b26c6c207fef346')
+options=('staticlibs')
+
+prepare() {
+ cd $srcdir/ParadisEO-2.0
+
+ # Fix conflict with lib64 symlink
+ sed -i 's/lib64/lib/' cmake/Config.cmake
+}
+
+build() {
+ cd $srcdir/ParadisEO-2.0
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release .
+ make
+}
+
+package() {
+ cd $srcdir/ParadisEO-2.0
+
+ make install DESTDIR=$pkgdir
+}
+