summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOndrej Patrovic2016-10-28 09:02:31 -0400
committerOndrej Patrovic2016-10-28 09:02:31 -0400
commit7ba8a74c68b031bef5c27da344f46654c872c908 (patch)
treea9a3252f4b4c1fa23bd4ae7f98c2c028951dff9b
parent272420f265a2a2db173094fefb75b213c6e80f70 (diff)
downloadaur-7ba8a74c68b031bef5c27da344f46654c872c908.tar.gz
Added mount scripts & cleaned up PKGBUILD
-rw-r--r--PKGBUILD55
-rwxr-xr-xdkms.conf.in3
-rwxr-xr-xmount.paragon-ufsd2
-rw-r--r--paragon-ufsd-dkms.install2
-rw-r--r--paragon-ufsd.conf1
5 files changed, 35 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42028092d2cc..f0a5df85311e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,56 +4,59 @@ _pkgname=paragon-ufsd
pkgname=${_pkgname}-dkms-git
_pkgver=9.4
pkgver=9.4.r5.g5407244
-pkgrel=1
-pkgdesc='Paragon NTFS & HFS+ for Linux driver.'
+pkgrel=2
+_srcdir=${_pkgname}-${pkgver}
+pkgdesc='Paragon NTFS & HFS+ for Linux driver (DKMS)'
arch=('i686' 'x86_64')
url='https://www.paragon-software.com/home/ntfs-linux-per/'
license=('custom')
depends=('dkms')
-provides=("${_pkgname}=${_pkgver}")
-conflicts=(${_pkgname} "${_pkgname}-dkms" "ufsd-module-dkms")
-makedepends=('tar' 'linux-headers>2.6.35')
-optdepends=("paragon-ufsd-tools: NTFS & HFS+ utilities")
+provides=("${_pkgname}=${_pkgver}" "${_pkgname}-dkms=${_pkgver}")
+conflicts=(${_pkgname} "${_pkgname}-dkms" 'ufsd-module-dkms' 'ntfs-3g' 'ntfsprogs')
+makedepends=('tar' 'sed' 'git' 'findutils' 'linux-headers>2.6.35' 'linux-headers<4.9')
+optdepends=('paragon-ufsd-tools: NTFS & HFS+ utilities (requires purchase)')
backup=("etc/modules-load.d/${_pkgname}.conf")
install=paragon-ufsd-dkms.install
-_source="Paragon-147-FRE_NTFS_Linux_${_pkgver}_Express.tar.gz"
+noextract=("Paragon-147-FRE_NTFS_Linux_${_pkgver}_Express.tar.gz")
source=(
- "dkms.conf.in"
- "http://dl.paragon-software.com/esd/${_source}"
- "${_pkgname}::git+https://github.com/ondr3j/${_pkgname}.git"
+ 'dkms.conf.in'
+ 'paragon-ufsd.conf'
+ 'mount.paragon-ufsd'
+ "http://dl.paragon-software.com/esd/${noextract[0]}"
+ "${_srcdir}::git+https://github.com/ondr3j/${_pkgname}.git"
)
-noextract=("${_source}")
-
-sha256sums=('cc55c9972379573d20e12ca1a48532e8f020045d4b62a9f9c7e8140b973163d0'
- '8cafe1a9a9ab083c90f5fdbee88d2df8f2fbeb057d7a67bd7b7abc3cd123f506'
- 'SKIP')
+sha256sums=(
+ 'f46362ce51cdbacd4b20495905d18598ff3223d36e9c6a6508e434eac8998687'
+ '59e584e80168f42f7887872a8c8dc14ef40f1f949138302d9437ae9bcc2c8aba'
+ '6c5521b6b0eeb9520af02f8299920b7a325c5ff3ea9a42ca5576b3c3aed1d0bb'
+ '8cafe1a9a9ab083c90f5fdbee88d2df8f2fbeb057d7a67bd7b7abc3cd123f506'
+ 'SKIP'
+)
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "${_srcdir}"
echo "${_pkgver}.r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${srcdir}"
- echo "ufsd" > "${_pkgname}.conf"
-
- cd "${_pkgname}"
- tar --wildcards --no-anchored --strip=1 -xf "${srcdir}/${_source}" "*.bin"
+ cd "${_srcdir}"
sed -e "s/@PACKAGE_VERSION@/${pkgver}/" "${srcdir}/dkms.conf.in" > dkms.conf
+ tar --wildcards --no-anchored --strip=1 -xf "${srcdir}/${noextract[0]}" "*.bin"
}
package() {
- cd "${srcdir}"
- install -Dm 644 "${_pkgname}.conf" "${pkgdir}/etc/modules-load.d/${_pkgname}.conf"
+ install -Dm 755 mount.paragon-ufsd "${pkgdir}/usr/bin/mount.paragon-ufsd"
+ install -Dm 644 paragon-ufsd.conf "${pkgdir}/etc/modules-load.d/paragon-ufsd.conf"
- cd "${_pkgname}"
+ cd "${_srcdir}"
+ install -Dm 644 License.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
find . -type f -exec install -Dm 644 {,"${pkgdir}/usr/src/${_pkgname}-${pkgver}/"}{} \;
- # Restore the execute bit on the configuration script
chmod +x "${pkgdir}/usr/src/${_pkgname}-${pkgver}/configure"
- install -Dm 644 License.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ ln -rs "${pkgdir}/usr/bin/mount.paragon-ufsd" "${pkgdir}/usr/bin/mount.ntfs"
+ ln -rs "${pkgdir}/usr/bin/mount.paragon-ufsd" "${pkgdir}/usr/bin/mount.hfsplus"
}
diff --git a/dkms.conf.in b/dkms.conf.in
index 8e6c9b62131d..51dd2be1cd23 100755
--- a/dkms.conf.in
+++ b/dkms.conf.in
@@ -2,7 +2,8 @@ PACKAGE_NAME="paragon-ufsd"
PACKAGE_VERSION="@PACKAGE_VERSION@"
AUTOINSTALL="yes"
MAKE="./configure --with-kb-dir=$kernel_source_dir --with-kernelversion=$kernelver && make driver"
+CLEAN="[ ! -f Makefile ] || make clean"
BUILT_MODULE_NAME[0]="ufsd"
BUILT_MODULE_NAME[1]="jnl"
DEST_MODULE_LOCATION[0]="/kernel/fs/ufsd"
-DEST_MODULE_LOCATION[1]="/kernel/fs/ufsd" \ No newline at end of file
+DEST_MODULE_LOCATION[1]="/kernel/fs/ufsd"
diff --git a/mount.paragon-ufsd b/mount.paragon-ufsd
new file mode 100755
index 000000000000..ed839795018f
--- /dev/null
+++ b/mount.paragon-ufsd
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/mount -t ufsd "$@"
diff --git a/paragon-ufsd-dkms.install b/paragon-ufsd-dkms.install
index 5f4dc3d4a6c0..11d31cb308d5 100644
--- a/paragon-ufsd-dkms.install
+++ b/paragon-ufsd-dkms.install
@@ -19,4 +19,4 @@ pre_remove() {
dkms remove -m paragon-ufsd/${1%%-*} --all
depmod -a &> /dev/null
-} \ No newline at end of file
+}
diff --git a/paragon-ufsd.conf b/paragon-ufsd.conf
new file mode 100644
index 000000000000..568ee29010fc
--- /dev/null
+++ b/paragon-ufsd.conf
@@ -0,0 +1 @@
+ufsd