summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKokaKiwi2024-01-29 11:21:20 +0100
committerKokaKiwi2024-01-29 11:21:20 +0100
commit979e13340c4d935a681f4ad71bded9f85ca4ac1d (patch)
tree3192d5eee15eb22d3b88e34ed7213f78875c7538
parent6c6749b2b1d748881646b46b793fce1e2d79328a (diff)
downloadaur-979e13340c4d935a681f4ad71bded9f85ca4ac1d.tar.gz
upgpkg: parallel-hashmap 1.3.12-1
upstream release
-rw-r--r--.SRCINFO14
-rw-r--r--0001-makepkg-Use-system-gtest.patch47
-rw-r--r--PKGBUILD19
3 files changed, 36 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 040391273df1..03569a801807 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = parallel-hashmap
pkgdesc = A family of header-only, very fast and memory-friendly hashmap and btree containers.
- pkgver = 1.3.11
+ pkgver = 1.3.12
pkgrel = 1
url = https://greg7mdp.github.io/parallel-hashmap/
arch = any
- license = Apache
+ license = Apache-2.0
makedepends = cmake
makedepends = make
makedepends = git
makedepends = gtest
optdepends = python: For Conan python package manager.
- source = parallel-hashmap-1.3.11.tar.gz::https://github.com/greg7mdp/parallel-hashmap/archive/be6a2c79857c9ea76760ca6ce782e1609713428e.tar.gz
+ source = parallel-hashmap-1.3.12.tar.gz::https://github.com/greg7mdp/parallel-hashmap/archive/v1.3.12.tar.gz
source = 0001-makepkg-Use-system-gtest.patch
- sha256sums = 3844b03a34316c93461f799d3a0ec748661edd3366c88d6b88dff1256ccea8b2
- sha256sums = ea86c04fcb31005826500c57672d74234792c1d1a6bbe482758597bbeffc0ceb
- b2sums = 4acd3d8842941ba5f7dd61422f7955a01a3851d0113dbc8f497ee16af27e0d2f43993e214654ccb1ce7e5cd0fc31282c34e7f2619616f28e66691d0d04ff7062
- b2sums = 29df10b97cfcc8987c4fba3eb747fc3fb8cedc742431de8e59af5ef0e543d6f00458a0f55fe37cb9199051326ce2d95a394daed31e039419b38faaee3cccfa35
+ sha256sums = 0cc203144321924cfbfcc401f42d8204c0dd24e2760c7a1c091baa16d9777c08
+ sha256sums = 8bd643ef83f8b5681ca875da1aec361846d9262a4d038921333ff50240b75f51
+ b2sums = e26c6b70c3cf1b55a0c8a7f002899d5cf5f709b434939447800d551ccd9a9ff2d9ed50b52bd7f4ca0c1cae0d080c8294527894f220db1a01c726a79ede10f188
+ b2sums = 3d6b8f54801b43f68f2ca224e4844dde1ed66ae51b145e79579eb2db123f8ae0e38fb7d16fbbadea237275d65a53d72bbb83621808d0c6facc5d61ead0771f3a
pkgname = parallel-hashmap
diff --git a/0001-makepkg-Use-system-gtest.patch b/0001-makepkg-Use-system-gtest.patch
index 9de3beaf8873..25d3a3f01112 100644
--- a/0001-makepkg-Use-system-gtest.patch
+++ b/0001-makepkg-Use-system-gtest.patch
@@ -1,45 +1,38 @@
-From bce0edec2ede4b5951914d01e4021d21e7fed225 Mon Sep 17 00:00:00 2001
-From: Julianne H <julianne.hervier@qonfucius.team>
-Date: Fri, 3 Mar 2023 15:24:02 +0100
+From 8b95aad477c32ebefeee5c76092dee38c7c4b0f7 Mon Sep 17 00:00:00 2001
+From: KokaKiwi <kokakiwi+git@kokakiwi.net>
+Date: Mon, 29 Jan 2024 11:17:58 +0100
Subject: [PATCH] makepkg: Use system gtest
---
- CMakeLists.txt | 11 +++++++----
- 1 file changed, 7 insertions(+), 4 deletions(-)
+ CMakeLists.txt | 11 ++---------
+ 1 file changed, 2 insertions(+), 9 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 7b0a6ea..55414de 100644
+index d247c28..e964a5b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -88,16 +88,20 @@ endif()
- option(PHMAP_BUILD_TESTS "Whether or not to build the tests" ${PHMAP_MASTER_PROJECT})
- option(PHMAP_BUILD_EXAMPLES "Whether or not to build the examples" ${PHMAP_MASTER_PROJECT})
-
-+option(PHMAP_USE_SYSTEM_GTEST "Use system gtest" ON)
-+
- if(MSVC)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /bigobj")
- endif()
+@@ -98,14 +98,8 @@ endif()
if (PHMAP_BUILD_TESTS)
-+ include_directories(${PROJECT_SOURCE_DIR})
- if (NOT PHMAP_GTEST_LIBS)
-+ if (PHMAP_USE_SYSTEM_GTEST)
-+ find_package(GTest REQUIRED)
-+ set(PHMAP_GTEST_LIBS GTest::gtest GTest::gtest_main GTest::gmock)
-+ else ()
- include(cmake/DownloadGTest.cmake)
-- include_directories(${PROJECT_SOURCE_DIR})
+- include(cmake/DownloadGTest.cmake)
-
- check_target(gtest)
- check_target(gtest_main)
- check_target(gmock)
-@@ -200,4 +204,3 @@ if (PHMAP_BUILD_EXAMPLES)
+- check_target(gtest)
+- check_target(gtest_main)
+- check_target(gmock)
+- set(PHMAP_GTEST_LIBS gmock_main)
+- endif()
++ find_package(GTest REQUIRED)
++ set(PHMAP_GTEST_LIBS GTest::gtest GTest::gtest_main GTest::gmock)
+
+ enable_testing()
+
+@@ -205,4 +199,3 @@ if (PHMAP_BUILD_EXAMPLES)
target_link_libraries(ex_knucleotide Threads::Threads)
target_link_libraries(ex_bench Threads::Threads)
endif()
-
--
-2.40.0
+2.43.0
diff --git a/PKGBUILD b/PKGBUILD
index 5ecf589cc79e..2d8a879bd50f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,30 @@
# Maintainer: KokaKiwi <kokakiwi+aur at kokakiwi dot net>
pkgname=parallel-hashmap
-pkgver=1.3.11
-_pkgrev=be6a2c79857c9ea76760ca6ce782e1609713428e
+pkgver=1.3.12
pkgrel=1
pkgdesc='A family of header-only, very fast and memory-friendly hashmap and btree containers.'
url='https://greg7mdp.github.io/parallel-hashmap/'
-license=('Apache')
+license=('Apache-2.0')
arch=('any')
makedepends=('cmake' 'make' 'git' 'gtest')
optdepends=('python: For Conan python package manager.')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/greg7mdp/parallel-hashmap/archive/$_pkgrev.tar.gz"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/greg7mdp/parallel-hashmap/archive/v$pkgver.tar.gz"
0001-makepkg-Use-system-gtest.patch)
-sha256sums=('3844b03a34316c93461f799d3a0ec748661edd3366c88d6b88dff1256ccea8b2'
- 'ea86c04fcb31005826500c57672d74234792c1d1a6bbe482758597bbeffc0ceb')
-b2sums=('4acd3d8842941ba5f7dd61422f7955a01a3851d0113dbc8f497ee16af27e0d2f43993e214654ccb1ce7e5cd0fc31282c34e7f2619616f28e66691d0d04ff7062'
- '29df10b97cfcc8987c4fba3eb747fc3fb8cedc742431de8e59af5ef0e543d6f00458a0f55fe37cb9199051326ce2d95a394daed31e039419b38faaee3cccfa35')
+sha256sums=('0cc203144321924cfbfcc401f42d8204c0dd24e2760c7a1c091baa16d9777c08'
+ '8bd643ef83f8b5681ca875da1aec361846d9262a4d038921333ff50240b75f51')
+b2sums=('e26c6b70c3cf1b55a0c8a7f002899d5cf5f709b434939447800d551ccd9a9ff2d9ed50b52bd7f4ca0c1cae0d080c8294527894f220db1a01c726a79ede10f188'
+ '3d6b8f54801b43f68f2ca224e4844dde1ed66ae51b145e79579eb2db123f8ae0e38fb7d16fbbadea237275d65a53d72bbb83621808d0c6facc5d61ead0771f3a')
prepare() {
- cd "$pkgname-$_pkgrev"
+ cd "$pkgname-$pkgver"
patch -Np1 -i "$srcdir/0001-makepkg-Use-system-gtest.patch"
}
build() {
rm -rf build
- cmake -B build -S "$pkgname-$_pkgrev" \
+ cmake -B build -S "$pkgname-$pkgver" \
-D CMAKE_BUILD_TYPE=None \
-D CMAKE_INSTALL_PREFIX=/usr \
-D PHMAP_BUILD_TESTS=ON \