summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Pharoah2021-02-07 15:31:57 -0500
committerMatt Pharoah2021-02-07 15:33:54 -0500
commit99d51508470bb5b7c369fc319a4396c96b2f9c6d (patch)
tree74bd153925b42181d63cf6bfba23ef45c20d5fac
downloadaur-99d51508470bb5b7c369fc319a4396c96b2f9c6d.tar.gz
Version 2.0.2
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
-rwxr-xr-xparallel-launcher-2.0.2.tar.gzbin0 -> 129734 bytes
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a0ef61773b9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = parallel-launcher
+ pkgdesc = A simple easy-to-use launcher for the ParallelN64 and Mupen64Plus-Next emulators
+ pkgver = 2.0.2
+ pkgrel = 0
+ url = https://blueprint64.ca/parallel-launcher
+ arch = x86_64
+ license = GPL2
+ makedepends = gcc
+ makedepends = qt5-declarative
+ makedepends = make
+ depends = glibc
+ depends = libstdc++5
+ depends = gcc-libs
+ depends = qt5-base
+ depends = qt5-svg
+ depends = sdl2
+ depends = findutils
+ source = parallel-launcher-2.0.2.tar.gz
+ md5sums = 57d25f68a1518ccb9ed37bb68a0ee908
+
+pkgname = parallel-launcher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a848ac909b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Matt Pharoah <mtpharoah@gmail.com>
+pkgname=parallel-launcher
+pkgver=2.0.2
+pkgrel=0
+epoch=
+pkgdesc='A simple easy-to-use launcher for the ParallelN64 and Mupen64Plus-Next emulators'
+arch=('x86_64')
+url='https://blueprint64.ca/parallel-launcher'
+license=('GPL2')
+groups=()
+depends=(
+ 'glibc'
+ 'libstdc++5'
+ 'gcc-libs'
+ 'qt5-base'
+ 'qt5-svg'
+ 'sdl2'
+ 'findutils'
+)
+makedepends=(
+ 'gcc'
+ 'qt5-declarative'
+ 'make'
+)
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=('parallel-launcher-2.0.2.tar.gz')
+noextract=()
+md5sums=('57d25f68a1518ccb9ed37bb68a0ee908')
+validpgpkeys=()
+
+build() {
+ qmake-qt5 app.pro -spec linux-g++
+ make
+}
+
+package() {
+ install -D parallel-launcher $pkgdir/usr/bin/parallel-launcher
+ install -D parallel-launcher.desktop $pkgdir/usr/share/applications/parallel-launcher.desktop
+ install -D data/appicon.svg $pkgdir/usr/share/parallel-launcher/appicon.svg
+}
diff --git a/parallel-launcher-2.0.2.tar.gz b/parallel-launcher-2.0.2.tar.gz
new file mode 100755
index 000000000000..bc9d01c99b2a
--- /dev/null
+++ b/parallel-launcher-2.0.2.tar.gz
Binary files differ