summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Phillips2022-11-19 21:18:06 +1300
committerDavid Phillips2022-11-19 21:18:06 +1300
commit8947586cab6d887b57d31a4c9064c291d1ff84af (patch)
tree7f0c0aa625d11877a12101ba9c92f96e41faccec
parent5c7a522141ae7d64a55069e7f6becb8f9e8a28d5 (diff)
downloadaur-paramano.tar.gz
Bump to 0.72 with fixes
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Add-missing-harfbuzz-include-dir-to-search-path.patch27
-rw-r--r--PKGBUILD19
3 files changed, 10 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d38ca311323..a507335d076f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = paramano
pkgdesc = Docking battery monitor and CPU governer controller (fork of trayfreq)
- pkgver = 0.71
+ pkgver = 0.72
pkgrel = 1
- url = https://git.nah.nz/paramano/
+ url = https://gitlab.com/dphillips/paramano
arch = i686
arch = x86_64
arch = armv6h
@@ -10,10 +10,7 @@ pkgbase = paramano
depends = gtk3
depends = sudo
backup = etc/paramano.conf
- source = https://git.nah.nz/paramano/snapshot/paramano-0.71.tar.xz
- source = 0001-Add-missing-harfbuzz-include-dir-to-search-path.patch
- sha512sums = 03b885a35429d04b6ce9212b7fe95e7f7e2d7e6fdbae7ec08f47bed1ff94f2d6e596f462d511ed5ae8f29f82c272b4614701661f9ca1613d33fb14e97b8db2c6
- sha512sums = 44f10d13dc71ef9022311e3ae729d02749012961eb653a52d652fd4e8b4e43497ffee7131a626bd5e44258087183f2b7419d5881859d2de94a22250457c2d5a4
+ source = git+https://gitlab.com/dphillips/paramano.git#tag=0.72
+ sha512sums = SKIP
pkgname = paramano
-
diff --git a/0001-Add-missing-harfbuzz-include-dir-to-search-path.patch b/0001-Add-missing-harfbuzz-include-dir-to-search-path.patch
deleted file mode 100644
index dd34106457ee..000000000000
--- a/0001-Add-missing-harfbuzz-include-dir-to-search-path.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From a8dd26bec6ce2790c421d5973fc0335042875922 Mon Sep 17 00:00:00 2001
-From: David Phillips <david@sighup.nz>
-Date: Wed, 9 Oct 2019 20:11:43 +1300
-Subject: [PATCH] Add missing harfbuzz include dir to search path.
-
-It appears that Arch Linux has either moved harfbuzz headers, or is newly
-depending on harbuzz from pango. This patch includes the harfbuzz include dir
-in CFLAGS.
----
- config.mk | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/config.mk b/config.mk
-index 9b68792..af91126 100644
---- a/config.mk
-+++ b/config.mk
-@@ -42,6 +42,7 @@ DEPS += bat_tray.h \
- CFLAGS += -I/usr/include/gtk-3.0 \
- -I/usr/lib/gtk-3.0/include \
- -I/usr/include/pango-1.0 \
-+ -I/usr/include/harfbuzz \
- -I/usr/include/cairo \
- -I/usr/include/gdk-pixbuf-2.0 \
- -I/usr/include/atk-1.0 \
---
-2.23.0
-
diff --git a/PKGBUILD b/PKGBUILD
index 6142aa1f671d..bb4de637cedc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,21 @@
# Maintainer: David Phillips (aka phillid) <dbphillipsnz at _remove this part if you want_ gmail dot com>
pkgname=paramano
-pkgver=0.71
+pkgver=0.72
pkgrel=1
pkgdesc="Docking battery monitor and CPU governer controller (fork of trayfreq)"
arch=('i686' 'x86_64' 'armv6h')
-url="https://git.nah.nz/${pkgname}/"
+url="https://gitlab.com/dphillips/${pkgname}"
license=('GPL')
depends=('gtk3' 'sudo')
-source=("https://git.nah.nz/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.xz"
- "0001-Add-missing-harfbuzz-include-dir-to-search-path.patch")
-sha512sums=('03b885a35429d04b6ce9212b7fe95e7f7e2d7e6fdbae7ec08f47bed1ff94f2d6e596f462d511ed5ae8f29f82c272b4614701661f9ca1613d33fb14e97b8db2c6'
- '44f10d13dc71ef9022311e3ae729d02749012961eb653a52d652fd4e8b4e43497ffee7131a626bd5e44258087183f2b7419d5881859d2de94a22250457c2d5a4')
+source=("git+${url}.git#tag=${pkgver}")
+sha512sums=('SKIP')
backup=('etc/paramano.conf')
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -Np1 -i "${srcdir}/0001-Add-missing-harfbuzz-include-dir-to-search-path.patch"
-}
-
build() {
- make -C "${srcdir}/${pkgname}-${pkgver}" all
+ make -C "${srcdir}/${pkgname}" all
}
package() {
- make -C "${srcdir}/${pkgname}-${pkgver}" install DESTDIR="${pkgdir}"
+ make -C "${srcdir}/${pkgname}" install DESTDIR="${pkgdir}"
}