summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgameslayer2022-12-26 15:13:37 +1000
committergameslayer2022-12-26 15:13:37 +1000
commit18e9bef06f33b58a3706bf5a71c7ed3868dadabc (patch)
tree217278ae785f50f39d7a61ad5ef0bd8f73c25473
parent7038d46dd76eccb96126646189e1eb1b3d064471 (diff)
downloadaur-18e9bef06f33b58a3706bf5a71c7ed3868dadabc.tar.gz
AUR Hotfix only. - Added launch script for package manager use only, this will also be used to resolve the KDE launch issue as I make some changes to the PKGBUILD file on the AUR. The package will remain as the same version so users affected by the issue will just need to clear their cache and reinstall the AUR package.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 7 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ab6af24dfbb..782cbd0e11aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = paramountplus
pkgdesc = Unnofficial ParamountPlus desktop application
pkgver = 1.0.2
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/ParamountPlus-desktop/application
arch = x86_64
license = GPL
@@ -12,7 +12,7 @@ pkgbase = paramountplus
depends = libxss
depends = git
conflicts = ParamountPlus-bin
- source = https://gitlab.com/paramountplus/application/-/archive/1.0.2-2/application-1.0.2-2.tar.bz2
- sha256sums = a1eab14be40274621d184ac15bda4308746b4059bd04aa9ea4e59d201bf4e7b2
+ source = https://gitlab.com/paramountplus/application/-/archive/1.0.2-3/application-1.0.2-3.tar.bz2
+ sha256sums = SKIP
pkgname = paramountplus
diff --git a/PKGBUILD b/PKGBUILD
index 16405ead443a..38269c9209b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=paramountplus
_pkgname=ParamountPlus
pkgver=1.0.2
-pkgrel=2
+pkgrel=3
pkgdesc="Unnofficial ParamountPlus desktop application"
arch=('x86_64')
url="https://gitlab.com/ParamountPlus-desktop/application"
@@ -10,28 +10,21 @@ depends=('libelectron' 'nss' 'gtk3' 'libxss' 'git')
makedepends=('unzip')
conflicts=("ParamountPlus-bin")
source=("https://gitlab.com/paramountplus/application/-/archive/$pkgver-$pkgrel/application-$pkgver-$pkgrel.tar.bz2")
-sha256sums=('a1eab14be40274621d184ac15bda4308746b4059bd04aa9ea4e59d201bf4e7b2')
+sha256sums=('SKIP')
package() {
for dir in application-$pkgver-$pkgrel ; do mv "${dir}" "$_pkgname" ;done
cd "$srcdir/$_pkgname"
- cat <<EOT >> $pkgname
- #!/bin/bash
- cd /opt/$_pkgname &&
- npm start
-EOT
-
- chmod +x $pkgname
+ chmod +x $pkgname.sh
ln -sf "/opt/libelectron/node_modules" "$srcdir/$_pkgname"
install -dm755 "$pkgdir/opt/$_pkgname"
install -dm755 "$pkgdir/usr/share/pixmaps"
cp -r ./ "$pkgdir/opt/$_pkgname"
cp -r "$pkgdir/opt/$_pkgname/$pkgname.svg" "$pkgdir/usr/share/pixmaps"
-
# Link to binary
install -dm755 "$pkgdir/usr/bin"
- ln -s "/opt/$_pkgname/$pkgname" "$pkgdir/usr/bin"
+ ln -s "/opt/$_pkgname/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
# Desktop Entry
install -Dm644 "$srcdir/$_pkgname/$_pkgname.desktop" \