summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2018-03-01 17:09:08 -0500
committerSolomon Choina2018-03-01 17:09:08 -0500
commit7cc13c995e0b385ff072654c6fc53bed165125b5 (patch)
tree8642371e0371ebf4f6648ea38d6b47127d50d09e
parente697206daca11270ca14192e1aca740b59b5ce6d (diff)
downloadaur-7cc13c995e0b385ff072654c6fc53bed165125b5.tar.gz
updating pkgver and updating the package style
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD48
2 files changed, 16 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e3c87d4a87f..8a17762090d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
+# Generated by mksrcinfo v8
+# Thu Mar 1 22:08:52 UTC 2018
pkgbase = paranoid-git
pkgdesc = GTK+3 configuration tool for compton.
- pkgver = 0.1
+ pkgver = r53.dc9496c
pkgrel = 1
+ epoch = 1
url = https://github.com/semplice/paranoid
arch = any
license = GPL
makedepends = git
depends = compton
provides = paranoid
+ source = git+https://github.com/natemaia/paranoid
+ sha512sums = SKIP
pkgname = paranoid-git
diff --git a/PKGBUILD b/PKGBUILD
index 7a359290497d..075fab8ac286 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,61 +1,33 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
-# for more information on packaging from GIT sources.
# Maintainer: Your Name <youremail@domain.com>
pkgname=paranoid-git
-pkgver=0.1
+pkgver=r53.dc9496c
pkgrel=1
pkgdesc="GTK+3 configuration tool for compton."
arch=('any')
url="https://github.com/semplice/paranoid"
license=('GPL')
-groups=()
depends=('compton')
makedepends=('git')
provides=('paranoid')
conflicts=()
replaces=()
-backup=()
-options=()
-install=
-source=()
-noextract=()
-md5sums=() #generate with 'makepkg -g'
+sha512sums=('SKIP')
+source=("git+https://github.com/natemaia/paranoid")
+epoch=1
-_gitroot="https://github.com/semplice/paranoid"
-_gitname='paranoid'
+pkgver() {
+ cd "paranoid"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
- #
- # BUILD HERE
- #
+ cd "$srcdir/paranoid"
python setup.py build
}
package() {
- cd "$srcdir/$_gitname-build"
+ cd "$srcdir/paranoid"
python setup.py install --root="$pkgdir/" --optimize=1
}