summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Goethel2016-06-20 00:37:51 +0200
committerOliver Goethel2016-06-20 00:37:51 +0200
commit0a0fd256fc8d8075954aea6651d27c641809b379 (patch)
tree1c794a0d674a2ea68b082c5dae6f67bffa26b3e9
parent0baf0520e0bdcba183270d59e65a37aaa50f5b93 (diff)
downloadaur-0a0fd256fc8d8075954aea6651d27c641809b379.tar.gz
upgpkg: paraview 5.1.0-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--ffmpeg3_compat.patch62
-rw-r--r--vtk-gcc6.patch44
4 files changed, 12 insertions, 133 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5d7605d9f62..46ce8079bfe9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon May 9 15:58:16 UTC 2016
+# Sun Jun 19 22:37:21 UTC 2016
pkgbase = paraview
pkgdesc = Parallel Visualization Application using VTK
- pkgver = 5.0.1
- pkgrel = 4
+ pkgver = 5.1.0
+ pkgrel = 1
url = http://www.paraview.org
arch = i686
arch = x86_64
@@ -27,17 +27,13 @@ pkgbase = paraview
depends = zlib
optdepends = python2-matplotlib: Needed to support equation rendering using MathText markup language
optdepends = python2-numpy: Needed for using some filters such as "Python Calculator"
- source = http://paraview.org/files/v5.0/ParaView-v5.0.1-source.tar.gz
+ source = http://paraview.org/files/v5.1/ParaView-v5.1.0.tar.gz
source = paraview_32bit.patch
source = 0001-find_hdf5.patch
- source = ffmpeg3_compat.patch
- source = vtk-gcc6.patch
source = paraview-desktop.patch
- sha1sums = 3d72635df84421c2bc4d59ec4a121348966ec28f
+ sha1sums = 1076c189f07308fe11f82079c07a0771542c5ff7
sha1sums = c25134330c582371e1009b51445cdb435144b53f
sha1sums = 3f8701c349194cff12f5d1104fbc070a52dd3da1
- sha1sums = a78177f8dd6dedd9ad189fa12730ec53c7d02508
- sha1sums = b9f32419d0d0b1c03dc99eae932ec1c03a936cf0
sha1sums = d7da23daca34cd015294c4d2f702cdc4a81f0853
pkgname = paraview
diff --git a/PKGBUILD b/PKGBUILD
index 28f56e6f8096..d7dd039f6d2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
# Contributor: Simon Zilliken <simon____AT____zilliken____DOT____name>
pkgname=paraview
-pkgver=5.0.1
-pkgrel=4
+pkgver=5.1.0
+pkgrel=1
pkgdesc='Parallel Visualization Application using VTK'
arch=('i686' 'x86_64')
url='http://www.paraview.org'
@@ -18,21 +18,17 @@ depends=('qt5-tools' 'openmpi' 'python2' 'ffmpeg' 'boost' 'glew'
makedepends=('cmake' 'mesa' 'gcc-fortran')
optdepends=('python2-matplotlib: Needed to support equation rendering using MathText markup language'
'python2-numpy: Needed for using some filters such as "Python Calculator"')
-source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${pkgver}-source.tar.gz"
+source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${pkgver}.tar.gz"
'paraview_32bit.patch'
'0001-find_hdf5.patch'
- 'ffmpeg3_compat.patch'
- 'vtk-gcc6.patch'
'paraview-desktop.patch')
-sha1sums=('3d72635df84421c2bc4d59ec4a121348966ec28f'
+sha1sums=('1076c189f07308fe11f82079c07a0771542c5ff7'
'c25134330c582371e1009b51445cdb435144b53f'
'3f8701c349194cff12f5d1104fbc070a52dd3da1'
- 'a78177f8dd6dedd9ad189fa12730ec53c7d02508'
- 'b9f32419d0d0b1c03dc99eae932ec1c03a936cf0'
'd7da23daca34cd015294c4d2f702cdc4a81f0853')
prepare() {
- cd "${srcdir}/ParaView-v${pkgver}-source"
+ cd "${srcdir}/ParaView-v${pkgver}"
patch -p1 -i ../paraview_32bit.patch
patch -p1 -i ../paraview-desktop.patch
@@ -40,13 +36,6 @@ prepare() {
# Find HDF before the check (for NetCDF)
patch "VTK/ThirdParty/netcdf/vtknetcdf/CMakeLists.txt" \
"../0001-find_hdf5.patch"
-
- cd "${srcdir}/ParaView-v${pkgver}-source/VTK"
-
- patch -p1 -i ../../ffmpeg3_compat.patch
-
- patch -p1 -i ../../vtk-gcc6.patch
-
rm -rf "${srcdir}/build"
mkdir "${srcdir}/build"
@@ -98,7 +87,7 @@ build() {
${cmake_system_flags} \
${cmake_system_python_flags} \
${ffmpeg_compat_flags} \
- ../ParaView-v${pkgver}-source
+ ../ParaView-v${pkgver}
make
}
@@ -109,5 +98,5 @@ package() {
make DESTDIR="${pkgdir}" install
#Install license
- install -Dm644 "${srcdir}/ParaView-v${pkgver}-source/License_v1.2.txt" "${pkgdir}/usr/share/licenses/paraview/LICENSE"
+ install -Dm644 "${srcdir}/ParaView-v${pkgver}/License_v1.2.txt" "${pkgdir}/usr/share/licenses/paraview/LICENSE"
}
diff --git a/ffmpeg3_compat.patch b/ffmpeg3_compat.patch
deleted file mode 100644
index bf9100ce351c..000000000000
--- a/ffmpeg3_compat.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-diff --git a/IO/FFMPEG/vtkFFMPEGWriter.cxx b/IO/FFMPEG/vtkFFMPEGWriter.cxx
-index d3fd421..294b421 100644
---- a/IO/FFMPEG/vtkFFMPEGWriter.cxx
-+++ b/IO/FFMPEG/vtkFFMPEGWriter.cxx
-@@ -191,11 +191,11 @@ int vtkFFMPEGWriterInternal::Start()
- c->height = this->Dim[1];
- if (this->Writer->GetCompression())
- {
-- c->pix_fmt = PIX_FMT_YUVJ422P;
-+ c->pix_fmt = AV_PIX_FMT_YUVJ422P;
- }
- else
- {
-- c->pix_fmt = PIX_FMT_BGR24;
-+ c->pix_fmt = AV_PIX_FMT_BGR24;
- }
-
- //to do playback at actual recorded rate, this will need more work see also below
-@@ -274,13 +274,13 @@ int vtkFFMPEGWriterInternal::Start()
- #endif
-
- //for the output of the writer's input...
-- this->rgbInput = avcodec_alloc_frame();
-+ this->rgbInput = av_frame_alloc();
- if (!this->rgbInput)
- {
- vtkGenericWarningMacro (<< "Could not make rgbInput avframe." );
- return 0;
- }
-- int RGBsize = avpicture_get_size(PIX_FMT_RGB24, c->width, c->height);
-+ int RGBsize = avpicture_get_size(AV_PIX_FMT_RGB24, c->width, c->height);
- unsigned char *rgb = (unsigned char *)av_malloc(sizeof(unsigned char) * RGBsize);
- if (!rgb)
- {
-@@ -288,10 +288,10 @@ int vtkFFMPEGWriterInternal::Start()
- return 0;
- }
- //The rgb buffer should get deleted when this->rgbInput is.
-- avpicture_fill((AVPicture *)this->rgbInput, rgb, PIX_FMT_RGB24, c->width, c->height);
-+ avpicture_fill((AVPicture *)this->rgbInput, rgb, AV_PIX_FMT_RGB24, c->width, c->height);
-
- //and for the output to the codec's input.
-- this->yuvOutput = avcodec_alloc_frame();
-+ this->yuvOutput = av_frame_alloc();
- if (!this->yuvOutput)
- {
- vtkGenericWarningMacro (<< "Could not make yuvOutput avframe." );
-@@ -349,12 +349,12 @@ int vtkFFMPEGWriterInternal::Write(vtkImageData *id)
- //convert that to YUV for input to the codec
- #ifdef VTK_FFMPEG_HAS_IMG_CONVERT
- img_convert((AVPicture *)this->yuvOutput, cc->pix_fmt,
-- (AVPicture *)this->rgbInput, PIX_FMT_RGB24,
-+ (AVPicture *)this->rgbInput, AV_PIX_FMT_RGB24,
- cc->width, cc->height);
- #else
- //convert that to YUV for input to the codec
- SwsContext* convert_ctx = sws_getContext(
-- cc->width, cc->height, PIX_FMT_RGB24,
-+ cc->width, cc->height, AV_PIX_FMT_RGB24,
- cc->width, cc->height, cc->pix_fmt,
- SWS_BICUBIC, NULL, NULL, NULL);
-
diff --git a/vtk-gcc6.patch b/vtk-gcc6.patch
deleted file mode 100644
index e7f6ce637b86..000000000000
--- a/vtk-gcc6.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-diff --git a/CMake/GenerateExportHeader.cmake b/CMake/GenerateExportHeader.cmake
-index ecfae31..80244df 100644
---- a/CMake/GenerateExportHeader.cmake
-+++ b/CMake/GenerateExportHeader.cmake
-@@ -163,10 +163,10 @@ endmacro()
- macro(_test_compiler_hidden_visibility)
-
- if(CMAKE_COMPILER_IS_GNUCXX)
-- execute_process(COMMAND ${CMAKE_C_COMPILER} ARGS --version
-+ execute_process(COMMAND ${CMAKE_C_COMPILER} --version
- OUTPUT_VARIABLE _gcc_version_info
- ERROR_VARIABLE _gcc_version_info)
-- string(REGEX MATCH "[345]\\.[0-9]\\.[0-9]*"
-+ string(REGEX MATCH "[3-9]\\.[0-9]\\.[0-9]*"
- _gcc_version "${_gcc_version_info}")
- # gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
- # patch level, handle this here:
-@@ -181,7 +181,7 @@ macro(_test_compiler_hidden_visibility)
- endif()
-
- if(CMAKE_CXX_COMPILER_ID MATCHES "Intel")
-- execute_process(COMMAND ${CMAKE_CXX_COMPILER} ARGS -V
-+ execute_process(COMMAND ${CMAKE_CXX_COMPILER} -V
- OUTPUT_VARIABLE _intel_version_info
- ERROR_VARIABLE _intel_version_info)
- string(REGEX REPLACE ".*Version ([0-9]+(\\.[0-9]+)+).*" "\\1"
-diff --git a/CMake/vtkCompilerExtras.cmake b/CMake/vtkCompilerExtras.cmake
-index e39bd30..4dc928a 100644
---- a/CMake/vtkCompilerExtras.cmake
-+++ b/CMake/vtkCompilerExtras.cmake
-@@ -28,11 +28,11 @@ if(CMAKE_COMPILER_IS_GNUCXX)
- endif()
-
- # Now check if we can use visibility to selectively export symbols
-- execute_process(COMMAND ${CMAKE_C_COMPILER} ARGS --version
-+ execute_process(COMMAND ${CMAKE_C_COMPILER} --version
- OUTPUT_VARIABLE _gcc_version_info
- ERROR_VARIABLE _gcc_version_info)
-
-- string (REGEX MATCH "[345]\\.[0-9]\\.[0-9]*"
-+ string (REGEX MATCH "[3-9]\\.[0-9]\\.[0-9]*"
- _gcc_version "${_gcc_version_info}")
- if(NOT _gcc_version)
- string (REGEX REPLACE ".*\\(GCC\\).*([34]\\.[0-9]).*" "\\1.0"