summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2017-07-25 19:47:19 +0200
committereolianoe2017-07-25 19:47:19 +0200
commit59aedb2dfca129034e29d3e85d1042ba813dbab1 (patch)
treeab11b48e6caaaa14a5cce43b4067ce01e26a3713
parent550ea67fdf4bd819e6c5737ea8176a6dcd853b98 (diff)
downloadaur-59aedb2dfca129034e29d3e85d1042ba813dbab1.tar.gz
fix VisItBridge
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--visit_fix_gcc7.patch43
3 files changed, 56 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e65f742d700f..1a673fd4ad5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Jun 26 20:12:45 UTC 2017
+# Tue Jul 25 17:47:13 UTC 2017
pkgbase = paraview
pkgdesc = Parallel Visualization Application using VTK
pkgver = 5.4.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.paraview.org
arch = i686
arch = x86_64
@@ -33,7 +33,9 @@ pkgbase = paraview
depends = ospray
depends = cgns
source = http://paraview.org/files/v5.4/ParaView-v5.4.0.tar.gz
+ source = visit_fix_gcc7.patch
sha1sums = d1bc9112d76f603d3232069b4ea9c507c4e1b1a7
+ sha1sums = f86feb14e7e17ce3ad5341ee4f52b40111cecbec
pkgname = paraview
diff --git a/PKGBUILD b/PKGBUILD
index d0e0205d1478..bd8bbfccdc6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=paraview
_pkgver=5.4.0
pkgver=${_pkgver//-/.}
-pkgrel=2
+pkgrel=3
pkgdesc='Parallel Visualization Application using VTK'
arch=('i686' 'x86_64')
url='http://www.paraview.org'
@@ -22,14 +22,19 @@ depends=('qt5-tools' 'qt5-x11extras' 'qt5-xmlpatterns'
'expat' 'freetype2' 'libjpeg' 'libxml2' 'libtheora' 'libpng' 'libtiff' 'zlib'
'ospray' 'cgns')
makedepends=('cmake' 'mesa' 'gcc-fortran' 'ninja')
-source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${_pkgver}.tar.gz")
-sha1sums=('d1bc9112d76f603d3232069b4ea9c507c4e1b1a7')
+source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${_pkgver}.tar.gz"
+ "visit_fix_gcc7.patch")
+sha1sums=('d1bc9112d76f603d3232069b4ea9c507c4e1b1a7'
+ 'f86feb14e7e17ce3ad5341ee4f52b40111cecbec')
prepare() {
cd "${srcdir}/ParaView-v${_pkgver}"
#rm -rf "${srcdir}/build"
mkdir -p "${srcdir}/build"
+
+ patch Utilities/VisItBridge/databases/readers/Vs/VsStaggeredField.C \
+ "${srcdir}/visit_fix_gcc7.patch"
}
build() {
@@ -42,7 +47,6 @@ build() {
VTK_USE_SYSTEM_LIB+="-DVTK_USE_SYSTEM_${lib}:BOOL=ON "
done
- # VisitBridge bug: https://gitlab.kitware.com/paraview/paraview/issues/17456
cmake \
-DBUILD_DOCUMENTATION:BOOL=OFF \
-DBUILD_EXAMPLES:BOOL=ON \
@@ -60,7 +64,7 @@ build() {
-DPARAVIEW_INSTALL_DEVELOPMENT_FILES:BOOL=ON \
-DPARAVIEW_QT_VERSION:STRING=5 \
-DPARAVIEW_USE_MPI:BOOL=ON \
- -DPARAVIEW_USE_VISITBRIDGE:BOOL=OFF \
+ -DPARAVIEW_USE_VISITBRIDGE:BOOL=ON \
-DPARAVIEW_USE_OSPRAY:BOOL=ON \
-DVISIT_BUILD_READER_CGNS:BOOL=ON \
-DVTK_PYTHON_FULL_THREADSAFE:BOOL=ON \
diff --git a/visit_fix_gcc7.patch b/visit_fix_gcc7.patch
new file mode 100644
index 000000000000..f9c3a518ffe7
--- /dev/null
+++ b/visit_fix_gcc7.patch
@@ -0,0 +1,43 @@
+------------------------------------------------------------------------
+r31082 | whitlocb | 2017-06-16 00:19:15 +0200 (Fri, 16 Jun 2017) | 1 line
+
+Fix for GCC 7
+
+Index: databases/Vs/VsStaggeredField.C
+===================================================================
+--- databases/Vs/VsStaggeredField.C (revision 31081)
++++ databases/Vs/VsStaggeredField.C (revision 31082)
+@@ -26,10 +26,13 @@
+ this->indexOrder = VsSchema::compMajorCKey;
+ this->centering = VsSchema::nodalCenteringKey;
+
++#if 0
++ // There is no clear method under GCC 7. What good would it do here anyway?
+ this->oriCellDims.clear();
+ this->oriCellDimProd.clear();
+ this->newCellDims.clear();
+ this->newCellDimProd.clear();
++#endif
+ }
+
+ template<class TYPE>
+@@ -136,7 +139,7 @@
+ // iterate over subgrid
+ for (size_t subBigIndx = 0; subBigIndx < this->numNeighbors; ++subBigIndx) {
+ std::valarray<int> subCellInds = this->getSubCellIndexSet(subBigIndx);
+- std::valarray<int> newCellInds = oriCellInds*this->numNeighbors + subCellInds;
++ std::valarray<int> newCellInds = oriCellInds*static_cast<TYPE>(this->numNeighbors) + subCellInds;
+ size_t newBigIndx = this->getNewBigIndex(newCellInds);
+ std::valarray<TYPE> xi = std::valarray<TYPE>(subCellInds) / this->twoPowSubRes;
+ this->setNewFieldVals(newBigIndx, xi, sigmaVals, neighVals, dataPtr);
+@@ -147,7 +150,7 @@
+ template <class TYPE>
+ std::valarray<int>
+ VsStaggeredField<TYPE>::getOriCellIndexSet(size_t bigIndex) const {
+- return (bigIndex / this->oriCellDimProd) % this->oriCellDims;
++ return (bigIndex / static_cast<TYPE>(this->oriCellDimProd)) % this->oriCellDims;
+ }
+
+ template <class TYPE>
+
+------------------------------------------------------------------------