summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Eleftheriou2015-07-06 00:21:44 +0200
committerGeorge Eleftheriou2015-07-06 00:21:44 +0200
commitb490451845efdd9bdc28193956ba91011dc9dae4 (patch)
tree38a713ffb431ab00d93442a80a99385ebfec8275
downloadaur-b490451845efdd9bdc28193956ba91011dc9dae4.tar.gz
Initial import
-rw-r--r--.SRCINFO40
-rw-r--r--0001-gcc49.patch122
-rw-r--r--0002-int.patch22
-rw-r--r--PKGBUILD102
-rw-r--r--paraview.desktop9
-rw-r--r--paraview.pngbin0 -> 367 bytes
6 files changed, 295 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24b73c5f5636
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = paraview
+ pkgdesc = Parallel Visualization Application using VTK
+ pkgver = 4.3.1
+ pkgrel = 1
+ url = http://www.paraview.org
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = mesa
+ depends = qtwebkit
+ depends = openmpi
+ depends = python2
+ depends = ffmpeg-compat
+ depends = boost
+ depends = libcgns-paraview
+ depends = expat
+ depends = freetype2
+ depends = hdf5
+ depends = libjpeg
+ depends = libxml2
+ depends = libtheora
+ depends = libpng
+ depends = libtiff
+ depends = zlib
+ optdepends = python2-matplotlib: Needed to support equation rendering using MathText markup language
+ optdepends = python2-numpy: Needed for using some filters such as "Python Calculator"
+ source = http://paraview.org/files/v4.3/ParaView-v4.3.1-source.tar.gz
+ source = paraview.png
+ source = paraview.desktop
+ source = 0001-gcc49.patch
+ source = 0002-int.patch
+ sha1sums = 9c0666ea13ebde3fe9a92cf24255c42a6a20cf79
+ sha1sums = a2dff014e1235dfaa93cd523286f9c97601d3bbc
+ sha1sums = 1f94c8ff79bb2bd2c02d6b403ea1f4599616531b
+ sha1sums = 69e1f8c0b90ceee46feaf11c3fae7a22bf68e0dd
+ sha1sums = 07963d6f7de78f154f2f6a2aaea6380a9e26bab6
+
+pkgname = paraview
+
diff --git a/0001-gcc49.patch b/0001-gcc49.patch
new file mode 100644
index 000000000000..2ed74f0282c9
--- /dev/null
+++ b/0001-gcc49.patch
@@ -0,0 +1,122 @@
+--- a/VTK/Filters/ParallelMPI/vtkDistributedDataFilter.cxx 2014-09-23 16:47:10.000000000 +0200
++++ b/VTK/Filters/ParallelMPI/vtkDistributedDataFilter.cxx 2014-12-22 10:31:13.575228267 +0100
+@@ -1091,7 +1091,10 @@
+ vtkIdType cellsPerNode = numTotalCells / nprocs;
+
+ vtkIdList **sendCells = new vtkIdList * [ nprocs ];
+- memset(sendCells, 0, sizeof(vtkIdList *) * nprocs);
++
++ if (sizeof(vtkIdList *) * nprocs > 0) {
++ memset(sendCells, 0, sizeof(vtkIdList *) * nprocs);
++ }
+
+ if (numConsumers == nprocs - 1)
+ {
+@@ -1582,7 +1585,9 @@
+ // Exchange int arrays
+
+ float **recvArrays = new float * [nprocs];
+- memset(recvArrays, 0, sizeof(float *) * nprocs);
++ if (sizeof(float *) * nprocs > 0) {
++ memset(recvArrays, 0, sizeof(float *) * nprocs);
++ }
+
+ if (sendSize[me] > 0) // sent myself an array
+ {
+@@ -1703,7 +1708,9 @@
+ // Exchange int arrays
+
+ vtkIdType **recvArrays = new vtkIdType * [nprocs];
+- memset(recvArrays, 0, sizeof(vtkIdType *) * nprocs);
++ if (sizeof(vtkIdType *) * nprocs > 0) {
++ memset(recvArrays, 0, sizeof(vtkIdType *) * nprocs);
++ }
+
+ if (sendSize[me] > 0) // sent myself an array
+ {
+@@ -2807,7 +2814,9 @@
+
+ unsigned char *vals = new unsigned char [npoints];
+
+- memset(vals, val, npoints);
++ if (npoints > 0) {
++ memset(vals, val, npoints);
++ }
+
+ vtkUnsignedCharArray *Array = vtkUnsignedCharArray::New();
+ Array->SetName(arrayName);
+@@ -2827,7 +2836,9 @@
+
+ unsigned char *vals = new unsigned char [ncells];
+
+- memset(vals, val, ncells);
++ if (ncells > 0) {
++ memset(vals, val, ncells);
++ }
+
+ vtkUnsignedCharArray *Array = vtkUnsignedCharArray::New();
+ Array->SetName(arrayName);
+@@ -3026,7 +3037,9 @@
+ vtkIdType nGridPoints = grid->GetNumberOfPoints();
+
+ vtkIdType *numPointsOutside = new vtkIdType [nprocs];
+- memset(numPointsOutside, 0, sizeof(vtkIdType) * nprocs);
++ if (sizeof(vtkIdType) * nprocs > 0) {
++ memset(numPointsOutside, 0, sizeof(vtkIdType) * nprocs);
++ }
+
+ vtkIdTypeArray *globalIds = vtkIdTypeArray::New();
+ globalIds->SetNumberOfValues(nGridPoints);
+@@ -3108,10 +3121,16 @@
+ // global ID back?
+
+ vtkFloatArray **ptarrayOut = new vtkFloatArray * [nprocs];
+- memset(ptarrayOut, 0, sizeof(vtkFloatArray *) * nprocs);
++
++ if (sizeof(vtkFloatArray *) * nprocs > 0) {
++ memset(ptarrayOut, 0, sizeof(vtkFloatArray *) * nprocs);
++ }
+
+ vtkIdTypeArray **localIds = new vtkIdTypeArray * [nprocs];
+- memset(localIds, 0, sizeof(vtkIdTypeArray *) * nprocs);
++
++ if (sizeof(vtkIdTypeArray *) * nprocs > 0) {
++ memset(localIds, 0, sizeof(vtkIdTypeArray *) * nprocs);
++ }
+
+ vtkIdType *next = new vtkIdType [nprocs];
+ vtkIdType *next3 = new vtkIdType [nprocs];
+@@ -3286,7 +3305,9 @@
+ {
+ // There are no cells in my assigned region
+
+- memset(gids, 0, sizeof(vtkIdTypeArray *) * nprocs);
++ if (sizeof(vtkIdTypeArray *) * nprocs > 0) {
++ memset(gids, 0, sizeof(vtkIdTypeArray *) * nprocs);
++ }
+
+ return gids;
+ }
+@@ -3491,7 +3512,10 @@
+ std::multimap<int, int>::iterator mapIt;
+
+ vtkIdTypeArray **processList = new vtkIdTypeArray * [nprocs];
+- memset(processList, 0, sizeof (vtkIdTypeArray *) * nprocs);
++
++ if (sizeof (vtkIdTypeArray *) * nprocs > 0) {
++ memset(processList, 0, sizeof (vtkIdTypeArray *) * nprocs);
++ }
+
+ for (int i=0; i<nprocs; i++)
+ {
+@@ -3581,7 +3605,9 @@
+ vtkIdType numPoints = grid->GetNumberOfPoints();
+
+ vtkIdTypeArray **ghostPtIds = new vtkIdTypeArray * [nprocs];
+- memset(ghostPtIds, 0, sizeof(vtkIdTypeArray *) * nprocs);
++ if (sizeof(vtkIdTypeArray *) * nprocs) {
++ memset(ghostPtIds, 0, sizeof(vtkIdTypeArray *) * nprocs);
++ }
+
+ if (numPoints < 1)
+ {
diff --git a/0002-int.patch b/0002-int.patch
new file mode 100644
index 000000000000..2a66eea6e4f9
--- /dev/null
+++ b/0002-int.patch
@@ -0,0 +1,22 @@
+--- a/VTK/Rendering/FreeType/vtkFreeTypeTools.cxx 2014-09-23 16:47:11.000000000 +0200
++++ b/VTK/Rendering/FreeType/vtkFreeTypeTools.cxx 2014-12-22 11:04:14.003492645 +0100
+@@ -1183,7 +1183,7 @@
+ if (bitmap)
+ {
+ metaData.ascent = std::max(bitmapGlyph->top - 1, metaData.ascent);
+- metaData.descent = std::min(-(bitmap->rows - (bitmapGlyph->top - 1)),
++ metaData.descent = std::min(-int((bitmap->rows - (bitmapGlyph->top - 1))),
+ metaData.descent);
+ }
+ ++heightString;
+@@ -1950,8 +1950,8 @@
+ if (bitmap)
+ {
+ bbox[0] = std::min(bbox[0], pen[0] + bitmapGlyph->left);
+- bbox[1] = std::max(bbox[1], pen[0] + bitmapGlyph->left + bitmap->width);
+- bbox[2] = std::min(bbox[2], pen[1] + bitmapGlyph->top - 1 - bitmap->rows);
++ bbox[1] = std::max(bbox[1], int(pen[0] + bitmapGlyph->left + bitmap->width));
++ bbox[2] = std::min(bbox[2], int(pen[1] + bitmapGlyph->top - 1 - bitmap->rows));
+ bbox[3] = std::max(bbox[3], pen[1] + bitmapGlyph->top - 1);
+ }
+ else
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a303accf32aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,102 @@
+# Maintainer: George Eleftheriou <eleftg>
+# Contributor: Mathias Anselmann <mathias.anselmann@gmail.com>
+# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Thomas Dziedzic < gostrc at gmail >
+# Contributor: Michele Mocciola <mickele>
+# Contributor: Simon Zilliken <simon____AT____zilliken____DOT____name>
+
+pkgname=paraview
+pkgver=4.3.1
+pkgrel=1
+pkgdesc='Parallel Visualization Application using VTK'
+arch=('i686' 'x86_64')
+url='http://www.paraview.org'
+license=('custom')
+depends=('qtwebkit' 'openmpi' 'python2' 'ffmpeg-compat' 'boost' 'libcgns-paraview'
+ 'expat' 'freetype2' 'hdf5' 'libjpeg' 'libxml2' 'libtheora' 'libpng' 'libtiff' 'zlib')
+makedepends=('cmake' 'mesa')
+optdepends=('python2-matplotlib: Needed to support equation rendering using MathText markup language'
+ 'python2-numpy: Needed for using some filters such as "Python Calculator"')
+source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${pkgver}-source.tar.gz"
+ 'paraview.png'
+ 'paraview.desktop'
+ '0001-gcc49.patch'
+ '0002-int.patch')
+sha1sums=('9c0666ea13ebde3fe9a92cf24255c42a6a20cf79'
+ 'a2dff014e1235dfaa93cd523286f9c97601d3bbc'
+ '1f94c8ff79bb2bd2c02d6b403ea1f4599616531b'
+ '69e1f8c0b90ceee46feaf11c3fae7a22bf68e0dd'
+ '07963d6f7de78f154f2f6a2aaea6380a9e26bab6')
+
+prepare() {
+ cd "${srcdir}/ParaView-v${pkgver}-source"
+
+ # Patch for mpi4py, see
+ # http://www.paraview.org/pipermail/paraview/2014-February/030517.html
+ patch -p1 < "${srcdir}/0001-gcc49.patch"
+ patch -p1 < "${srcdir}/0002-int.patch"
+
+ rm -rf "${srcdir}/build"
+ mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+}
+
+build() {
+ cd "${srcdir}/build"
+
+ # flags to enable system libs
+ # add PROTOBUF when http://www.vtk.org/Bug/view.php?id=13656 gets fixed
+ local cmake_system_flags=""
+ for lib in EXPAT FREETYPE HDF5 JPEG LIBXML2 OGGTHEORA PNG TIFF ZLIB; do
+ cmake_system_flags+="-DVTK_USE_SYSTEM_${lib}:BOOL=ON "
+ done
+
+ # flags to use python2 instead of python which is 3.x.x on archlinux
+ local cmake_system_python_flags="-DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR:PATH=/usr/include/python2.7 -DPYTHON_LIBRARY:PATH=/usr/lib/libpython2.7.so"
+
+ # flags to use ffmpeg-compat instead of ffmpeg until
+ # http://paraview.org/Bug/view.php?id=14215 gets fixed
+ local ffmpeg_compat_flags="-DFFMPEG_INCLUDE_DIR:PATH=/usr/include/ffmpeg-compat \
+ -DFFMPEG_avcodec_LIBRARY=/usr/lib/ffmpeg-compat/libavcodec.so \
+ -DFFMPEG_avformat_LIBRARY=/usr/lib/ffmpeg-compat/libavformat.so \
+ -DFFMPEG_avutil_LIBRARY=/usr/lib/ffmpeg-compat/libavutil.so \
+ -DFFMPEG_swscale_LIBRARY=/usr/lib/ffmpeg-compat/libswscale.so"
+
+ # enable when http://paraview.org/Bug/view.php?id=12852 gets fixed:
+ #-DCMAKE_SKIP_RPATH:BOOL=YES \
+ cmake \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DBUILD_TESTING:BOOL=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_C_COMPILER=mpicc \
+ -DCMAKE_CXX_COMPILER=mpicxx \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_VERBOSE_MAKEFILE:BOOL=OFF \
+ -DPARAVIEW_ENABLE_FFMPEG:BOOL=ON \
+ -DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
+ -DPARAVIEW_USE_MPI:BOOL=ON \
+ -DPARAVIEW_USE_VISITBRIDGE:BOOL=ON \
+ -DQT_HELP_GENERATOR:FILEPATH=/usr/lib/qt4/bin/qhelpgenerator \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ -DVISIT_BUILD_READER_CGNS:BOOL=ON \
+ ${cmake_system_flags} \
+ ${cmake_system_python_flags} \
+ ${ffmpeg_compat_flags} \
+ ../ParaView-v${pkgver}-source
+
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+
+ make DESTDIR="${pkgdir}" install
+
+ #Install license
+ install -Dm644 "${srcdir}/ParaView-v${pkgver}-source/License_v1.2.txt" "${pkgdir}/usr/share/licenses/paraview/LICENSE"
+
+ #Install desktop shortcuts
+ install -Dm644 "${srcdir}/paraview.png" "${pkgdir}/usr/share/pixmaps/paraview.png"
+ desktop-file-install --dir="${pkgdir}"/usr/share/applications "${srcdir}/paraview.desktop"
+}
diff --git a/paraview.desktop b/paraview.desktop
new file mode 100644
index 000000000000..40d907b6b4dc
--- /dev/null
+++ b/paraview.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=ParaView
+GenericName=Data Viewer
+Comment=ParaView allows visualization of large data sets
+Type=Application
+Terminal=false
+Icon=paraview
+Categories=Graphics;
+Exec=/usr/bin/paraview
diff --git a/paraview.png b/paraview.png
new file mode 100644
index 000000000000..6e39f3d4f7f9
--- /dev/null
+++ b/paraview.png
Binary files differ