summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Goethel2016-01-13 12:34:17 +0100
committerOliver Goethel2016-01-13 12:34:17 +0100
commitee86ee34c2900def888613852dc981a67a69e4fd (patch)
tree4a6d7fdcc05ee0fff5e5b46519b10f7ab1f41b26
parentd4bf96833aafa3ff8f2d7f16399e30514ef04dfc (diff)
downloadaur-ee86ee34c2900def888613852dc981a67a69e4fd.tar.gz
bump to 5.0.0
-rw-r--r--.SRCINFO14
-rw-r--r--0001-find_hdf5.patch10
-rw-r--r--PKGBUILD24
3 files changed, 35 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2fb16ef53508..9c1d115d645c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed Jan 13 11:33:52 UTC 2016
pkgbase = paraview
pkgdesc = Parallel Visualization Application using VTK
- pkgver = 4.4.0
- pkgrel = 2
+ pkgver = 5.0.0
+ pkgrel = 1
url = http://www.paraview.org
arch = i686
arch = x86_64
license = custom
makedepends = cmake
makedepends = mesa
- depends = qtwebkit
+ depends = qt5-tools
depends = openmpi
depends = python2
depends = ffmpeg-compat
@@ -25,14 +27,16 @@ pkgbase = paraview
depends = zlib
optdepends = python2-matplotlib: Needed to support equation rendering using MathText markup language
optdepends = python2-numpy: Needed for using some filters such as "Python Calculator"
- source = http://paraview.org/files/v4.4/ParaView-v4.4.0-source.tar.gz
+ source = http://paraview.org/files/v5.0/ParaView-v5.0.0-source.tar.gz
source = paraview.png
source = paraview.desktop
source = paraview_32bit.patch
- sha1sums = 276fc91f2a7aec72b7740c5312b560cc76157370
+ source = 0001-find_hdf5.patch
+ sha1sums = 909da124e13a385ce4bfb5afd4d0089aa5271904
sha1sums = a2dff014e1235dfaa93cd523286f9c97601d3bbc
sha1sums = 1f94c8ff79bb2bd2c02d6b403ea1f4599616531b
sha1sums = c25134330c582371e1009b51445cdb435144b53f
+ sha1sums = 3f8701c349194cff12f5d1104fbc070a52dd3da1
pkgname = paraview
diff --git a/0001-find_hdf5.patch b/0001-find_hdf5.patch
new file mode 100644
index 000000000000..731a28b6f91e
--- /dev/null
+++ b/0001-find_hdf5.patch
@@ -0,0 +1,10 @@
+--- VTK/ThirdParty/netcdf/vtknetcdf/CMakeLists.txt 2015-10-01 16:27:10.529402587 +0200
++++ VTK/ThirdParty/netcdf/vtknetcdf/CMakeLists.txt.new 2015-10-01 16:26:47.586013737 +0200
+@@ -229,6 +229,7 @@
+ SET(CXX NETCDF_ENABLE_CXX)
+
+ # NetCDF4 needs HDF5 HL support. Check that's available.
++find_package(HDF5 REQUIRED)
+ set (USE_NETCDF4 OFF)
+ if (NOT VTK_USE_SYSTEM_HDF5)
+ # using VTK's HDF5, we always build that with HL support.
diff --git a/PKGBUILD b/PKGBUILD
index d4e4bfa9146f..7ee0d6005d20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,13 @@
# Contributor: Simon Zilliken <simon____AT____zilliken____DOT____name>
pkgname=paraview
-pkgver=4.4.0
-pkgrel=2
+pkgver=5.0.0
+pkgrel=1
pkgdesc='Parallel Visualization Application using VTK'
arch=('i686' 'x86_64')
url='http://www.paraview.org'
license=('custom')
-depends=('qtwebkit' 'openmpi' 'python2' 'ffmpeg-compat' 'boost' 'cgns'
+depends=('qt5-tools' 'openmpi' 'python2' 'ffmpeg-compat' 'boost' 'cgns'
'expat' 'freetype2' 'hdf5' 'libjpeg' 'libxml2' 'libtheora' 'libpng' 'libtiff' 'zlib')
makedepends=('cmake' 'mesa')
optdepends=('python2-matplotlib: Needed to support equation rendering using MathText markup language'
@@ -20,16 +20,22 @@ optdepends=('python2-matplotlib: Needed to support equation rendering using Math
source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${pkgver}-source.tar.gz"
'paraview.png'
'paraview.desktop'
- 'paraview_32bit.patch')
-sha1sums=('276fc91f2a7aec72b7740c5312b560cc76157370'
+ 'paraview_32bit.patch'
+ '0001-find_hdf5.patch')
+sha1sums=('909da124e13a385ce4bfb5afd4d0089aa5271904'
'a2dff014e1235dfaa93cd523286f9c97601d3bbc'
'1f94c8ff79bb2bd2c02d6b403ea1f4599616531b'
- 'c25134330c582371e1009b51445cdb435144b53f')
+ 'c25134330c582371e1009b51445cdb435144b53f'
+ '3f8701c349194cff12f5d1104fbc070a52dd3da1')
prepare() {
cd "${srcdir}/ParaView-v${pkgver}-source"
patch -p1 -i ../paraview_32bit.patch
+
+ # Find HDF before the check (for NetCDF)
+ patch "VTK/ThirdParty/netcdf/vtknetcdf/CMakeLists.txt" \
+ "../0001-find_hdf5.patch"
rm -rf "${srcdir}/build"
@@ -73,8 +79,10 @@ build() {
-DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
-DPARAVIEW_USE_MPI:BOOL=ON \
-DPARAVIEW_USE_VISITBRIDGE:BOOL=ON \
- -DQT_HELP_GENERATOR:FILEPATH=/usr/lib/qt4/bin/qhelpgenerator \
- -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ -DPARAVIEW_QT_VERSION=5 \
+ -DVTK_QT_VERSION=5 \
+ -DQT_HELP_GENERATOR:FILEPATH=/usr/lib/qt/bin/qhelpgenerator \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt5 \
-DVISIT_BUILD_READER_CGNS:BOOL=ON \
${cmake_system_flags} \
${cmake_system_python_flags} \