summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Goethel2016-03-08 10:22:40 +0100
committerOliver Goethel2016-03-08 10:22:40 +0100
commitf44190621014dd78d55125059e4a01f42d3f47f8 (patch)
tree5908c6a55a83ab395078dba5add012657d45148d
parent978f4079829e7d0353e2c8901ba867f28e5685bd (diff)
downloadaur-f44190621014dd78d55125059e4a01f42d3f47f8.tar.gz
added ffmpeg3_compat.patch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
-rw-r--r--ffmpeg3_compat.patch62
3 files changed, 83 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b903ea6dc259..42178d95d67f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Mar 7 21:21:05 UTC 2016
+# Tue Mar 8 09:22:24 UTC 2016
pkgbase = paraview
pkgdesc = Parallel Visualization Application using VTK
pkgver = 5.0.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.paraview.org
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = paraview
depends = qt5-tools
depends = openmpi
depends = python2
- depends = ffmpeg2.8
+ depends = ffmpeg
depends = boost
depends = cgns
depends = glew
@@ -34,11 +34,13 @@ pkgbase = paraview
source = paraview.desktop
source = paraview_32bit.patch
source = 0001-find_hdf5.patch
+ source = ffmpeg3_compat.patch
sha1sums = 909da124e13a385ce4bfb5afd4d0089aa5271904
sha1sums = a2dff014e1235dfaa93cd523286f9c97601d3bbc
sha1sums = 1f94c8ff79bb2bd2c02d6b403ea1f4599616531b
sha1sums = c25134330c582371e1009b51445cdb435144b53f
sha1sums = 3f8701c349194cff12f5d1104fbc070a52dd3da1
+ sha1sums = a78177f8dd6dedd9ad189fa12730ec53c7d02508
pkgname = paraview
diff --git a/PKGBUILD b/PKGBUILD
index 8e234f84874f..ce634deaf45b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,12 +7,12 @@
pkgname=paraview
pkgver=5.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Parallel Visualization Application using VTK'
arch=('i686' 'x86_64')
url='http://www.paraview.org'
license=('custom')
-depends=('qt5-tools' 'openmpi' 'python2' 'ffmpeg2.8' 'boost' 'cgns' 'glew'
+depends=('qt5-tools' 'openmpi' 'python2' 'ffmpeg' 'boost' 'cgns' 'glew'
'expat' 'freetype2' 'hdf5' 'libjpeg' 'libxml2' 'libtheora' 'libpng' 'libtiff' 'zlib')
makedepends=('cmake' 'mesa' 'gcc-fortran')
optdepends=('python2-matplotlib: Needed to support equation rendering using MathText markup language'
@@ -21,21 +21,27 @@ source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${pkgver}-source.tar
'paraview.png'
'paraview.desktop'
'paraview_32bit.patch'
- '0001-find_hdf5.patch')
+ '0001-find_hdf5.patch'
+ 'ffmpeg3_compat.patch')
sha1sums=('909da124e13a385ce4bfb5afd4d0089aa5271904'
'a2dff014e1235dfaa93cd523286f9c97601d3bbc'
'1f94c8ff79bb2bd2c02d6b403ea1f4599616531b'
'c25134330c582371e1009b51445cdb435144b53f'
- '3f8701c349194cff12f5d1104fbc070a52dd3da1')
+ '3f8701c349194cff12f5d1104fbc070a52dd3da1'
+ 'a78177f8dd6dedd9ad189fa12730ec53c7d02508')
prepare() {
cd "${srcdir}/ParaView-v${pkgver}-source"
patch -p1 -i ../paraview_32bit.patch
-
+
# Find HDF before the check (for NetCDF)
patch "VTK/ThirdParty/netcdf/vtknetcdf/CMakeLists.txt" \
"../0001-find_hdf5.patch"
+
+ cd "${srcdir}/ParaView-v${pkgver}-source/VTK"
+
+ patch -p1 -i ../../ffmpeg3_compat.patch
rm -rf "${srcdir}/build"
@@ -58,11 +64,11 @@ build() {
-DPYTHON_INCLUDE_DIR:PATH=/usr/include/python2.7 -DPYTHON_LIBRARY:PATH=/usr/lib/libpython2.7.so"
# flags to use ffmpeg2.8
- local ffmpeg_compat_flags="-DFFMPEG_INCLUDE_DIR:PATH=/usr/include/ffmpeg2.8 \
- -DFFMPEG_avcodec_LIBRARY=/usr/lib/ffmpeg2.8/libavcodec.so \
- -DFFMPEG_avformat_LIBRARY=/usr/lib/ffmpeg2.8/libavformat.so \
- -DFFMPEG_avutil_LIBRARY=/usr/lib/ffmpeg2.8/libavutil.so \
- -DFFMPEG_swscale_LIBRARY=/usr/lib/ffmpeg2.8/libswscale.so"
+ local ffmpeg_compat_flags="-DFFMPEG_INCLUDE_DIR:PATH=/usr/include/ \
+ -DFFMPEG_avcodec_LIBRARY=/usr/lib/libavcodec.so \
+ -DFFMPEG_avformat_LIBRARY=/usr/lib/libavformat.so \
+ -DFFMPEG_avutil_LIBRARY=/usr/lib/libavutil.so \
+ -DFFMPEG_swscale_LIBRARY=/usr/lib/libswscale.so"
# enable when http://paraview.org/Bug/view.php?id=12852 gets fixed:
#-DCMAKE_SKIP_RPATH:BOOL=YES \
diff --git a/ffmpeg3_compat.patch b/ffmpeg3_compat.patch
new file mode 100644
index 000000000000..bf9100ce351c
--- /dev/null
+++ b/ffmpeg3_compat.patch
@@ -0,0 +1,62 @@
+diff --git a/IO/FFMPEG/vtkFFMPEGWriter.cxx b/IO/FFMPEG/vtkFFMPEGWriter.cxx
+index d3fd421..294b421 100644
+--- a/IO/FFMPEG/vtkFFMPEGWriter.cxx
++++ b/IO/FFMPEG/vtkFFMPEGWriter.cxx
+@@ -191,11 +191,11 @@ int vtkFFMPEGWriterInternal::Start()
+ c->height = this->Dim[1];
+ if (this->Writer->GetCompression())
+ {
+- c->pix_fmt = PIX_FMT_YUVJ422P;
++ c->pix_fmt = AV_PIX_FMT_YUVJ422P;
+ }
+ else
+ {
+- c->pix_fmt = PIX_FMT_BGR24;
++ c->pix_fmt = AV_PIX_FMT_BGR24;
+ }
+
+ //to do playback at actual recorded rate, this will need more work see also below
+@@ -274,13 +274,13 @@ int vtkFFMPEGWriterInternal::Start()
+ #endif
+
+ //for the output of the writer's input...
+- this->rgbInput = avcodec_alloc_frame();
++ this->rgbInput = av_frame_alloc();
+ if (!this->rgbInput)
+ {
+ vtkGenericWarningMacro (<< "Could not make rgbInput avframe." );
+ return 0;
+ }
+- int RGBsize = avpicture_get_size(PIX_FMT_RGB24, c->width, c->height);
++ int RGBsize = avpicture_get_size(AV_PIX_FMT_RGB24, c->width, c->height);
+ unsigned char *rgb = (unsigned char *)av_malloc(sizeof(unsigned char) * RGBsize);
+ if (!rgb)
+ {
+@@ -288,10 +288,10 @@ int vtkFFMPEGWriterInternal::Start()
+ return 0;
+ }
+ //The rgb buffer should get deleted when this->rgbInput is.
+- avpicture_fill((AVPicture *)this->rgbInput, rgb, PIX_FMT_RGB24, c->width, c->height);
++ avpicture_fill((AVPicture *)this->rgbInput, rgb, AV_PIX_FMT_RGB24, c->width, c->height);
+
+ //and for the output to the codec's input.
+- this->yuvOutput = avcodec_alloc_frame();
++ this->yuvOutput = av_frame_alloc();
+ if (!this->yuvOutput)
+ {
+ vtkGenericWarningMacro (<< "Could not make yuvOutput avframe." );
+@@ -349,12 +349,12 @@ int vtkFFMPEGWriterInternal::Write(vtkImageData *id)
+ //convert that to YUV for input to the codec
+ #ifdef VTK_FFMPEG_HAS_IMG_CONVERT
+ img_convert((AVPicture *)this->yuvOutput, cc->pix_fmt,
+- (AVPicture *)this->rgbInput, PIX_FMT_RGB24,
++ (AVPicture *)this->rgbInput, AV_PIX_FMT_RGB24,
+ cc->width, cc->height);
+ #else
+ //convert that to YUV for input to the codec
+ SwsContext* convert_ctx = sws_getContext(
+- cc->width, cc->height, PIX_FMT_RGB24,
++ cc->width, cc->height, AV_PIX_FMT_RGB24,
+ cc->width, cc->height, cc->pix_fmt,
+ SWS_BICUBIC, NULL, NULL, NULL);
+