summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCong Gu2015-09-23 21:48:19 -0500
committerCong Gu2015-09-23 21:48:19 -0500
commitf966ea4f315b3ac53bc42eb1130ad2a4355acf3b (patch)
tree4ce94c74a1366b9265390c39afd9b359ba203eb5
downloadaur-f966ea4f315b3ac53bc42eb1130ad2a4355acf3b.tar.gz
Initial import
-rw-r--r--.SRCINFO39
-rw-r--r--PKGBUILD94
-rw-r--r--paraview.desktop9
-rw-r--r--paraview.pngbin0 -> 367 bytes
4 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9864f4b3d4de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+pkgbase = paraview-manta
+ pkgdesc = Parallel Visualization Application using VTK (with MantaView plugin)
+ pkgver = 4.4.0
+ pkgrel = 1
+ url = http://www.paraview.org
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = cmake
+ makedepends = mesa
+ depends = qtwebkit
+ depends = openmpi
+ depends = python2
+ depends = ffmpeg-compat
+ depends = boost
+ depends = libcgns-paraview
+ depends = expat
+ depends = freetype2
+ depends = hdf5
+ depends = libjpeg
+ depends = libxml2
+ depends = libtheora
+ depends = libpng
+ depends = libtiff
+ depends = zlib
+ depends = manta
+ optdepends = python2-matplotlib: Needed to support equation rendering using MathText markup language
+ optdepends = python2-numpy: Needed for using some filters such as "Python Calculator"
+ provides = paraview
+ conflicts = paraview
+ source = http://paraview.org/files/v4.4/ParaView-v4.4.0-source.tar.gz
+ source = paraview.png
+ source = paraview.desktop
+ sha1sums = 276fc91f2a7aec72b7740c5312b560cc76157370
+ sha1sums = a2dff014e1235dfaa93cd523286f9c97601d3bbc
+ sha1sums = 1f94c8ff79bb2bd2c02d6b403ea1f4599616531b
+
+pkgname = paraview-manta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f43d3f402ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,94 @@
+# Maintainer: <gucong@gc-desktop>
+
+pkgname=paraview-manta
+pkgver=4.4.0
+pkgrel=1
+pkgdesc='Parallel Visualization Application using VTK (with MantaView plugin)'
+arch=('i686' 'x86_64')
+url='http://www.paraview.org'
+license=('custom')
+depends=('qtwebkit' 'openmpi' 'python2' 'ffmpeg-compat' 'boost' 'libcgns-paraview'
+ 'expat' 'freetype2' 'hdf5' 'libjpeg' 'libxml2' 'libtheora' 'libpng' 'libtiff' 'zlib' 'manta')
+makedepends=('cmake' 'mesa')
+optdepends=('python2-matplotlib: Needed to support equation rendering using MathText markup language'
+ 'python2-numpy: Needed for using some filters such as "Python Calculator"')
+conflicts=('paraview')
+provides=('paraview')
+source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${pkgver}-source.tar.gz"
+ 'paraview.png'
+ 'paraview.desktop'
+ )
+sha1sums=('276fc91f2a7aec72b7740c5312b560cc76157370'
+ 'a2dff014e1235dfaa93cd523286f9c97601d3bbc'
+ '1f94c8ff79bb2bd2c02d6b403ea1f4599616531b')
+
+prepare() {
+ cd "${srcdir}/ParaView-v${pkgver}-source"
+
+ rm -rf "${srcdir}/build"
+ mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+}
+
+build() {
+ cd "${srcdir}/build"
+
+ # flags to enable system libs
+ # add PROTOBUF when http://www.vtk.org/Bug/view.php?id=13656 gets fixed
+ local cmake_system_flags=""
+ for lib in EXPAT FREETYPE HDF5 JPEG LIBXML2 OGGTHEORA PNG TIFF ZLIB; do
+ cmake_system_flags+="-DVTK_USE_SYSTEM_${lib}:BOOL=ON "
+ done
+
+ # flags to use python2 instead of python which is 3.x.x on archlinux
+ local cmake_system_python_flags="-DPYTHON_EXECUTABLE:PATH=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR:PATH=/usr/include/python2.7 -DPYTHON_LIBRARY:PATH=/usr/lib/libpython2.7.so"
+
+ # flags to use ffmpeg-compat instead of ffmpeg until
+ # http://paraview.org/Bug/view.php?id=14215 gets fixed
+ local ffmpeg_compat_flags="-DFFMPEG_INCLUDE_DIR:PATH=/usr/include/ffmpeg-compat \
+ -DFFMPEG_avcodec_LIBRARY=/usr/lib/ffmpeg-compat/libavcodec.so \
+ -DFFMPEG_avformat_LIBRARY=/usr/lib/ffmpeg-compat/libavformat.so \
+ -DFFMPEG_avutil_LIBRARY=/usr/lib/ffmpeg-compat/libavutil.so \
+ -DFFMPEG_swscale_LIBRARY=/usr/lib/ffmpeg-compat/libswscale.so"
+
+ # enable when http://paraview.org/Bug/view.php?id=12852 gets fixed:
+ #-DCMAKE_SKIP_RPATH:BOOL=YES \
+ cmake \
+ -DBUILD_SHARED_LIBS:BOOL=ON \
+ -DBUILD_TESTING:BOOL=OFF \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_C_COMPILER=mpicc \
+ -DCMAKE_CXX_COMPILER=mpicxx \
+ -DCMAKE_INSTALL_PREFIX:PATH=/usr \
+ -DCMAKE_VERBOSE_MAKEFILE:BOOL=OFF \
+ -DPARAVIEW_ENABLE_FFMPEG:BOOL=ON \
+ -DPARAVIEW_ENABLE_PYTHON:BOOL=ON \
+ -DPARAVIEW_USE_MPI:BOOL=ON \
+ -DPARAVIEW_USE_VISITBRIDGE:BOOL=ON \
+ -DQT_HELP_GENERATOR:FILEPATH=/usr/lib/qt4/bin/qhelpgenerator \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ -DVISIT_BUILD_READER_CGNS:BOOL=ON \
+ -DPARAVIEW_BUILD_PLUGIN_MantaView:BOOL=ON \
+ -DMANTA_BUILD:PATH=/usr \
+ -DMANTA_SOURCE:PATH=/usr/include \
+ ${cmake_system_flags} \
+ ${cmake_system_python_flags} \
+ ${ffmpeg_compat_flags} \
+ ../ParaView-v${pkgver}-source
+
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+
+ make DESTDIR="${pkgdir}" install
+
+ #Install license
+ install -Dm644 "${srcdir}/ParaView-v${pkgver}-source/License_v1.2.txt" "${pkgdir}/usr/share/licenses/paraview/LICENSE"
+
+ #Install desktop shortcuts
+ install -Dm644 "${srcdir}/paraview.png" "${pkgdir}/usr/share/pixmaps/paraview.png"
+ desktop-file-install --dir="${pkgdir}"/usr/share/applications "${srcdir}/paraview.desktop"
+}
diff --git a/paraview.desktop b/paraview.desktop
new file mode 100644
index 000000000000..40d907b6b4dc
--- /dev/null
+++ b/paraview.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=ParaView
+GenericName=Data Viewer
+Comment=ParaView allows visualization of large data sets
+Type=Application
+Terminal=false
+Icon=paraview
+Categories=Graphics;
+Exec=/usr/bin/paraview
diff --git a/paraview.png b/paraview.png
new file mode 100644
index 000000000000..6e39f3d4f7f9
--- /dev/null
+++ b/paraview.png
Binary files differ