summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichele Mocciola2016-05-13 22:49:18 +0200
committerMichele Mocciola2016-05-13 22:49:18 +0200
commitc716c9edd6e8c191eea241132fff9afb90fb00a9 (patch)
treedbc550dda06fb9ff586ac7d98335684733a360d2
parenteb66acd7d80bd0a396dbfe0483d2fb7bca170452 (diff)
downloadaur-c716c9edd6e8c191eea241132fff9afb90fb00a9.tar.gz
Updated to gcc-6 and ffmpeg-3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD43
-rw-r--r--ffmpeg-3.patch61
-rw-r--r--gcc6.patch19
4 files changed, 123 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dbe5f095e61..711c731eb6d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Fri May 13 20:48:40 UTC 2016
pkgbase = paraview-salome
pkgdesc = Parallel Visualization Application using VTK - This version is built to be linked against salome modules
pkgver = 4.2.0
- pkgrel = 1
+ pkgrel = 3
url = http://www.paraview.org
arch = i686
arch = x86_64
@@ -12,11 +14,11 @@ pkgbase = paraview-salome
makedepends = doxygen
depends = qtwebkit
depends = python2
- depends = ffmpeg-compat
+ depends = ffmpeg
depends = boost
depends = expat
depends = freetype2
- depends = hdf5
+ depends = hdf5-1.8
depends = libjpeg
depends = libxml2
depends = libtheora
@@ -33,6 +35,8 @@ pkgbase = paraview-salome
source = paraview-salome.desktop
source = uint.patch
source = gcc49.patch
+ source = gcc6.patch
+ source = ffmpeg-3.patch
source = ParaView-4.2.0.patch
source = surface_lic.png
md5sums = 77cf0e3804eb7bb91d2d94b10bd470f4
@@ -40,6 +44,8 @@ pkgbase = paraview-salome
md5sums = e3ba22be644f91da7018f429c3b7dd39
md5sums = e034fc590bd332175dcd6bf126f14d97
md5sums = 12fa547d0c79ea6a780279712574a5fe
+ md5sums = 951e035583c784986a3cd5e7e35519e2
+ md5sums = 58055ab1dd936cc233120b10f4e7eaa7
md5sums = 3e4c48633eb337c42653f51e6112f347
md5sums = 2f3f049a703224ca230eadffd5016455
diff --git a/PKGBUILD b/PKGBUILD
index 082915ba3da3..ef165e1c6d80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,31 +6,44 @@
pkgname=paraview-salome
pkgver=4.2.0
-pkgrel=1
+pkgrel=3
pkgdesc='Parallel Visualization Application using VTK - This version is built to be linked against salome modules'
arch=('i686' 'x86_64')
url='http://www.paraview.org'
license=('custom')
-depends=('qtwebkit' 'python2' 'ffmpeg-compat' 'boost' 'expat' 'freetype2' 'hdf5' 'libjpeg' 'libxml2' 'libtheora' 'libpng' 'libtiff' 'zlib' 'protobuf')
+depends=('qtwebkit' 'python2' 'ffmpeg' 'boost' 'expat' 'freetype2' 'hdf5-1.8' 'libjpeg' 'libxml2' 'libtheora' 'libpng' 'libtiff' 'zlib' 'protobuf')
makedepends=('cmake' 'mesa' 'eigen3' 'doxygen')
optdepends=('python2-matplotlib: Needed to support equation rendering using MathText markup language' 'python2-numpy: Needed for using some filters such as "Python Calculator"')
-source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${pkgver}-source.tar.gz" "${pkgname}.png" "${pkgname}.desktop" "uint.patch" "gcc49.patch" "ParaView-4.2.0.patch" "surface_lic.png" )
+source=("http://paraview.org/files/v${pkgver:0:3}/ParaView-v${pkgver}-source.tar.gz" "${pkgname}.png" "${pkgname}.desktop" "uint.patch" "gcc49.patch" "gcc6.patch" "ffmpeg-3.patch" "ParaView-4.2.0.patch" "surface_lic.png" )
options=(staticlibs)
provides=("paraview=${pkgver}")
-# _installdir=/opt/paraview43
+# _installdir=/opt/${pkgname}
_installdir=/usr
prepare(){
+ cd "${srcdir}"
+
+ if [ -d build ]; then
+ rm -rf build
+ fi
+
cd "${srcdir}/ParaView-v${pkgver}-source"
# patch to solve gcc49 compatiblity
patch -Np1 -i "${srcdir}/gcc49.patch"
+
+ # patch for gcc6 compatibility
+ sed -i -e "s|345|3456|" {VTK/CMake/GenerateExportHeader.cmake,VTK/CMake/vtkCompilerExtras.cmake}
+ patch -Np1 -i "${srcdir}/gcc6.patch"
# patch to solve uint conversion to int
patch -Np1 -i "${srcdir}/uint.patch"
+ # patch to copile with ffmpeg-3
+ patch -Np1 -i "${srcdir}/ffmpeg-3.patch"
+
# patch from salome-platform
patch -Np1 -i "${srcdir}/ParaView-4.2.0.patch"
@@ -53,6 +66,7 @@ build() {
# cmake general settings
cmake_options+=" -DCMAKE_BUILD_TYPE:STRING=Release"
+ # cmake_options+=" -DCMAKE_CXX_STANDARD=98"
cmake_options+=" -DCMAKE_INSTALL_PREFIX=${_installdir}"
cmake_options+=" -DBUILD_SHARED_LIBS=ON"
cmake_options+=" -DBUILD_TESTING=OFF"
@@ -95,6 +109,15 @@ build() {
cmake_options+=" -DVTK_WRAP_TCL:BOOL=OFF"
fi
+ # force usage of hdf5-1.8
+ local hdf5dir="/opt/hdf5-1.8"
+ cmake_options+=" -DHDF5_C_COMPILER_EXECUTABLE=${hdf5dir}/bin/h5cc"
+ cmake_options+=" -DHDF5_C_INCLUDE_DIR=${hdf5dir}/include"
+ cmake_options+=" -DHDF5_DIFF_EXECUTABLE=${hdf5dir}/bin/h5diff"
+ cmake_options+=" -DHDF5_HL_INCLUDE_DIR=${hdf5dir}/include"
+ cmake_options+=" -DHDF5_hdf5_LIBRARY_RELEASE=${hdf5dir}/lib/libhdf5.so"
+ cmake_options+=" -DHDF5_hdf5_hl_LIBRARY_RELEASE=${hdf5dir}/lib/libhdf5_hl.so"
+
# Java settings
cmake_options+=" -DVTK_WRAP_JAVA:BOOL=OFF"
@@ -163,11 +186,11 @@ build() {
cmake_options+=" -DPARAVIEW_ENABLE_FFMPEG=ON"
# flags to use ffmpeg-compat instead of ffmpeg
- cmake_options+=" -DFFMPEG_INCLUDE_DIR=/usr/include/ffmpeg-compat"
- cmake_options+=" -DFFMPEG_avcodec_LIBRARY=/usr/lib/ffmpeg-compat/libavcodec.so"
- cmake_options+=" -DFFMPEG_avformat_LIBRARY=/usr/lib/ffmpeg-compat/libavformat.so"
- cmake_options+=" -DFFMPEG_avutil_LIBRARY=/usr/lib/ffmpeg-compat/libavutil.so"
- cmake_options+=" -DFFMPEG_swscale_LIBRARY=/usr/lib/ffmpeg-compat/libswscale.so"
+ # cmake_options+=" -DFFMPEG_INCLUDE_DIR=/usr/include/ffmpeg-compat"
+ # cmake_options+=" -DFFMPEG_avcodec_LIBRARY=/usr/lib/ffmpeg-compat/libavcodec.so"
+ # cmake_options+=" -DFFMPEG_avformat_LIBRARY=/usr/lib/ffmpeg-compat/libavformat.so"
+ # cmake_options+=" -DFFMPEG_avutil_LIBRARY=/usr/lib/ffmpeg-compat/libavutil.so"
+ # cmake_options+=" -DFFMPEG_swscale_LIBRARY=/usr/lib/ffmpeg-compat/libswscale.so"
# let's start
cmake -Wno-dev \
@@ -214,5 +237,7 @@ md5sums=('77cf0e3804eb7bb91d2d94b10bd470f4'
'e3ba22be644f91da7018f429c3b7dd39'
'e034fc590bd332175dcd6bf126f14d97'
'12fa547d0c79ea6a780279712574a5fe'
+ '951e035583c784986a3cd5e7e35519e2'
+ '58055ab1dd936cc233120b10f4e7eaa7'
'3e4c48633eb337c42653f51e6112f347'
'2f3f049a703224ca230eadffd5016455')
diff --git a/ffmpeg-3.patch b/ffmpeg-3.patch
new file mode 100644
index 000000000000..2ffdc6d013b6
--- /dev/null
+++ b/ffmpeg-3.patch
@@ -0,0 +1,61 @@
+diff -Naur ParaView-v4.2.0-source.orig/VTK/IO/FFMPEG/vtkFFMPEGWriter.cxx ParaView-v4.2.0-source/VTK/IO/FFMPEG/vtkFFMPEGWriter.cxx
+--- ParaView-v4.2.0-source.orig/VTK/IO/FFMPEG/vtkFFMPEGWriter.cxx 2016-05-13 11:21:34.322631568 +0200
++++ ParaView-v4.2.0-source/VTK/IO/FFMPEG/vtkFFMPEGWriter.cxx 2016-05-13 15:45:28.098994000 +0200
+@@ -189,11 +189,11 @@
+ c->height = this->Dim[1];
+ if (this->Writer->GetCompression())
+ {
+- c->pix_fmt = PIX_FMT_YUVJ422P;
++ c->pix_fmt = AV_PIX_FMT_YUVJ422P;
+ }
+ else
+ {
+- c->pix_fmt = PIX_FMT_BGR24;
++ c->pix_fmt = AV_PIX_FMT_BGR24;
+ }
+
+ //to do playback at actual recorded rate, this will need more work see also below
+@@ -272,13 +272,13 @@
+ #endif
+
+ //for the output of the writer's input...
+- this->rgbInput = avcodec_alloc_frame();
++ this->rgbInput = av_frame_alloc();
+ if (!this->rgbInput)
+ {
+ vtkGenericWarningMacro (<< "Could not make rgbInput avframe." );
+ return 0;
+ }
+- int RGBsize = avpicture_get_size(PIX_FMT_RGB24, c->width, c->height);
++ int RGBsize = avpicture_get_size(AV_PIX_FMT_RGB24, c->width, c->height);
+ unsigned char *rgb = new unsigned char[RGBsize];
+ if (!rgb)
+ {
+@@ -286,10 +286,10 @@
+ return 0;
+ }
+ //The rgb buffer should get deleted when this->rgbInput is.
+- avpicture_fill((AVPicture *)this->rgbInput, rgb, PIX_FMT_RGB24, c->width, c->height);
++ avpicture_fill((AVPicture *)this->rgbInput, rgb, AV_PIX_FMT_RGB24, c->width, c->height);
+
+ //and for the output to the codec's input.
+- this->yuvOutput = avcodec_alloc_frame();
++ this->yuvOutput = av_frame_alloc();
+ if (!this->yuvOutput)
+ {
+ vtkGenericWarningMacro (<< "Could not make yuvOutput avframe." );
+@@ -347,12 +347,12 @@
+ //convert that to YUV for input to the codec
+ #ifdef VTK_FFMPEG_HAS_IMG_CONVERT
+ img_convert((AVPicture *)this->yuvOutput, cc->pix_fmt,
+- (AVPicture *)this->rgbInput, PIX_FMT_RGB24,
++ (AVPicture *)this->rgbInput, AV_PIX_FMT_RGB24,
+ cc->width, cc->height);
+ #else
+ //convert that to YUV for input to the codec
+ SwsContext* convert_ctx = sws_getContext(
+- cc->width, cc->height, PIX_FMT_RGB24,
++ cc->width, cc->height, AV_PIX_FMT_RGB24,
+ cc->width, cc->height, cc->pix_fmt,
+ SWS_BICUBIC, NULL, NULL, NULL);
+
diff --git a/gcc6.patch b/gcc6.patch
new file mode 100644
index 000000000000..4a686fda930a
--- /dev/null
+++ b/gcc6.patch
@@ -0,0 +1,19 @@
+diff -Naur ParaView-v4.2.0-source.orig/Plugins/PointSprite/Qvis/VolumeAttributes.cpp ParaView-v4.2.0-source/Plugins/PointSprite/Qvis/VolumeAttributes.cpp
+--- ParaView-v4.2.0-source.orig/Plugins/PointSprite/Qvis/VolumeAttributes.cpp 2016-05-13 11:21:34.149298238 +0200
++++ ParaView-v4.2.0-source/Plugins/PointSprite/Qvis/VolumeAttributes.cpp 2016-05-13 19:24:03.332076000 +0200
+@@ -39,6 +39,7 @@
+ #include <DataNode.h>
+ #include <ColorControlPoint.h>
+ #include <GaussianControlPoint.h>
++#include <cmath>
+
+ namespace pointsprite {
+ //
+@@ -1825,7 +1826,6 @@
+ // Made the method const.
+ //
+ // ****************************************************************************
+-#include <math.h>
+ void
+ VolumeAttributes::GetGaussianOpacities(unsigned char *alphas) const
+ {