summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEtienne Perot2019-05-27 16:43:40 -0700
committerEtienne Perot2019-05-27 16:43:40 -0700
commitb32084bfb8c65d8afbdc3369f041d0211f877cf5 (patch)
tree6740ab004ba3a787129900f0b92f0b15d8bea114
parent3051046296e4f6d1e87980b8fa4749b57ecb4449 (diff)
downloadaur-b32084bfb8c65d8afbdc3369f041d0211f877cf5.tar.gz
Update GPG invocation in PKGBUILD.
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51d741b89083..2cb3277f2641 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Etienne Perot <etienne at perot dot me>
pkgname=parcimonie-sh-git
-pkgver=72.03713bb
+pkgver=73.551999c
pkgrel=1
pkgdesc='Bash reimplementation of parcimonie - Refresh your GnuPG keyring without disclosing your whole contact list to the world'
arch=('any')
@@ -27,7 +27,7 @@ check() {
mkdir -p "$GNUPGHOME"
chmod 700 "$GNUPGHOME"
gpg --import < "${srcdir}/pgp-key"
- gpgKeyId="$(gpg --batch --with-colons < "${srcdir}/pgp-key" | grep '^sub:' | head -1 | cut -d ':' -f 5)"
+ gpgKeyId="$(gpg --show-key --batch --with-colons < "$srcdir/pgp-key" | grep '^sub:' | head -1 | cut -d ':' -f 5)"
git log --max-count=1 --pretty="format:%H,%G?,%GK" HEAD | grep -q ",[GU],${gpgKeyId}\$"
returnValue="$?"
if [ "$returnValue" -eq 0 ]; then