summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Hofer2015-06-20 16:40:07 +0200
committerLaurent Hofer2015-06-20 16:40:07 +0200
commit6ffa4674ae0fdc6bbf0725261aaf7bb5b3a47a46 (patch)
tree15193268146de3bad6f558f4e5d5cda5bf8bb403
downloadaur-6ffa4674ae0fdc6bbf0725261aaf7bb5b3a47a46.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f9b74cf398b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pari25
+ pkgdesc = Computer algebra system designed for fast computations in number theory
+ pkgver = 2.5.5
+ pkgrel = 2
+ url = http://pari.math.u-bordeaux.fr/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = perl
+ makedepends = texlive-core
+ depends = gmp
+ depends = libx11
+ optdepends = perl: gphelp, tex2mail
+ provides = pari
+ conflicts = pari
+ source = http://pari.math.u-bordeaux.fr/pub/pari/unix/OLD/2.5/pari-2.5.5.tar.gz
+ sha1sums = 77637f935ee4a3b78e7015cef00146bd2f7e96bc
+
+pkgname = pari25
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98bef3ec7fc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Maintainer: Laurent Hofer <laurenth at laurenth dot net>
+
+pkgname=pari25
+_pkgname=pari
+pkgver=2.5.5
+pkgrel=2
+pkgdesc='Computer algebra system designed for fast computations in number theory'
+url='http://pari.math.u-bordeaux.fr/'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('gmp' 'libx11')
+makedepends=('perl' 'texlive-core')
+optdepends=('perl: gphelp, tex2mail')
+conflicts=('pari')
+provides=('pari')
+source=("http://pari.math.u-bordeaux.fr/pub/pari/unix/OLD/2.5/${_pkgname}-${pkgver}.tar.gz")
+sha1sums=('77637f935ee4a3b78e7015cef00146bd2f7e96bc')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./Configure \
+ --prefix=/usr \
+ --with-readline \
+ --with-gmp \
+
+ make all
+}
+
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make bench
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ ln -sf gp.1.gz "${pkgdir}"/usr/share/man/man1/pari.1
+}