summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer kel2016-02-22 00:42:21 +0800
committerquininer kel2016-02-22 00:42:21 +0800
commit4952bea6e564663049f3e6b78a9b1a362d269442 (patch)
tree03446c82dcccb31912033a72930c87f61d7caa75
parentca8cb99f818eaa7088195196b5c08896300370cc (diff)
downloadaur-4952bea6e564663049f3e6b78a9b1a362d269442.tar.gz
fix ctrlc
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--fix-ctrlc.patch12
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b6fe19dc3e09..a90a70181ac3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Feb 19 11:17:00 UTC 2016
+# Sun Feb 21 16:42:05 UTC 2016
pkgbase = parity-git
pkgdesc = Fast, light, robust Ethereum implementation
- pkgver = 0.9.99.2138
+ pkgver = 0.9.99.2244
pkgrel = 1
url = https://github.com/ethcore/parity
arch = i686
@@ -17,8 +17,10 @@ pkgbase = parity-git
conflicts = parity
source = git://github.com/ethcore/parity.git
source = fix-heapsize.patch
+ source = fix-ctrlc.patch
sha256sums = SKIP
sha256sums = 3b2f97b2f7905580a3402be36acdff8f61fc248d0c1a0d7831742e2913f81c73
+ sha256sums = 203ef0e968a0eb46c6b2cde37f291d9f4584d615a9c51fd6e31804ae7dce5e30
pkgname = parity-git
diff --git a/PKGBUILD b/PKGBUILD
index 7c16a18ca510..12de4ad50ce3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@ pkgname=parity-git
_pkgname=parity
pkgdesc="Fast, light, robust Ethereum implementation"
pkgrel=1
-pkgver=0.9.99.2138
+pkgver=0.9.99.2244
arch=('i686' 'x86_64')
conflicts=("parity")
provides=("parity")
@@ -10,8 +10,12 @@ url="https://github.com/ethcore/parity"
license=('AGPL-3.0')
depends=('rocksdb')
makedepends=('rust' 'cargo' 'git' 'python-pytoml')
-source=('git://github.com/ethcore/parity.git' 'fix-heapsize.patch')
-sha256sums=('SKIP' '3b2f97b2f7905580a3402be36acdff8f61fc248d0c1a0d7831742e2913f81c73')
+source=('git://github.com/ethcore/parity.git' 'fix-heapsize.patch' 'fix-ctrlc.patch')
+sha256sums=(
+ 'SKIP'
+ '3b2f97b2f7905580a3402be36acdff8f61fc248d0c1a0d7831742e2913f81c73'
+ '203ef0e968a0eb46c6b2cde37f291d9f4584d615a9c51fd6e31804ae7dce5e30'
+)
pkgver() {
cd $_pkgname
@@ -20,6 +24,7 @@ pkgver() {
build() {
cd $_pkgname
+ patch ./Cargo.toml <../fix-ctrlc.patch
patch ./util/Cargo.toml <../fix-heapsize.patch
cargo update
cargo build --release
diff --git a/fix-ctrlc.patch b/fix-ctrlc.patch
new file mode 100644
index 000000000000..e8cb16b396ad
--- /dev/null
+++ b/fix-ctrlc.patch
@@ -0,0 +1,12 @@
+diff --git a/Cargo.toml b/Cargo.toml
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -10,7 +10,7 @@ log = "0.3"
+ env_logger = "0.3"
+ rustc-serialize = "0.3"
+ docopt = "0.6"
+-ctrlc = { git = "https://github.com/tomusdrw/rust-ctrlc.git" }
++ctrlc = { git = "https://github.com/quininer/rust-ctrlc.git", branch = "parity" }
+ clippy = { version = "0.0.42", optional = true }
+ ethcore-util = { path = "util" }
+ ethcore = { path = "ethcore" }