summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer kel2016-02-19 19:17:11 +0800
committerquininer kel2016-02-19 19:17:11 +0800
commitca8cb99f818eaa7088195196b5c08896300370cc (patch)
tree07442af9c3fa88169c3619e572276caa8b552ed6
parent5aa2dcca26c48216e022a16e3e188260321dc7d7 (diff)
downloadaur-ca8cb99f818eaa7088195196b5c08896300370cc.tar.gz
fix nightly
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
-rw-r--r--fix-heapsize.patch12
3 files changed, 22 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01566f5401dc..b6fe19dc3e09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
# Generated by mksrcinfo v8
-# Fri Feb 19 08:00:02 UTC 2016
+# Fri Feb 19 11:17:00 UTC 2016
pkgbase = parity-git
pkgdesc = Fast, light, robust Ethereum implementation
- pkgver = 0.9.99.2102
+ pkgver = 0.9.99.2138
pkgrel = 1
url = https://github.com/ethcore/parity
arch = i686
arch = x86_64
license = AGPL-3.0
- makedepends = rust>=1.7
- makedepends = rust<1.8
+ makedepends = rust
makedepends = cargo
makedepends = git
makedepends = python-pytoml
@@ -17,7 +16,9 @@ pkgbase = parity-git
provides = parity
conflicts = parity
source = git://github.com/ethcore/parity.git
+ source = fix-heapsize.patch
sha256sums = SKIP
+ sha256sums = 3b2f97b2f7905580a3402be36acdff8f61fc248d0c1a0d7831742e2913f81c73
pkgname = parity-git
diff --git a/PKGBUILD b/PKGBUILD
index 5a1a325c3cf0..7c16a18ca510 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,16 +2,16 @@ pkgname=parity-git
_pkgname=parity
pkgdesc="Fast, light, robust Ethereum implementation"
pkgrel=1
-pkgver=0.9.99.2102
+pkgver=0.9.99.2138
arch=('i686' 'x86_64')
conflicts=("parity")
provides=("parity")
url="https://github.com/ethcore/parity"
license=('AGPL-3.0')
depends=('rocksdb')
-makedepends=('rust>=1.7' 'rust<1.8' 'cargo' 'git' 'python-pytoml')
-source=('git://github.com/ethcore/parity.git')
-sha256sums=('SKIP')
+makedepends=('rust' 'cargo' 'git' 'python-pytoml')
+source=('git://github.com/ethcore/parity.git' 'fix-heapsize.patch')
+sha256sums=('SKIP' '3b2f97b2f7905580a3402be36acdff8f61fc248d0c1a0d7831742e2913f81c73')
pkgver() {
cd $_pkgname
@@ -20,6 +20,7 @@ pkgver() {
build() {
cd $_pkgname
+ patch ./util/Cargo.toml <../fix-heapsize.patch
cargo update
cargo build --release
}
diff --git a/fix-heapsize.patch b/fix-heapsize.patch
new file mode 100644
index 000000000000..a63d93f4f2d7
--- /dev/null
+++ b/fix-heapsize.patch
@@ -0,0 +1,12 @@
+diff --git a/Cargo.toml b/Cargo.toml
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -20,7 +20,7 @@ lazy_static = "0.1"
+ eth-secp256k1 = { git = "https://github.com/arkpar/rust-secp256k1.git" }
+ rust-crypto = "0.2.34"
+ elastic-array = "0.4"
+-heapsize = "0.3"
++heapsize = { git = "https://github.com/NikVolf/heapsize.git" }
+ itertools = "0.4"
+ crossbeam = "0.2"
+ slab = { git = "https://github.com/arkpar/slab.git" }