summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Sanches2022-01-21 23:22:20 -0300
committerGabriel Sanches2022-01-21 23:22:20 -0300
commit8c85258a7f2278564ac8381a360e3673bfbdd033 (patch)
tree32af14363fcc4f924e41084817759134187f0848
downloadaur-8c85258a7f2278564ac8381a360e3673bfbdd033.tar.gz
Publish Park v0.1.2
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1d84daacf53e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = park
+ pkgdesc = Configuration-based dotfiles manager
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://gitlab.com/gbrlsnchs/park
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = cargo
+ optdepends = gettext: contains envsubst, which can be used in configs to resolve environment variables
+ source = https://gitlab.com/gbrlsnchs/park/-/archive/v0.1.2/park-v0.1.2.tar.gz
+ sha256sums = 5ea22dccb489c84123c2a45fb1c9617da785f1541e01a334e12b51a343381de3
+
+pkgname = park
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..959218e2f32a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Vasia Novikov <n1dr+cmarchlinux@yaaandex.com> (replace "aaa" with "a")
+pkgname=park
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Configuration-based dotfiles manager"
+url="https://gitlab.com/gbrlsnchs/park"
+source=("https://gitlab.com/gbrlsnchs/park/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+arch=("x86_64" "i686")
+license=("MIT")
+
+makedepends=("cargo")
+optdepends=(
+ "gettext: contains envsubst, which can be used in configs to resolve environment variables"
+)
+
+sha256sums=("5ea22dccb489c84123c2a45fb1c9617da785f1541e01a334e12b51a343381de3")
+
+build () {
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+
+ cargo build --release
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+ install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ install -Dm644 "target/completions/${pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${pkgname}.bash"
+ install -Dm644 "target/completions/${pkgname}.fish" "${pkgdir}/usr/share/fish/completions/${pkgname}.fish"
+ install -Dm644 "target/completions/_${pkgname}" "${pkgdir}/usr/share/zsh/functions/Completion/Linux/_${pkgname}"
+}